summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmadeusz Żołnowski <aidecoe@gentoo.org>2017-03-26 22:15:25 +0100
committerAmadeusz Żołnowski <aidecoe@gentoo.org>2017-03-29 22:37:22 +0100
commit2f800d840422c74eace605ff32d8233b39820d39 (patch)
tree75e8447462ff52c2a206f8403cf27f8af93e4a9a /dev-erlang/goldrush/goldrush-0.1.9.ebuild
parentdev-erlang/jiffy: Bump version (diff)
downloadgentoo-2f800d840422c74eace605ff32d8233b39820d39.tar.gz
gentoo-2f800d840422c74eace605ff32d8233b39820d39.tar.bz2
gentoo-2f800d840422c74eace605ff32d8233b39820d39.zip
dev-erlang/goldrush: Bump version
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-erlang/goldrush/goldrush-0.1.9.ebuild')
-rw-r--r--dev-erlang/goldrush/goldrush-0.1.9.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-erlang/goldrush/goldrush-0.1.9.ebuild b/dev-erlang/goldrush/goldrush-0.1.9.ebuild
new file mode 100644
index 000000000000..901bcd88f016
--- /dev/null
+++ b/dev-erlang/goldrush/goldrush-0.1.9.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit rebar
+
+DESCRIPTION="Small Erlang app that provides fast event stream processing"
+HOMEPAGE="https://github.com/DeadZen/goldrush"
+SRC_URI="https://github.com/DeadZen/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~sparc ~x86"
+
+DEPEND=">=dev-lang/erlang-17.1"
+RDEPEND="${DEPEND}"
+
+DOCS=( README.org )
+
+src_prepare() {
+ rebar_src_prepare
+ # 'priv' directory contains only edoc.css, but doc isn't going to be built.
+ rm -r "${S}/priv" || die
+}