summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno <hanno@gentoo.org>2019-09-18 13:19:07 +0200
committerHanno <hanno@gentoo.org>2019-09-18 13:19:07 +0200
commitd98f373551dd5a3c4e9ea6a88b4089c78de056be (patch)
tree8d92d00c4d3c4b256fd49d5f38bfd618168ae0d6 /dev-erlang/goldrush/goldrush-0.2.0.ebuild
parentwww-misc/monitorix: x86 stable wrt bug #694782 (diff)
downloadgentoo-d98f373551dd5a3c4e9ea6a88b4089c78de056be.tar.gz
gentoo-d98f373551dd5a3c4e9ea6a88b4089c78de056be.tar.bz2
gentoo-d98f373551dd5a3c4e9ea6a88b4089c78de056be.zip
dev-erlang/goldrush: Version bump.
From Vampik's overlay. Signed-off-by: Hanno Boeck <hanno@gentoo.org> Package-Manager: Portage-2.3.76, Repoman-2.3.17
Diffstat (limited to 'dev-erlang/goldrush/goldrush-0.2.0.ebuild')
-rw-r--r--dev-erlang/goldrush/goldrush-0.2.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-erlang/goldrush/goldrush-0.2.0.ebuild b/dev-erlang/goldrush/goldrush-0.2.0.ebuild
new file mode 100644
index 000000000000..69eb6fcdfe86
--- /dev/null
+++ b/dev-erlang/goldrush/goldrush-0.2.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit rebar
+
+DESCRIPTION="Small Erlang app that provides fast event stream processing"
+HOMEPAGE="https://github.com/DeadZen/goldrush"
+SRC_URI="https://github.com/DeadZen/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~sparc ~x86"
+
+DEPEND=">=dev-lang/erlang-17.1"
+RDEPEND="${DEPEND}"
+
+DOCS=( README.org )
+
+src_prepare() {
+ rebar_src_prepare
+ # 'priv' directory contains only edoc.css, but doc isn't going to be built.
+ rm -r "${S}/priv" || die
+}