summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2022-03-02 23:01:00 +0100
committerFlorian Schmaus <flow@gentoo.org>2022-03-02 23:04:41 +0100
commitdbd1fc42329593521f0920d32f166132720399d1 (patch)
treee329ef2ac0129a80f268d2a19bf8b5257aaffd9e /dev-erlang/jose/jose-1.11.2.ebuild
parentmedia-sound/abcm2ps: removed obsolete 8.14.12 (diff)
downloadgentoo-dbd1fc42329593521f0920d32f166132720399d1.tar.gz
gentoo-dbd1fc42329593521f0920d32f166132720399d1.tar.bz2
gentoo-dbd1fc42329593521f0920d32f166132720399d1.zip
dev-erlang/jose: add 1.11.2
Bug: https://bugs.gentoo.org/834322 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'dev-erlang/jose/jose-1.11.2.ebuild')
-rw-r--r--dev-erlang/jose/jose-1.11.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-erlang/jose/jose-1.11.2.ebuild b/dev-erlang/jose/jose-1.11.2.ebuild
new file mode 100644
index 000000000000..f1d8df750985
--- /dev/null
+++ b/dev-erlang/jose/jose-1.11.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit rebar
+
+DESCRIPTION="JSON Object Signing and Encryption (JOSE) for Erlang and Elixir"
+HOMEPAGE="https://github.com/potatosalad/erlang-jose"
+SRC_URI="https://github.com/potatosalad/erlang-jose/archive/${PV}.tar.gz
+ -> erlang-${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/erlang-19.0"
+RDEPEND="${DEPEND}"
+
+DOCS=( ALGORITHMS.md CHANGELOG.md README.md examples/KEY-GENERATION.md )
+
+# TODO: jose has test suite, but it require lots of dependencies. It may not be
+# TODO: urgent, but it would be nice to have those sooner or later.
+RESTRICT=test
+
+S="${WORKDIR}/erlang-${P}"