summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-07-17 00:52:30 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-07-17 00:54:36 +0200
commitc55d70f2f39a759c81554c0ee609cae389761c76 (patch)
tree9b62ea202196b4e676d860a15875335dcea78c7c /dev-games/newton/newton-3.14.ebuild
parentsys-apps/rng-tools: bump to 6.3.1 (diff)
downloadgentoo-c55d70f2f39a759c81554c0ee609cae389761c76.tar.gz
gentoo-c55d70f2f39a759c81554c0ee609cae389761c76.tar.bz2
gentoo-c55d70f2f39a759c81554c0ee609cae389761c76.zip
dev-games/newton: 3.14 version bump
Package-Manager: Portage-2.3.43, Repoman-2.3.10
Diffstat (limited to 'dev-games/newton/newton-3.14.ebuild')
-rw-r--r--dev-games/newton/newton-3.14.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-games/newton/newton-3.14.ebuild b/dev-games/newton/newton-3.14.ebuild
new file mode 100644
index 000000000000..e998f8cc5f0c
--- /dev/null
+++ b/dev-games/newton/newton-3.14.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils toolchain-funcs
+
+MY_P="${PN}-dynamics-${P}"
+DESCRIPTION="Integrated solution for real time simulation of physics environments"
+HOMEPAGE="http://newtondynamics.com/forum/newton.php"
+SRC_URI="https://github.com/MADEAPPS/newton-dynamics/archive/${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND=""
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ cmake-utils_src_prepare
+ sed -i -e '/packages/d' CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_PREFIX=/usr/
+ -DNEWTON_DEMOS_SANDBOX=OFF
+ -DCMAKE_VERBOSE_MAKEFILE=ON
+ )
+ cmake-utils_src_configure
+}