summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/cipher-rc4
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/cipher-rc4')
-rw-r--r--dev-haskell/cipher-rc4/Manifest2
-rw-r--r--dev-haskell/cipher-rc4/cipher-rc4-0.1.2.ebuild27
-rw-r--r--dev-haskell/cipher-rc4/cipher-rc4-0.1.4.ebuild31
-rw-r--r--dev-haskell/cipher-rc4/metadata.xml11
4 files changed, 71 insertions, 0 deletions
diff --git a/dev-haskell/cipher-rc4/Manifest b/dev-haskell/cipher-rc4/Manifest
new file mode 100644
index 000000000000..e15823db71b1
--- /dev/null
+++ b/dev-haskell/cipher-rc4/Manifest
@@ -0,0 +1,2 @@
+DIST cipher-rc4-0.1.2.tar.gz 4576 SHA256 61b908f643cb123788c42e92e7c68fc376d6b094520f00cd10180e7874c5d95b SHA512 187f1f2e65a12fe6adba7cd979a3d4432325c908c745f79e6383f8a2e1b816078c899d538d211d2540e505b5bd6161e43dd4ed24a7b77e67a5b4bc387e8cd856 WHIRLPOOL f1e0c825464447b584263fa53e9474127791cf816ca9cfa5651fbd05eb58f5fb6b2cda0e5469a3fbd4f04a327de46787eeef949ae48f31c46b68df3c6f51786d
+DIST cipher-rc4-0.1.4.tar.gz 4315 SHA256 c67e731bc9e7f3882e33609c3d9ec97b4e9bbd2f95cd882926acfb621970384d SHA512 68415b4327371b4ea6fec9064f76c3a3372e223c3c717ee066941823cbbcdc50a7cd02c3fa7268dce4128e7b088e8a88012dd8478126d3f9d6a4e5b99f990d95 WHIRLPOOL 9f4681e3a3092d63432d8b0165eff8f7db6a06c4a24517a7a4e0a48ed5f963e38eed4e92cf45b3c436ed77408076b574ae201193bebdd556fb8bab21fb04c4d1
diff --git a/dev-haskell/cipher-rc4/cipher-rc4-0.1.2.ebuild b/dev-haskell/cipher-rc4/cipher-rc4-0.1.2.ebuild
new file mode 100644
index 000000000000..5aafd2d5d0ad
--- /dev/null
+++ b/dev-haskell/cipher-rc4/cipher-rc4-0.1.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Fast RC4 cipher implementation"
+HOMEPAGE="http://github.com/vincenthz/hs-cipher-rc4"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ test? ( >=dev-haskell/quickcheck-2
+ >=dev-haskell/test-framework-0.3.3
+ >=dev-haskell/test-framework-quickcheck2-0.2.9
+ )
+ >=dev-haskell/cabal-1.8"
diff --git a/dev-haskell/cipher-rc4/cipher-rc4-0.1.4.ebuild b/dev-haskell/cipher-rc4/cipher-rc4-0.1.4.ebuild
new file mode 100644
index 000000000000..01ebfdfb6353
--- /dev/null
+++ b/dev-haskell/cipher-rc4/cipher-rc4-0.1.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Fast RC4 cipher implementation"
+HOMEPAGE="http://github.com/vincenthz/hs-cipher-rc4"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="dev-haskell/byteable:=[profile?]
+ >=dev-haskell/crypto-cipher-types-0.0.5:=[profile?] <dev-haskell/crypto-cipher-types-0.1:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/crypto-cipher-tests-0.0.7
+ >=dev-haskell/quickcheck-2
+ >=dev-haskell/test-framework-0.3.3
+ >=dev-haskell/test-framework-quickcheck2-0.2.9 )
+"
diff --git a/dev-haskell/cipher-rc4/metadata.xml b/dev-haskell/cipher-rc4/metadata.xml
new file mode 100644
index 000000000000..ce95c167e672
--- /dev/null
+++ b/dev-haskell/cipher-rc4/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ Fast RC4 cipher implementation
+ </longdescription>
+ <upstream>
+ <remote-id type="github">vincenthz/hs-cipher-rc4</remote-id>
+ </upstream>
+</pkgmetadata>