summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/citeproc-hs
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/citeproc-hs')
-rw-r--r--dev-haskell/citeproc-hs/Manifest2
-rw-r--r--dev-haskell/citeproc-hs/citeproc-hs-0.3.10.ebuild52
-rw-r--r--dev-haskell/citeproc-hs/citeproc-hs-0.3.9.ebuild49
-rw-r--r--dev-haskell/citeproc-hs/files/citeproc-hs-0.3.10-ghc-7.10.patch28
-rw-r--r--dev-haskell/citeproc-hs/metadata.xml23
5 files changed, 154 insertions, 0 deletions
diff --git a/dev-haskell/citeproc-hs/Manifest b/dev-haskell/citeproc-hs/Manifest
new file mode 100644
index 000000000000..08dff54387e2
--- /dev/null
+++ b/dev-haskell/citeproc-hs/Manifest
@@ -0,0 +1,2 @@
+DIST citeproc-hs-0.3.10.tar.gz 115588 SHA256 1928db4f4c00f6722281f25171fc58412ec74c5e42adfc901a33a20dd10e65b9 SHA512 961c97fb82a0d497946695ef71dcbf0072dd9522a0f3b8e44975348b9ccf3ee703e2923408b3c3f1c58de04665418f54b95773865ed9cb16ad31a548a18b8b6f WHIRLPOOL 9b4d7d23aa43a06c43ff7600f92a03b93f7f0b44fcaaa6f846789633f993db44893c795014b2a13961839a341f8e6f9fd0ff8a72c670beb11c97443ea43222cf
+DIST citeproc-hs-0.3.9.tar.gz 114621 SHA256 4f6b7db9b731789f25e4faebce8ec2ea4a19a920aaad6951a5e8b23cd4187438 SHA512 54e84f458985a5605d3473a66af30351aa100ba3630c25976d4a17ffb980e364d514acbca168bc93b785cd7519b82dd228bbdddf1c5e0e4ad4f03e74b0ec254f WHIRLPOOL 1ed3bb9c07c469f225470498d3ebb1a8ae9650b0b36da6be949959d5c263ed08594fe012ab58ce8136a580fe9a4ec839b8f4554059129ae6e05301099f9da26f
diff --git a/dev-haskell/citeproc-hs/citeproc-hs-0.3.10.ebuild b/dev-haskell/citeproc-hs/citeproc-hs-0.3.10.ebuild
new file mode 100644
index 000000000000..fad67d36bdbc
--- /dev/null
+++ b/dev-haskell/citeproc-hs/citeproc-hs-0.3.10.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.3
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit base haskell-cabal
+
+DESCRIPTION="A Citation Style Language implementation in Haskell"
+HOMEPAGE="http://istitutocolli.org/repos/citeproc-hs/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+bibutils embed_data_files +hexpat +network +small_base unicode_collation"
+
+RDEPEND="dev-haskell/json:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ >=dev-haskell/pandoc-types-1.8:=[profile?] <dev-haskell/pandoc-types-1.13:=[profile?]
+ dev-haskell/parsec:=[profile?]
+ dev-haskell/syb:=[profile?]
+ dev-haskell/utf8-string:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ bibutils? ( >=dev-haskell/hs-bibutils-0.3:=[profile?] )
+ embed_data_files? ( dev-haskell/file-embed:=[profile?] )
+ hexpat? ( >=dev-haskell/hexpat-0.20.2:=[profile?] )
+ !hexpat? ( dev-haskell/xml:=[profile?] )
+ network? ( >=dev-haskell/http-4000.0.9:=[profile?]
+ >=dev-haskell/network-2.6:=[profile?]
+ >=dev-haskell/network-uri-2.6:=[profile?] )
+ unicode_collation? ( dev-haskell/text:=[profile?]
+ dev-haskell/text-icu:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
+
+PATCHES=("${FILESDIR}/${P}-ghc-7.10.patch")
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag bibutils bibutils) \
+ $(cabal_flag embed_data_files embed_data_files) \
+ $(cabal_flag hexpat hexpat) \
+ $(cabal_flag network network) \
+ $(cabal_flag small_base small_base) \
+ $(cabal_flag unicode_collation unicode_collation)
+}
diff --git a/dev-haskell/citeproc-hs/citeproc-hs-0.3.9.ebuild b/dev-haskell/citeproc-hs/citeproc-hs-0.3.9.ebuild
new file mode 100644
index 000000000000..40d415d9992c
--- /dev/null
+++ b/dev-haskell/citeproc-hs/citeproc-hs-0.3.9.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="A Citation Style Language implementation in Haskell"
+HOMEPAGE="http://gorgias.mine.nu/repos/citeproc-hs/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+bibutils embed_data_files +hexpat +network +small_base unicode_collation"
+
+RDEPEND="dev-haskell/json:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ >=dev-haskell/pandoc-types-1.8:=[profile?] <dev-haskell/pandoc-types-1.13:=[profile?]
+ dev-haskell/parsec:=[profile?]
+ dev-haskell/syb:=[profile?]
+ dev-haskell/utf8-string:=[profile?]
+ >=dev-lang/ghc-6.12.1:=
+ bibutils? ( >=dev-haskell/hs-bibutils-0.3:=[profile?] )
+ embed_data_files? ( dev-haskell/file-embed:=[profile?] )
+ hexpat? ( >=dev-haskell/hexpat-0.20.2:=[profile?] )
+ !hexpat? ( dev-haskell/xml:=[profile?] )
+ network? ( >=dev-haskell/http-4000.0.9:=[profile?]
+ >=dev-haskell/network-2:=[profile?] )
+ unicode_collation? ( dev-haskell/text:=[profile?]
+ dev-haskell/text-icu:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8.0.2
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag bibutils bibutils) \
+ $(cabal_flag embed_data_files embed_data_files) \
+ $(cabal_flag hexpat hexpat) \
+ $(cabal_flag network network) \
+ $(cabal_flag small_base small_base) \
+ $(cabal_flag unicode_collation unicode_collation)
+}
diff --git a/dev-haskell/citeproc-hs/files/citeproc-hs-0.3.10-ghc-7.10.patch b/dev-haskell/citeproc-hs/files/citeproc-hs-0.3.10-ghc-7.10.patch
new file mode 100644
index 000000000000..0ea6ce4e4313
--- /dev/null
+++ b/dev-haskell/citeproc-hs/files/citeproc-hs-0.3.10-ghc-7.10.patch
@@ -0,0 +1,28 @@
+--- citeproc-hs-0.3.10-orig/src/Text/CSL/Eval.hs 2015-03-17 21:32:38.000000000 +1100
++++ citeproc-hs-0.3.10/src/Text/CSL/Eval.hs 2015-04-04 11:18:45.018893632 +1100
+@@ -1,4 +1,5 @@
+ {-# LANGUAGE PatternGuards #-}
++{-# LANGUAGE FlexibleContexts #-}
+ -----------------------------------------------------------------------------
+ -- |
+ -- Module : Text.CSL.Eval
+--- citeproc-hs-0.3.10-orig/src/Text/CSL/Eval/Names.hs 2015-03-17 21:32:38.000000000 +1100
++++ citeproc-hs-0.3.10/src/Text/CSL/Eval/Names.hs 2015-04-04 11:18:28.823909497 +1100
+@@ -1,4 +1,5 @@
+ {-# LANGUAGE PatternGuards #-}
++{-# LANGUAGE FlexibleContexts #-}
+ -----------------------------------------------------------------------------
+ -- |
+ -- Module : Text.CSL.Eval.Names
+--- citeproc-hs-0.3.10-orig/src/Text/CSL/Test.hs 2015-03-17 21:32:38.000000000 +1100
++++ citeproc-hs-0.3.10/src/Text/CSL/Test.hs 2015-04-04 11:21:42.164719120 +1100
+@@ -29,7 +29,9 @@
+ import Data.Maybe (isJust)
+ import Data.Time
+ import System.Directory
++#if !MIN_VERSION_time(1,5,0)
+ import System.Locale
++#endif
+
+ import Text.ParserCombinators.Parsec
+
diff --git a/dev-haskell/citeproc-hs/metadata.xml b/dev-haskell/citeproc-hs/metadata.xml
new file mode 100644
index 000000000000..472d0b81d352
--- /dev/null
+++ b/dev-haskell/citeproc-hs/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <use>
+ <flag name="bibutils">use Chris Putnam's <pkg>app-text/bibutils</pkg></flag>
+ <flag name="embed_data_files">Embed locale files into the library (needed for windows packaging)</flag>
+ <flag name="network">use <pkg>dev-haskell/network</pkg> and <pkg>dev-haskell/http</pkg> to retrieve CSL file from URIs</flag>
+ <flag name="hexpat">use <pkg>dev-haskell/hexpat</pkg> instead of <pkg>dev-haskell/xml</pkg> for XML parsing</flag>
+ <flag name="small_base">Choose the new smaller, split-up base package.</flag>
+ <flag name="unicode_collation">Use Haskell bindings to the <pkg>dev-libs/icu</pkg></flag>
+ </use>
+ <longdescription>
+ citeproc-hs is a library for rendering
+ bibliographic reference citations into a variety
+ of styles using a macro language called Citation
+ Style Language (CSL). More details on CSL can be
+ found here:
+ &lt;http://citationstyles.org/&gt;.
+
+ For the API documentation please see &quot;Text.CSL&quot;.
+ </longdescription>
+</pkgmetadata>