summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2016-01-19 21:44:43 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2016-01-19 22:29:01 +0000
commit53d365a2f897a77b52b07516a7bc939e59c9a93e (patch)
treeca87bdf760c5964f349433757895e7ee6eceae19 /dev-haskell/cryptonite
parentdev-haskell/memory: bump up to 0.10 (diff)
downloadgentoo-53d365a2f897a77b52b07516a7bc939e59c9a93e.tar.gz
gentoo-53d365a2f897a77b52b07516a7bc939e59c9a93e.tar.bz2
gentoo-53d365a2f897a77b52b07516a7bc939e59c9a93e.zip
dev-haskell/cryptonite: new package, a depend of dev-haskell/x509-1.6
Cryptography Primitives sink for haskell. A next generation of naty dev-haskell/crypto-* packages. Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-haskell/cryptonite')
-rw-r--r--dev-haskell/cryptonite/Manifest2
-rw-r--r--dev-haskell/cryptonite/cryptonite-0.7.ebuild42
-rw-r--r--dev-haskell/cryptonite/cryptonite-0.8.ebuild42
-rw-r--r--dev-haskell/cryptonite/metadata.xml35
4 files changed, 121 insertions, 0 deletions
diff --git a/dev-haskell/cryptonite/Manifest b/dev-haskell/cryptonite/Manifest
new file mode 100644
index 000000000000..823cd1faaec2
--- /dev/null
+++ b/dev-haskell/cryptonite/Manifest
@@ -0,0 +1,2 @@
+DIST cryptonite-0.7.tar.gz 324734 SHA256 6cd4d9ff100b06a08ceac56eb12153633957797b309032a963cdf3841f92ecd9 SHA512 077b181b1563087c6c04816a36bfd2efd7a732f72b02e5277f3d987093954ca8e420814b547c7c985418e74e8c838a3c8381b4821f3ed6fa8412b63078fade0e WHIRLPOOL d360075fbe8209adce66a8fa7072830149dd9f471152171f5dcda051f5f770876e543ecaa37ec9c5a65ad54afbf8cac47a8aba389537da0f75bdfac00aa8c66e
+DIST cryptonite-0.8.tar.gz 325531 SHA256 6401745cab3b83e81b84c09336215f3f80f532b3cfd948c4c53e891aa9b69b07 SHA512 c393e7a93f8d4368ae9ee3130eb44cbc0a4937fdbe27bb918a8900716d9946bae39897717b1c2b3c2531ce69562df3d3260177fa76a6f90ee53ace206fe382a3 WHIRLPOOL 04f04041227e42be0fd78196f1b34debe3effb3587463671c94ff866760ecac0e7b2590c9ba28368f951b354fefb03358b2ec38d300938d99f837a57e25f9437
diff --git a/dev-haskell/cryptonite/cryptonite-0.7.ebuild b/dev-haskell/cryptonite/cryptonite-0.7.ebuild
new file mode 100644
index 000000000000..84facab7a44b
--- /dev/null
+++ b/dev-haskell/cryptonite/cryptonite-0.7.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Cryptography Primitives sink"
+HOMEPAGE="https://github.com/vincenthz/cryptonite"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+integer-gmp +support_aesni +support_deepseq support_pclmuldq +support_rdrand"
+
+RESTRICT=test # slow
+
+RDEPEND=">=dev-haskell/memory-0.8:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ test? ( dev-haskell/byteable
+ dev-haskell/tasty
+ dev-haskell/tasty-hunit
+ dev-haskell/tasty-kat
+ dev-haskell/tasty-quickcheck )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag integer-gmp integer-gmp) \
+ $(cabal_flag support_aesni support_aesni) \
+ $(cabal_flag support_deepseq support_deepseq) \
+ $(cabal_flag support_pclmuldq support_pclmuldq) \
+ $(cabal_flag support_rdrand support_rdrand)
+}
diff --git a/dev-haskell/cryptonite/cryptonite-0.8.ebuild b/dev-haskell/cryptonite/cryptonite-0.8.ebuild
new file mode 100644
index 000000000000..414a7acf5780
--- /dev/null
+++ b/dev-haskell/cryptonite/cryptonite-0.8.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Cryptography Primitives sink"
+HOMEPAGE="https://github.com/haskell-crypto/cryptonite"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+integer-gmp +support_aesni +support_deepseq support_pclmuldq +support_rdrand"
+
+RESTRICT=test # slow
+
+RDEPEND=">=dev-haskell/memory-0.8:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ test? ( dev-haskell/byteable
+ dev-haskell/tasty
+ dev-haskell/tasty-hunit
+ dev-haskell/tasty-kat
+ dev-haskell/tasty-quickcheck )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag integer-gmp integer-gmp) \
+ $(cabal_flag support_aesni support_aesni) \
+ $(cabal_flag support_deepseq support_deepseq) \
+ $(cabal_flag support_pclmuldq support_pclmuldq) \
+ $(cabal_flag support_rdrand support_rdrand)
+}
diff --git a/dev-haskell/cryptonite/metadata.xml b/dev-haskell/cryptonite/metadata.xml
new file mode 100644
index 000000000000..a0964926a0ff
--- /dev/null
+++ b/dev-haskell/cryptonite/metadata.xml
@@ -0,0 +1,35 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ A repository of cryptographic primitives.
+
+ * Symmetric ciphers: AES, DES, 3DES, Blowfish, Camellia, RC4, Salsa, ChaCha.
+
+ * Hash: SHA1, SHA2, SHA3, MD2, MD4, MD5, Kekkak, Skein, Ripemd, Tiger, Whirlpool
+
+ * MAC: HMAC, Poly1305
+
+ * Assymmetric crypto: DSA, RSA, DH, ECDH, ECDSA, ECC, Curve25519, Ed25519
+
+ * Key Derivation Function: PBKDF2, Scrypt
+
+ * Cryptographic Random generation: System Entropy, Deterministic Random Generator
+
+ * Data related: Anti-Forensic Information Splitter (AFIS)
+
+ If anything cryptographic related is missing from here, submit
+ a pull request to have it added. This package strive to be a
+ cryptographic kitchen sink that provides cryptography for everyone.
+
+ Evaluate the security related to your requirements before using.
+ </longdescription>
+ <use>
+ <flag name="support_aesni">allow compilation with AESNI on system and architecture that supports it</flag>
+ <flag name="support_rdrand">allow compilation with AESNI on system and architecture that supports it</flag>
+ <flag name="support_pclmuldq">Allow compilation with pclmuldq on architecture that supports it</flag>
+ <flag name="integer-gmp">Whether or not to use GMP for some functions</flag>
+ <flag name="support_deepseq">add deepseq instances for cryptographic types</flag>
+ </use>
+</pkgmetadata>