summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/glade
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/glade')
-rw-r--r--dev-haskell/glade/Manifest2
-rw-r--r--dev-haskell/glade/glade-0.12.1-r1.ebuild30
-rw-r--r--dev-haskell/glade/glade-0.12.1.ebuild27
-rw-r--r--dev-haskell/glade/glade-0.12.5.0-r1.ebuild32
-rw-r--r--dev-haskell/glade/glade-0.12.5.0-r2.ebuild36
-rw-r--r--dev-haskell/glade/metadata.xml14
6 files changed, 141 insertions, 0 deletions
diff --git a/dev-haskell/glade/Manifest b/dev-haskell/glade/Manifest
new file mode 100644
index 000000000000..9626be508065
--- /dev/null
+++ b/dev-haskell/glade/Manifest
@@ -0,0 +1,2 @@
+DIST glade-0.12.1.tar.gz 153938 SHA256 2025c44fbaada6463a99e3c5b39bdc8c9b846b59fe04194ec5dffd65be6c8f84 SHA512 82ac4a4cff6124eabce0744a5b8cefbae6609c9acb023fdeb0285eb9b7c84bc6b6aa09f43dacf1ba1b35f7a7e7b3f03f213869ee087d926002af5f0992b0a1ce WHIRLPOOL 5a3761fa2670269018115d9fd6abd244fec3196dd5416d80414dc385f976fabf970cfacc288d2a71288698bc379e28dc3916a6303b091e813a2bd8acc2fb9b3f
+DIST glade-0.12.5.0.tar.gz 152942 SHA256 79eea09019429ba552b49ae11cf287577937234bd54713aa82ecf3968b3f7435 SHA512 5ea6ac03e919b881b53649c340d23eacc4c7e7055d9425b581c38bbc08192ad65e009b9bf03e9f224cee69ee2301354b2e42f4c7c845349b2b34fcdf8994c865 WHIRLPOOL 0d3e313d7a9f9c079e3a47fb2995dc70163a31fe6ae26d99e9c637e5b9e6512c49d0e27ebd26492117f01cddf3b22b89cea9f837028171da050c1766a1a279da
diff --git a/dev-haskell/glade/glade-0.12.1-r1.ebuild b/dev-haskell/glade/glade-0.12.1-r1.ebuild
new file mode 100644
index 000000000000..55d0921cf2e5
--- /dev/null
+++ b/dev-haskell/glade/glade-0.12.1-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+GTK_MAJ_VER="2"
+
+#nocabaldep is for the fancy cabal-detection feature at build-time
+CABAL_FEATURES="lib profile haddock hoogle hscolour nocabaldep"
+inherit haskell-cabal
+
+DESCRIPTION="Binding to the glade library"
+HOMEPAGE="http://projects.haskell.org/gtk2hs/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="2/${PV}"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="=dev-haskell/glib-0.12*:0=[profile?]
+ =dev-haskell/gtk-0.12*:${GTK_MAJ_VER}=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+ gnome-base/libglade:2.0"
+DEPEND="${RDEPEND}
+ dev-haskell/gtk2hs-buildtools:0
+ virtual/pkgconfig"
diff --git a/dev-haskell/glade/glade-0.12.1.ebuild b/dev-haskell/glade/glade-0.12.1.ebuild
new file mode 100644
index 000000000000..44de6d41be97
--- /dev/null
+++ b/dev-haskell/glade/glade-0.12.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# ebuild generated by hackport 0.2.17.9999
+
+EAPI=4
+
+#nocabaldep is for the fancy cabal-detection feature at build-time
+CABAL_FEATURES="lib profile haddock hscolour hoogle nocabaldep"
+inherit haskell-cabal
+
+DESCRIPTION="Binding to the glade library"
+HOMEPAGE="http://projects.haskell.org/gtk2hs/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="2"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="=dev-haskell/glib-0.12*:0[profile?]
+ =dev-haskell/gtk-0.12*:2[profile?]
+ >=dev-lang/ghc-6.10.1
+ gnome-base/libglade:2.0"
+DEPEND="${RDEPEND}
+ dev-haskell/gtk2hs-buildtools:0"
diff --git a/dev-haskell/glade/glade-0.12.5.0-r1.ebuild b/dev-haskell/glade/glade-0.12.5.0-r1.ebuild
new file mode 100644
index 000000000000..65e0e3c478f4
--- /dev/null
+++ b/dev-haskell/glade/glade-0.12.5.0-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.5.9999
+
+GTK_MAJ_VER="2"
+
+#nocabaldep is for the fancy cabal-detection feature at build-time
+CABAL_FEATURES="lib profile haddock hoogle hscolour nocabaldep"
+inherit haskell-cabal
+
+DESCRIPTION="Binding to the glade library"
+HOMEPAGE="http://projects.haskell.org/gtk2hs/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="${GTK_MAJ_VER}/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/glib-0.12.5.0:0=[profile?] <dev-haskell/glib-0.13:0=[profile?]
+ >=dev-haskell/gtk-0.12.5.0:${GTK_MAJ_VER}=[profile?] <dev-haskell/gtk-0.13:${GTK_MAJ_VER}=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+ gnome-base/libglade:2.0
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/gtk2hs-buildtools-0.12.5.1-r1:0=
+ virtual/pkgconfig
+"
diff --git a/dev-haskell/glade/glade-0.12.5.0-r2.ebuild b/dev-haskell/glade/glade-0.12.5.0-r2.ebuild
new file mode 100644
index 000000000000..a4bff412c803
--- /dev/null
+++ b/dev-haskell/glade/glade-0.12.5.0-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.5.9999
+
+#nocabaldep is for the fancy cabal-detection feature at build-time
+CABAL_FEATURES="lib profile haddock hoogle hscolour nocabaldep"
+inherit haskell-cabal
+
+DESCRIPTION="Binding to the glade library"
+HOMEPAGE="http://projects.haskell.org/gtk2hs/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="2/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/glib-0.12.5.0:0=[profile?] <dev-haskell/glib-0.14:0=[profile?]
+ >=dev-haskell/gtk-0.12.5.0:2=[profile?] <dev-haskell/gtk-0.14:2=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+ gnome-base/libglade:2.0
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/gtk2hs-buildtools-0.12.5.1-r1:0=
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ cabal_chdeps \
+ 'glib >= 0.12.5.0 && < 0.13' 'glib >= 0.12.5.0 && < 0.14' \
+ 'gtk >= 0.12.5.0 && < 0.13' 'gtk >= 0.12.5.0 && < 0.14'
+}
diff --git a/dev-haskell/glade/metadata.xml b/dev-haskell/glade/metadata.xml
new file mode 100644
index 000000000000..5d0c4f356b42
--- /dev/null
+++ b/dev-haskell/glade/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ This library allows to load externally stored user interfaces into
+ programs. This allows alteration of the interface without recompilation
+ of the program.
+
+ Note that this functionality is now provided in gtk directly
+ (as of version 2.12 of the gtk+ C lib) by the
+ Graphics.UI.Gtk.Builder module.
+ </longdescription>
+</pkgmetadata>