summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-08-04 23:41:18 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-08-04 23:41:18 +0100
commit9a9398bb847bdf080bc04c46eb7bc072e00d1a98 (patch)
tree5a9af4a66a1fdcb7463cc15b664b90e50958cf60 /dev-haskell/language-dot/language-dot-0.1.1.ebuild
parentdev-haskell/language-css: tweak for ghc-8.8 (diff)
downloadgentoo-9a9398bb847bdf080bc04c46eb7bc072e00d1a98.tar.gz
gentoo-9a9398bb847bdf080bc04c46eb7bc072e00d1a98.tar.bz2
gentoo-9a9398bb847bdf080bc04c46eb7bc072e00d1a98.zip
dev-haskell/language-dot: bump up to 0.1.1
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/language-dot/language-dot-0.1.1.ebuild')
-rw-r--r--dev-haskell/language-dot/language-dot-0.1.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-haskell/language-dot/language-dot-0.1.1.ebuild b/dev-haskell/language-dot/language-dot-0.1.1.ebuild
new file mode 100644
index 000000000000..cdd922c51593
--- /dev/null
+++ b/dev-haskell/language-dot/language-dot-0.1.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.1
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="A library for the analysis and creation of Graphviz DOT files"
+HOMEPAGE="http://hackage.haskell.org/package/language-dot"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+executable"
+
+RDEPEND=">=dev-haskell/parsec-3:=[profile?] <dev-haskell/parsec-4:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ >=dev-haskell/mtl-1:=[profile?] <dev-haskell/mtl-3:=[profile?]
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag executable executable)
+}