summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Todaro <solpeth@posteo.org>2020-07-29 11:48:53 +1000
committerSergei Trofimovich <slyfox@gentoo.org>2020-08-01 09:00:12 +0100
commitceacf612785ee252fd5ace43efb02378c9f3939b (patch)
tree9938436b5fd6dbdf3af3081ac9faa4fa860e2224 /dev-haskell/parsers/parsers-0.12.10.ebuild
parentdev-haskell/charset: add package (diff)
downloadgentoo-ceacf612785ee252fd5ace43efb02378c9f3939b.tar.gz
gentoo-ceacf612785ee252fd5ace43efb02378c9f3939b.tar.bz2
gentoo-ceacf612785ee252fd5ace43efb02378c9f3939b.zip
dev-haskell/parsers: add package
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Jack Todaro <solpeth@posteo.org> Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/parsers/parsers-0.12.10.ebuild')
-rw-r--r--dev-haskell/parsers/parsers-0.12.10.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-haskell/parsers/parsers-0.12.10.ebuild b/dev-haskell/parsers/parsers-0.12.10.ebuild
new file mode 100644
index 000000000000..a262cb26304a
--- /dev/null
+++ b/dev-haskell/parsers/parsers-0.12.10.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Parsing combinators"
+HOMEPAGE="https://github.com/ekmett/parsers/"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+attoparsec +parsec"
+
+RDEPEND=">=dev-haskell/base-orphans-0.3:=[profile?] <dev-haskell/base-orphans-1:=[profile?]
+ >=dev-haskell/charset-0.3:=[profile?] <dev-haskell/charset-1:=[profile?]
+ >=dev-haskell/mtl-2.0.1:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
+ >=dev-haskell/scientific-0.3:=[profile?] <dev-haskell/scientific-0.4:=[profile?]
+ >=dev-haskell/semigroups-0.12:=[profile?] <dev-haskell/semigroups-1:=[profile?]
+ >=dev-haskell/text-0.10:=[profile?] <dev-haskell/text-1.3:=[profile?]
+ >=dev-haskell/unordered-containers-0.2:=[profile?] <dev-haskell/unordered-containers-0.3:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+ attoparsec? ( >=dev-haskell/attoparsec-0.12.1.4:=[profile?] <dev-haskell/attoparsec-0.14:=[profile?] )
+ parsec? ( >=dev-haskell/parsec-3.1:=[profile?] <dev-haskell/parsec-3.2:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+ test? ( dev-haskell/quickcheck
+ dev-haskell/quickcheck-instances )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag attoparsec attoparsec) \
+ $(cabal_flag parsec parsec)
+}