summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Todaro <solpeth@posteo.org>2022-07-30 14:20:51 +1000
committerSam James <sam@gentoo.org>2022-07-30 06:21:27 +0100
commitcce209fab98b046d6599bb61fe41ed1756b98146 (patch)
treeafb9af44dbb7f3dc497848eeee0d37d70fa6fa23 /dev-haskell/regex-compat-tdfa
parentdev-haskell/persistent-sqlite: drop 2.10.6.2 (diff)
downloadgentoo-cce209fab98b046d6599bb61fe41ed1756b98146.tar.gz
gentoo-cce209fab98b046d6599bb61fe41ed1756b98146.tar.bz2
gentoo-cce209fab98b046d6599bb61fe41ed1756b98146.zip
dev-haskell/regex-compat-tdfa: patch for ghc-9.0
Pulled from ::haskell. Closes: https://bugs.gentoo.org/860507 Signed-off-by: Jack Todaro <solpeth@posteo.org> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/regex-compat-tdfa')
-rw-r--r--dev-haskell/regex-compat-tdfa/files/regex-compat-tdfa-0.95.1.4-ghc-9.0.patch11
-rw-r--r--dev-haskell/regex-compat-tdfa/regex-compat-tdfa-0.95.1.4.ebuild6
2 files changed, 15 insertions, 2 deletions
diff --git a/dev-haskell/regex-compat-tdfa/files/regex-compat-tdfa-0.95.1.4-ghc-9.0.patch b/dev-haskell/regex-compat-tdfa/files/regex-compat-tdfa-0.95.1.4-ghc-9.0.patch
new file mode 100644
index 000000000000..78d0ceb93575
--- /dev/null
+++ b/dev-haskell/regex-compat-tdfa/files/regex-compat-tdfa-0.95.1.4-ghc-9.0.patch
@@ -0,0 +1,11 @@
+--- regex-compat-tdfa-0.95.1.4-orig/Text/Regex.hs 2021-06-25 10:08:26.670791461 +1000
++++ regex-compat-tdfa-0.95.1.4/Text/Regex.hs 2021-06-25 10:08:10.325737439 +1000
+@@ -139,7 +139,7 @@
+ splitRegex :: Regex -> String -> [String]
+ splitRegex _ [] = []
+ splitRegex delim strIn =
+- let matches = map (!0) (matchAll delim strIn)
++ let matches = map (! 0) (matchAll delim strIn)
+ go _i str [] = str : []
+ go i str ((off,len):rest) =
+ let i' = off+len
diff --git a/dev-haskell/regex-compat-tdfa/regex-compat-tdfa-0.95.1.4.ebuild b/dev-haskell/regex-compat-tdfa/regex-compat-tdfa-0.95.1.4.ebuild
index efe655a7cf3b..71c308c67193 100644
--- a/dev-haskell/regex-compat-tdfa/regex-compat-tdfa-0.95.1.4.ebuild
+++ b/dev-haskell/regex-compat-tdfa/regex-compat-tdfa-0.95.1.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -10,7 +10,7 @@ CABAL_FEATURES="lib profile haddock hoogle hscolour"
inherit haskell-cabal
DESCRIPTION="Unicode Support version of Text.Regex, using regex-tdfa"
-HOMEPAGE="http://hub.darcs.net/shelarcy/regex-compat-tdfa"
+HOMEPAGE="https://hub.darcs.net/shelarcy/regex-compat-tdfa"
SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="BSD"
@@ -26,6 +26,8 @@ DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.6
"
+PATCHES=( "${FILESDIR}"/${PN}-0.95.1.4-ghc-9.0.patch )
+
src_configure() {
haskell-cabal_src_configure \
--flag=newbase \