summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-02-11 23:17:41 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2020-02-11 23:19:08 +0000
commit673ef56dfdfb58380e6db2a2e217fe388bb813ad (patch)
treeba6d9542462c6ac9e861ad6df7dc02b32d59fdb7 /dev-haskell/stack-bin/stack-bin-2.1.3.ebuild
parentapp-misc/golly: use desktop/xdg-utils eclasses instead of gnome-2 (diff)
downloadgentoo-673ef56dfdfb58380e6db2a2e217fe388bb813ad.tar.gz
gentoo-673ef56dfdfb58380e6db2a2e217fe388bb813ad.tar.bz2
gentoo-673ef56dfdfb58380e6db2a2e217fe388bb813ad.zip
dev-haskell/stack-bin: bump up to 2.1.3
Reported-by: Dennis Schridde Bug: https://bugs.gentoo.org/682976 Package-Manager: Portage-2.3.88, Repoman-2.3.20 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/stack-bin/stack-bin-2.1.3.ebuild')
-rw-r--r--dev-haskell/stack-bin/stack-bin-2.1.3.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-haskell/stack-bin/stack-bin-2.1.3.ebuild b/dev-haskell/stack-bin/stack-bin-2.1.3.ebuild
new file mode 100644
index 000000000000..189deee5218e
--- /dev/null
+++ b/dev-haskell/stack-bin/stack-bin-2.1.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="The Haskell Tool Stack (Binary)"
+HOMEPAGE="https://github.com/commercialhaskell/stack"
+
+uri() {
+ echo "https://github.com/commercialhaskell/stack/releases/download/v${PV}/stack-${PV}-linux-$1.tar.gz"
+}
+
+SRC_URI="
+ arm? ( $(uri arm) )
+ arm64? ( $(uri aarch64) )
+ x86? ( $(uri i386) )
+ amd64? ( $(uri x86_64) )
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="symlink"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ sys-libs/zlib
+ dev-libs/gmp:0
+"
+RDEPEND+=" symlink? ( !dev-haskell/stack )"
+
+S=${WORKDIR}
+
+QA_PREBUILT="/usr/bin/stack-bin"
+QA_PRESTRIPPED="/usr/bin/stack-bin"
+
+src_prepare() {
+ default
+
+ mv stack-${PV}-*/doc doc || die
+ mv stack-${PV}-*/stack stack-bin || die
+}
+
+src_install() {
+ dodoc -r doc/*
+ dobin stack-bin
+ use symlink && dosym stack-bin /usr/bin/stack
+}