summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/stringprep
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/stringprep')
-rw-r--r--dev-haskell/stringprep/Manifest2
-rw-r--r--dev-haskell/stringprep/metadata.xml8
-rw-r--r--dev-haskell/stringprep/stringprep-0.1.5.ebuild26
-rw-r--r--dev-haskell/stringprep/stringprep-1.0.0.ebuild31
4 files changed, 67 insertions, 0 deletions
diff --git a/dev-haskell/stringprep/Manifest b/dev-haskell/stringprep/Manifest
new file mode 100644
index 000000000000..8f279fc06da2
--- /dev/null
+++ b/dev-haskell/stringprep/Manifest
@@ -0,0 +1,2 @@
+DIST stringprep-0.1.5.tar.gz 82062 SHA256 b7e259809bdec929a96be21be120fc3191aa771fef1c139f01fd8736515845a8 SHA512 7899905037927ae4c7d490f56fdf5a7a051daf39324adcb0f4d9a1ad35b06f05b914f3b706ff61c77f694b654e85db7866a7cfc5c8982ccfbbbe6224874a735e WHIRLPOOL 18910cc2ffe5f97f133b148131f7da855e53aa2f54ec941dee6665d488eb0ad653b19c06617d1c510a17552b0ad3ddb1b620a6567a1b1a9e3e5758d6ce1ff5dc
+DIST stringprep-1.0.0.tar.gz 17166 SHA256 60015e858428f1af2f6e2e3e725a2738d8bcedd8258c043b09a5dddbfe664441 SHA512 0b6fc990124ccf12fe9a604b0f27a5b99a3d3a5fab7e938390fa9130ed3713cf4a7a610c1ac3b9e8f6138eb7e06a94c23f6bd9be132d1350607fe5abd010ee33 WHIRLPOOL 9ff71bb5ef5bfb0cd05d7054e34f05b86e2b3c43e1ef9a8e0d067b70fb6c2779cd57d108a0efb5ae46340ad1b86f060f36e3c0a915490dbdb1f386d052be4d19
diff --git a/dev-haskell/stringprep/metadata.xml b/dev-haskell/stringprep/metadata.xml
new file mode 100644
index 000000000000..aa8f1bde64f3
--- /dev/null
+++ b/dev-haskell/stringprep/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ Implements the &quot;StringPrep&quot; algorithm
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/stringprep/stringprep-0.1.5.ebuild b/dev-haskell/stringprep/stringprep-0.1.5.ebuild
new file mode 100644
index 000000000000..e30be938c8cb
--- /dev/null
+++ b/dev-haskell/stringprep/stringprep-0.1.5.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Implements the "StringPrep" algorithm"
+HOMEPAGE="http://hackage.haskell.org/package/stringprep"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/ranges-0.2.2:=[profile?]
+ >=dev-haskell/text-0.9:=[profile?]
+ >=dev-haskell/text-icu-0.6:=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
diff --git a/dev-haskell/stringprep/stringprep-1.0.0.ebuild b/dev-haskell/stringprep/stringprep-1.0.0.ebuild
new file mode 100644
index 000000000000..692d85fdd9ee
--- /dev/null
+++ b/dev-haskell/stringprep/stringprep-1.0.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Implements the "StringPrep" algorithm"
+HOMEPAGE="http://hackage.haskell.org/package/stringprep"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/text-0.9:=[profile?]
+ >=dev-haskell/text-icu-0.6:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/quickcheck
+ dev-haskell/tasty
+ dev-haskell/tasty-quickcheck
+ dev-haskell/tasty-th )
+"