summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2021-04-27 16:00:47 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2021-04-27 16:21:23 +0200
commitab65e806bec1645412850ff39eef69a22f462597 (patch)
tree28ec43dce1fb253c7f496c342dfd4190df77da4b /dev-java/hawtjni-runtime
parentdev-java/glassfish-persistence: removed obsolete 1.0-r1 (diff)
downloadgentoo-ab65e806bec1645412850ff39eef69a22f462597.tar.gz
gentoo-ab65e806bec1645412850ff39eef69a22f462597.tar.bz2
gentoo-ab65e806bec1645412850ff39eef69a22f462597.zip
dev-java/hawtjni-runtime: EAPI 7, min java 1.8:*
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Closes: https://github.com/gentoo/gentoo/pull/20557 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'dev-java/hawtjni-runtime')
-rw-r--r--dev-java/hawtjni-runtime/hawtjni-runtime-1.15-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-java/hawtjni-runtime/hawtjni-runtime-1.15-r1.ebuild b/dev-java/hawtjni-runtime/hawtjni-runtime-1.15-r1.ebuild
new file mode 100644
index 000000000000..e44e21df9132
--- /dev/null
+++ b/dev-java/hawtjni-runtime/hawtjni-runtime-1.15-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+MY_P="hawtjni-project-${PV}"
+
+DESCRIPTION="A JNI code generator based on the generator used by the Eclipse SWT project"
+HOMEPAGE="https://github.com/fusesource/hawtjni"
+SRC_URI="https://github.com/fusesource/hawtjni/archive/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+
+DEPEND=">=virtual/jdk-1.8:*"
+RDEPEND=">=virtual/jre-1.8:*"
+
+S="${WORKDIR}/hawtjni-${MY_P}/${PN}/src"
+JAVA_SRC_DIR="main/java"
+
+src_install() {
+ java-pkg-simple_src_install
+ dodoc ../../{changelog,notice,readme}.md
+}