summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2016-01-01 17:15:56 +0000
committerJames Le Cuirot <chewi@gentoo.org>2016-01-01 22:49:14 +0000
commitd08ce156e9c3f25c13d73e23c041114c901aaf36 (patch)
tree2aef1bf233c4c68ce8d4adf060299c6df5051c9e /dev-java/icedtea-web/icedtea-web-1.6.1.ebuild
parentapp-eselect/eselect-java: Version bump (diff)
downloadgentoo-d08ce156e9c3f25c13d73e23c041114c901aaf36.tar.gz
gentoo-d08ce156e9c3f25c13d73e23c041114c901aaf36.tar.bz2
gentoo-d08ce156e9c3f25c13d73e23c041114c901aaf36.zip
dev-java/icedtea-web: Version bump, addressing many issues
* Bump to version 1.6.1 (#530860) * Respect java-config's VM selection (#538144, #552640) * Use new eselect-java that looks for itweb-javaws (#504678) * Fix USE=doc under stricter Java 8 (#558718) * Don't call hg because .hg directory is missing (#528268) This version no longer relies on eselect java-nsplugin as it installs the plugin directly under /usr/lib/nsbrowser/plugins. It blocks the Oracle plugins because Firefox cannot disable them individually. Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-java/icedtea-web/icedtea-web-1.6.1.ebuild')
-rw-r--r--dev-java/icedtea-web/icedtea-web-1.6.1.ebuild83
1 files changed, 83 insertions, 0 deletions
diff --git a/dev-java/icedtea-web/icedtea-web-1.6.1.ebuild b/dev-java/icedtea-web/icedtea-web-1.6.1.ebuild
new file mode 100644
index 000000000000..94dc000bfb33
--- /dev/null
+++ b/dev-java/icedtea-web/icedtea-web-1.6.1.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+README_GENTOO_SUFFIX="-r1"
+
+inherit autotools eutils multilib readme.gentoo-r1 java-pkg-2
+
+DESCRIPTION="FOSS Java browser plugin and Web Start implementation"
+HOMEPAGE="http://icedtea.classpath.org"
+SRC_URI="http://icedtea.classpath.org/download/source/${P}.tar.gz"
+LICENSE="GPL-2 GPL-2-with-linking-exception LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="doc javascript +nsplugin tagsoup test"
+RESTRICT="test"
+
+CDEPEND="javascript? ( dev-java/rhino:1.6 )
+ nsplugin? ( >=dev-libs/glib-2.16 )
+ tagsoup? ( dev-java/tagsoup:0 )"
+
+DEPEND="${CDEPEND}
+ app-arch/zip
+ >=virtual/jdk-1.7
+ virtual/pkgconfig
+ nsplugin? ( net-misc/npapi-sdk )
+ test? ( >=dev-java/junit-4.8:4 )"
+
+RDEPEND="${CDEPEND}
+ >=app-eselect/eselect-java-0.2.0
+ >=virtual/jre-1.7
+ nsplugin? (
+ !dev-java/oracle-jdk-bin[nsplugin]
+ !dev-java/oracle-jre-bin[nsplugin]
+ )"
+
+src_prepare() {
+ # http://icedtea.classpath.org/bugzilla/show_bug.cgi?id=2779
+ # http://icedtea.classpath.org/bugzilla/show_bug.cgi?id=2780
+ epatch "${FILESDIR}"/${PN}-1.6-{javadoc,no-hg,launchers,respect-ldflags}.patch
+
+ if java-pkg_is-vm-version-ge "1.8" ; then
+ sed -i 's/JAVADOC_OPTS=/\0-Xdoclint:none /g' Makefile.am || die
+ fi
+
+ eautoreconf
+}
+
+src_configure() {
+ local tagsoup
+ use tagsoup && tagsoup="$(java-pkg_getjars tagsoup)"
+
+ local config=(
+ # Rename javaws to itweb-javaws as eselect java-vm manages
+ # javaws to prevent a clash with Oracle's implementation.
+ --program-transform-name='s/^javaws$/itweb-javaws/'
+ --libdir="${EPREFIX}"/usr/$(get_libdir)/nsbrowser/plugins
+ --with-java="${EPREFIX}"/usr/bin/java
+ --with-jdk-home="${JAVA_HOME}"
+ $(use_enable doc docs)
+ $(use_enable nsplugin plugin)
+ $(use_with javascript rhino)
+ $(use_with tagsoup tagsoup "${tagsoup}")
+ )
+
+ unset JAVA_HOME JDK_HOME CLASSPATH JAVAC JAVACFLAGS
+ econf "${config[@]}"
+}
+
+src_compile() {
+ default
+}
+
+src_install() {
+ default
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}