summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2016-04-05 21:45:12 +0100
committerJames Le Cuirot <chewi@gentoo.org>2016-04-07 22:45:33 +0100
commit8d211633d1d45575b25f152358373df41e477ad7 (patch)
tree51c06445aaa6039f24e73733f2c39f43c7f61a44 /dev-java/jetty-npn-api/jetty-npn-api-1.1.1.ebuild
parentdev-java/netty-tcnative: New package, required by netty-handler (diff)
downloadgentoo-8d211633d1d45575b25f152358373df41e477ad7.tar.gz
gentoo-8d211633d1d45575b25f152358373df41e477ad7.tar.bz2
gentoo-8d211633d1d45575b25f152358373df41e477ad7.zip
dev-java/jetty-npn-api: New package, required by netty-handler
Thanks to wltjr for the original ebuild. Annoyingly the GitHub repository for this has vanished, probably because it is deprecated. Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-java/jetty-npn-api/jetty-npn-api-1.1.1.ebuild')
-rw-r--r--dev-java/jetty-npn-api/jetty-npn-api-1.1.1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-java/jetty-npn-api/jetty-npn-api-1.1.1.ebuild b/dev-java/jetty-npn-api/jetty-npn-api-1.1.1.ebuild
new file mode 100644
index 000000000000..56ece4d9a05e
--- /dev/null
+++ b/dev-java/jetty-npn-api/jetty-npn-api-1.1.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_PN="${PN/jetty-/}"
+MY_PV="${PV}.v20141010"
+MY_P="${MY_PN}-${MY_PV}"
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Jetty's NPN API"
+HOMEPAGE="http://www.eclipse.org/jetty/"
+SRC_URI="http://central.maven.org/maven2/org/eclipse/jetty/npn/${MY_PN}/${MY_PV}/${MY_P}-sources.jar"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=virtual/jre-1.7"
+
+DEPEND=">=virtual/jdk-1.7
+ app-arch/unzip"