summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/sablecc-anttask
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/sablecc-anttask')
-rw-r--r--dev-java/sablecc-anttask/Manifest1
-rw-r--r--dev-java/sablecc-anttask/metadata.xml8
-rw-r--r--dev-java/sablecc-anttask/sablecc-anttask-1.1.0-r1.ebuild27
3 files changed, 36 insertions, 0 deletions
diff --git a/dev-java/sablecc-anttask/Manifest b/dev-java/sablecc-anttask/Manifest
new file mode 100644
index 000000000000..99943cb6e464
--- /dev/null
+++ b/dev-java/sablecc-anttask/Manifest
@@ -0,0 +1 @@
+DIST sablecc-anttask-1.1.0-src.tar.gz 14045 SHA256 1225ad44f093c6ad73132e599f9294abd20cbfb51c7cf53eadcf96cb14945235 SHA512 23e8f3e911660549fd5bd6bcec4c97c58138fbc478bb958695b9b5327cf3da6985830d1c7a8db45516e2f708f7a9405921342b2a05bdce31c39c71569d62059d WHIRLPOOL cda4247e9ae789e742d4a084b8ac7d6e51bdab3b9f7dbacfc8799fd75b2318f3e544f490630016343782ec1139b41a4c5f124da651c6356d9b1f1422f4a1a7f7
diff --git a/dev-java/sablecc-anttask/metadata.xml b/dev-java/sablecc-anttask/metadata.xml
new file mode 100644
index 000000000000..6c817e87bfb4
--- /dev/null
+++ b/dev-java/sablecc-anttask/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <upstream>
+ <remote-id type="sourceforge">sablecc</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-java/sablecc-anttask/sablecc-anttask-1.1.0-r1.ebuild b/dev-java/sablecc-anttask/sablecc-anttask-1.1.0-r1.ebuild
new file mode 100644
index 000000000000..e98fb557c501
--- /dev/null
+++ b/dev-java/sablecc-anttask/sablecc-anttask-1.1.0-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Ant task for sablecc"
+HOMEPAGE="http://sablecc.org/"
+SRC_URI="mirror://sourceforge/sablecc/${P}-src.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.4
+ dev-java/sablecc
+ >=dev-java/ant-core-1.7"
+DEPEND=">=virtual/jdk-1.4
+ ${RDEPEND}"
+
+src_install() {
+ java-pkg_dojar lib/${PN}.jar
+ java-pkg_register-ant-task
+ dohtml doc/*
+ dodoc AUTHORS ChangeLog README || die
+}