summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2024-05-25 07:31:05 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2024-05-25 11:22:52 +0200
commit24db00c6aab33b94484c4661b5e603742df360ce (patch)
tree97eae3580e2b26377ee89a76101aef8b8add44d7 /dev-java
parentdev-java/jflex: ant-task optional (diff)
downloadgentoo-24db00c6aab33b94484c4661b5e603742df360ce.tar.gz
gentoo-24db00c6aab33b94484c4661b5e603742df360ce.tar.bz2
gentoo-24db00c6aab33b94484c4661b5e603742df360ce.zip
dev-java/commons-vfs: drop 2.0-r3
Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/commons-vfs/commons-vfs-2.0-r3.ebuild71
-rw-r--r--dev-java/commons-vfs/files/commons-vfs-2.0-build.xml298
2 files changed, 0 insertions, 369 deletions
diff --git a/dev-java/commons-vfs/commons-vfs-2.0-r3.ebuild b/dev-java/commons-vfs/commons-vfs-2.0-r3.ebuild
deleted file mode 100644
index 418ad23cc41f..000000000000
--- a/dev-java/commons-vfs/commons-vfs-2.0-r3.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-JAVA_PKG_IUSE="source"
-
-inherit java-pkg-2 java-ant-2
-
-DESCRIPTION="A single API for accessing various different file systems"
-HOMEPAGE="https://commons.apache.org/vfs/"
-SRC_URI="https://archive.apache.org/dist/commons/vfs/source/${P}-src.tar.gz"
-S="${WORKDIR}/${P}/core"
-
-LICENSE="Apache-2.0"
-SLOT="2"
-KEYWORDS="amd64 ~arm arm64 ppc64 x86 ~amd64-linux ~x86-linux"
-
-CDEPEND="
- dev-java/ant:0
- dev-java/commons-collections:0
- dev-java/commons-logging:0
- dev-java/commons-net:0
- dev-java/commons-httpclient:3
- dev-java/jackrabbit-webdav:0
- dev-java/jsch:0"
-
-DEPEND="${CDEPEND}
- >=virtual/jdk-1.8:*"
-
-RDEPEND="${CDEPEND}
- >=virtual/jre-1.8:*"
-
-PATCHES=(
- "${FILESDIR}"/${P}-incompatibility.patch
-)
-
-EANT_GENTOO_CLASSPATH="
- ant
- commons-collections
- commons-logging
- commons-net
- commons-httpclient-3
- jackrabbit-webdav
- jsch
-"
-EANT_EXTRA_ARGS="-Dlibdir=${T}"
-
-# The build.xml is generated from maven and can't run the tests properly
-# Use maven test to execute these manually but that means downloading deps from
-# the internet. Also the tests need to login to some ftp servers and samba
-# shares so I doubt they work for everyone.
-#src_test() {
-# ANT_TASKS="ant-junit" eant test
-#}
-
-src_prepare() {
- default
- cp "${FILESDIR}"/${P}-build.xml build.xml || die
-
- java-ant_rewrite-classpath
- java-ant_ignore-system-classes
-}
-
-src_install() {
- java-pkg_newjar target/*.jar
-
- # [javadoc] No javadoc created, no need to post-process anything
-# use doc && java-pkg_dojavadoc target/site/apidocs
- use source && java-pkg_dosrc src/main/java
-}
diff --git a/dev-java/commons-vfs/files/commons-vfs-2.0-build.xml b/dev-java/commons-vfs/files/commons-vfs-2.0-build.xml
deleted file mode 100644
index 753e93d669f2..000000000000
--- a/dev-java/commons-vfs/files/commons-vfs-2.0-build.xml
+++ /dev/null
@@ -1,298 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-
-<!-- ====================================================================== -->
-<!-- Ant build file (http://ant.apache.org/) for Ant 1.6.2 or above. -->
-<!-- ====================================================================== -->
-
-<!-- ====================================================================== -->
-<!-- ===================== - DO NOT EDIT THIS FILE! - ===================== -->
-<!-- ====================================================================== -->
-<!-- -->
-<!-- Any modifications will be overwritten. -->
-<!-- -->
-<!-- Generated by Maven Ant Plugin on 5/29/13 3:05 PM -->
-<!-- See: http://maven.apache.org/plugins/maven-ant-plugin/ -->
-<!-- -->
-<!-- ====================================================================== -->
-
-<project name="commons-vfs2-from-maven" default="package" basedir=".">
-
- <!-- ====================================================================== -->
- <!-- Build environment properties -->
- <!-- ====================================================================== -->
-
- <property file="${user.home}/.m2/maven.properties"/>
- <property file="maven-build.properties"/>
-
- <property name="maven.build.finalName" value="commons-vfs2-2.0"/>
- <property name="maven.build.dir" value="target"/>
- <property name="maven.build.outputDir" value="${maven.build.dir}/classes"/>
- <property name="maven.build.srcDir.0" value="src/main/java"/>
- <property name="maven.build.resourceDir.0" value="src/main/java"/>
- <property name="maven.build.resourceDir.1" value=".."/>
- <property name="maven.build.testOutputDir" value="${maven.build.dir}/test-classes"/>
- <property name="maven.build.testDir.0" value="src/test/java"/>
- <property name="maven.build.testResourceDir.0" value="src/test/resources"/>
- <property name="maven.build.testResourceDir.1" value=".."/>
- <property name="maven.test.reports" value="${maven.build.dir}/test-reports"/>
- <property name="maven.reporting.outputDirectory" value="${maven.build.dir}/site"/>
-
- <property name="maven.repo.local" value="${user.home}/.m2/repository"/>
- <property name="maven.settings.offline" value="false"/>
- <property name="maven.settings.interactiveMode" value="true"/>
-
- <!-- ====================================================================== -->
- <!-- Defining classpaths -->
- <!-- ====================================================================== -->
-
- <path id="build.classpath">
- <pathelement location="${maven.repo.local}/commons-logging/commons-logging/1.1.1/commons-logging-1.1.1.jar"/>
- <pathelement location="${maven.repo.local}/ant/ant/1.6.2/ant-1.6.2.jar"/>
- <pathelement location="${maven.repo.local}/commons-net/commons-net/2.2/commons-net-2.2.jar"/>
- <pathelement location="${maven.repo.local}/commons-collections/commons-collections/3.1/commons-collections-3.1.jar"/>
- <pathelement location="${maven.repo.local}/commons-httpclient/commons-httpclient/3.1/commons-httpclient-3.1.jar"/>
- <pathelement location="${maven.repo.local}/commons-codec/commons-codec/1.2/commons-codec-1.2.jar"/>
- <pathelement location="${maven.repo.local}/org/apache/jackrabbit/jackrabbit-webdav/1.5.2/jackrabbit-webdav-1.5.2.jar"/>
- <pathelement location="${maven.repo.local}/org/apache/jackrabbit/jackrabbit-jcr-commons/1.5.2/jackrabbit-jcr-commons-1.5.2.jar"/>
- <pathelement location="${maven.repo.local}/org/slf4j/slf4j-api/1.5.3/slf4j-api-1.5.3.jar"/>
- <pathelement location="${maven.repo.local}/com/jcraft/jsch/0.1.42/jsch-0.1.42.jar"/>
- <pathelement location="${maven.repo.local}/org/apache/maven/scm/maven-scm-api/1.4/maven-scm-api-1.4.jar"/>
- <pathelement location="${maven.repo.local}/org/codehaus/plexus/plexus-utils/1.5.6/plexus-utils-1.5.6.jar"/>
- <pathelement location="${maven.repo.local}/org/apache/maven/scm/maven-scm-provider-svnexe/1.4/maven-scm-provider-svnexe-1.4.jar"/>
- <pathelement location="${maven.repo.local}/org/apache/maven/scm/maven-scm-provider-svn-commons/1.4/maven-scm-provider-svn-commons-1.4.jar"/>
- <pathelement location="${maven.repo.local}/regexp/regexp/1.3/regexp-1.3.jar"/>
- </path>
- <path id="build.test.classpath">
- <pathelement location="${maven.repo.local}/commons-logging/commons-logging/1.1.1/commons-logging-1.1.1.jar"/>
- <pathelement location="${maven.repo.local}/ant/ant/1.6.2/ant-1.6.2.jar"/>
- <pathelement location="${maven.repo.local}/commons-net/commons-net/2.2/commons-net-2.2.jar"/>
- <pathelement location="${maven.repo.local}/org/apache/commons/commons-compress/1.1/commons-compress-1.1.jar"/>
- <pathelement location="${maven.repo.local}/commons-collections/commons-collections/3.1/commons-collections-3.1.jar"/>
- <pathelement location="${maven.repo.local}/commons-httpclient/commons-httpclient/3.1/commons-httpclient-3.1.jar"/>
- <pathelement location="${maven.repo.local}/commons-codec/commons-codec/1.2/commons-codec-1.2.jar"/>
- <pathelement location="${maven.repo.local}/org/apache/jackrabbit/jackrabbit-webdav/1.5.2/jackrabbit-webdav-1.5.2.jar"/>
- <pathelement location="${maven.repo.local}/org/apache/jackrabbit/jackrabbit-jcr-commons/1.5.2/jackrabbit-jcr-commons-1.5.2.jar"/>
- <pathelement location="${maven.repo.local}/org/slf4j/slf4j-api/1.5.3/slf4j-api-1.5.3.jar"/>
- <pathelement location="${maven.repo.local}/com/jcraft/jsch/0.1.42/jsch-0.1.42.jar"/>
- <pathelement location="${maven.repo.local}/junit/junit/4.8.2/junit-4.8.2.jar"/>
- <pathelement location="${maven.repo.local}/org/apache/maven/scm/maven-scm-api/1.4/maven-scm-api-1.4.jar"/>
- <pathelement location="${maven.repo.local}/org/codehaus/plexus/plexus-utils/1.5.6/plexus-utils-1.5.6.jar"/>
- <pathelement location="${maven.repo.local}/org/apache/maven/scm/maven-scm-provider-svnexe/1.4/maven-scm-provider-svnexe-1.4.jar"/>
- <pathelement location="${maven.repo.local}/org/apache/maven/scm/maven-scm-provider-svn-commons/1.4/maven-scm-provider-svn-commons-1.4.jar"/>
- <pathelement location="${maven.repo.local}/regexp/regexp/1.3/regexp-1.3.jar"/>
- </path>
-
- <!-- ====================================================================== -->
- <!-- Cleaning up target -->
- <!-- ====================================================================== -->
-
- <target name="clean" description="Clean the output directory">
- <delete dir="${maven.build.dir}"/>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Compilation target -->
- <!-- ====================================================================== -->
-
- <target name="compile" depends="get-deps" description="Compile the code">
- <mkdir dir="${maven.build.outputDir}"/>
- <javac destdir="${maven.build.outputDir}"
- encoding="iso-8859-1"
- nowarn="false"
- debug="true"
- optimize="false"
- deprecation="true"
- target="1.5"
- verbose="false"
- fork="false"
- source="1.5">
- <src>
- <pathelement location="${maven.build.srcDir.0}"/>
- </src>
- <classpath refid="build.classpath"/>
- </javac>
- <copy todir="${maven.build.outputDir}">
- <fileset dir="${maven.build.resourceDir.0}">
- <exclude name="**/*.java"/>
- </fileset>
- </copy>
- <mkdir dir="${maven.build.outputDir}/META-INF"/>
- <copy todir="${maven.build.outputDir}/META-INF">
- <fileset dir="${maven.build.resourceDir.1}">
- <include name="NOTICE.txt"/>
- <include name="LICENSE.txt"/>
- </fileset>
- </copy>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Test-compilation target -->
- <!-- ====================================================================== -->
-
- <target name="compile-tests"
- depends="compile"
- description="Compile the test code"
- unless="maven.test.skip">
- <mkdir dir="${maven.build.testOutputDir}"/>
- <javac destdir="${maven.build.testOutputDir}"
- encoding="iso-8859-1"
- nowarn="false"
- debug="true"
- optimize="false"
- deprecation="true"
- target="1.5"
- verbose="false"
- fork="false"
- source="1.5">
- <src>
- <pathelement location="${maven.build.testDir.0}"/>
- </src>
- <classpath>
- <path refid="build.test.classpath"/>
- <pathelement location="${maven.build.outputDir}"/>
- </classpath>
- </javac>
- <copy todir="${maven.build.testOutputDir}">
- <fileset dir="${maven.build.testResourceDir.0}"/>
- </copy>
- <mkdir dir="${maven.build.testOutputDir}/META-INF"/>
- <copy todir="${maven.build.testOutputDir}/META-INF">
- <fileset dir="${maven.build.testResourceDir.1}">
- <include name="NOTICE.txt"/>
- <include name="LICENSE.txt"/>
- </fileset>
- </copy>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Run all tests -->
- <!-- ====================================================================== -->
-
- <target name="test"
- depends="compile-tests, junit-missing"
- unless="junit.skipped"
- description="Run the test cases">
- <mkdir dir="${maven.test.reports}"/>
- <junit printSummary="yes" haltonerror="true" haltonfailure="true" fork="true" dir=".">
- <sysproperty key="basedir" value="."/>
- <formatter type="xml"/>
- <formatter type="plain" usefile="false"/>
- <classpath>
- <path refid="build.test.classpath"/>
- <pathelement location="${maven.build.outputDir}"/>
- <pathelement location="${maven.build.testOutputDir}"/>
- </classpath>
- <batchtest todir="${maven.test.reports}" unless="test">
- <fileset dir="${maven.build.testDir.0}">
- <include name="**/Test*.java"/>
- <include name="**/*Test.java"/>
- <include name="**/*TestCase.java"/>
- <exclude name="**/RunTest.java"/>
- <exclude name="**/*$*"/>
- </fileset>
- </batchtest>
- <batchtest todir="${maven.test.reports}" if="test">
- <fileset dir="${maven.build.testDir.0}">
- <include name="**/${test}.java"/>
- <exclude name="**/RunTest.java"/>
- <exclude name="**/*$*"/>
- </fileset>
- </batchtest>
- </junit>
- </target>
-
- <target name="test-junit-present">
- <available classname="junit.framework.Test" property="junit.present"/>
- </target>
-
- <target name="test-junit-status"
- depends="test-junit-present">
- <condition property="junit.missing">
- <and>
- <isfalse value="${junit.present}"/>
- <isfalse value="${maven.test.skip}"/>
- </and>
- </condition>
- <condition property="junit.skipped">
- <or>
- <isfalse value="${junit.present}"/>
- <istrue value="${maven.test.skip}"/>
- </or>
- </condition>
- </target>
-
- <target name="junit-missing"
- depends="test-junit-status"
- if="junit.missing">
- <echo>=================================== WARNING ===================================</echo>
- <echo> JUnit is not present in your $ANT_HOME/lib directory. Tests not executed.</echo>
- <echo>===============================================================================</echo>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Javadoc target -->
- <!-- ====================================================================== -->
-
- <target name="javadoc" description="Generates the Javadoc of the application">
- <javadoc sourcepath="${maven.build.srcDir.0}"
- packagenames="*"
- destdir="${maven.reporting.outputDirectory}/apidocs"
- access="protected"
- old="false"
- verbose="false"
- encoding="iso-8859-1"
- version="true"
- use="true"
- author="true"
- splitindex="false"
- nodeprecated="false"
- nodeprecatedlist="false"
- notree="false"
- noindex="false"
- nohelp="false"
- nonavbar="false"
- serialwarn="false"
- charset="ISO-8859-1"
- source="1.5"
- linksource="true"
- breakiterator="false">
- <link href="http://download.oracle.com/javase/6/docs/api/"/>
- </javadoc>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Package target -->
- <!-- ====================================================================== -->
-
- <target name="package" depends="compile,test" description="Package the application">
- <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar"
- compress="true"
- index="false"
- basedir="${maven.build.outputDir}"
- excludes="**/package.html">
- </jar>
- </target>
-
- <!-- ====================================================================== -->
- <!-- A dummy target for the package named after the type it creates -->
- <!-- ====================================================================== -->
-
- <target name="jar" depends="package" description="Builds the jar for the application"/>
-
- <!-- ====================================================================== -->
- <!-- Download dependencies target -->
- <!-- ====================================================================== -->
-
- <target name="test-offline">
- <condition property="maven.mode.offline">
- <equals arg1="${maven.settings.offline}" arg2="true"/>
- </condition>
- </target>
-
- <target name="get-deps"
- depends="test-offline"
- description="Download all dependencies"
- unless="maven.mode.offline">
- </target>
-
-</project>