summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2022-09-13 16:13:08 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2022-09-13 16:17:34 -0700
commitcc0613141e60d62b391df254f81286e2123c8c1f (patch)
tree2f30dad103c2e3c7d7add8d9ca9e77fc2ca6646e /dev-java
parentdev-java/openjdk-jre-bin: add 17.0.4.1_p1 (diff)
downloadgentoo-cc0613141e60d62b391df254f81286e2123c8c1f.tar.gz
gentoo-cc0613141e60d62b391df254f81286e2123c8c1f.tar.bz2
gentoo-cc0613141e60d62b391df254f81286e2123c8c1f.zip
dev-java/openjdk: add -ga tag explanation inline
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/openjdk/openjdk-11.0.15_p10-r1.ebuild6
-rw-r--r--dev-java/openjdk/openjdk-11.0.16.1_p1.ebuild6
-rw-r--r--dev-java/openjdk/openjdk-17.0.3_p7-r1.ebuild6
-rw-r--r--dev-java/openjdk/openjdk-17.0.4.1_p1.ebuild6
-rw-r--r--dev-java/openjdk/openjdk-17.0.5_p5.ebuild6
-rw-r--r--dev-java/openjdk/openjdk-8.332_p09.ebuild11
-rw-r--r--dev-java/openjdk/openjdk-8.345_p01.ebuild11
7 files changed, 46 insertions, 6 deletions
diff --git a/dev-java/openjdk/openjdk-11.0.15_p10-r1.ebuild b/dev-java/openjdk/openjdk-11.0.15_p10-r1.ebuild
index ef15a142fec5..feaa4c78cbc9 100644
--- a/dev-java/openjdk/openjdk-11.0.15_p10-r1.ebuild
+++ b/dev-java/openjdk/openjdk-11.0.15_p10-r1.ebuild
@@ -5,6 +5,12 @@ EAPI=7
inherit eapi8-dosym check-reqs flag-o-matic java-pkg-2 java-vm-2 multiprocessing toolchain-funcs
+# don't change versioning scheme
+# to find correct _p number, look at
+# https://github.com/openjdk/jdk${SLOT}u/tags
+# you will see, for example, jdk-17.0.4.1-ga and jdk-17.0.4.1+1, both point
+# to exact same commit sha. we should always use the full version.
+# -ga tag is just for humans to easily identify General Availability release tag.
# we need -ga tag to fetch tarball and unpack it, but exact number everywhere else to
# set build version properly
MY_PV="${PV%_p*}-ga"
diff --git a/dev-java/openjdk/openjdk-11.0.16.1_p1.ebuild b/dev-java/openjdk/openjdk-11.0.16.1_p1.ebuild
index 4952d502f500..055cb96bc4a9 100644
--- a/dev-java/openjdk/openjdk-11.0.16.1_p1.ebuild
+++ b/dev-java/openjdk/openjdk-11.0.16.1_p1.ebuild
@@ -5,6 +5,12 @@ EAPI=7
inherit eapi8-dosym check-reqs flag-o-matic java-pkg-2 java-vm-2 multiprocessing toolchain-funcs
+# don't change versioning scheme
+# to find correct _p number, look at
+# https://github.com/openjdk/jdk${SLOT}u/tags
+# you will see, for example, jdk-17.0.4.1-ga and jdk-17.0.4.1+1, both point
+# to exact same commit sha. we should always use the full version.
+# -ga tag is just for humans to easily identify General Availability release tag.
# we need -ga tag to fetch tarball and unpack it, but exact number everywhere else to
# set build version properly
MY_PV="${PV%_p*}-ga"
diff --git a/dev-java/openjdk/openjdk-17.0.3_p7-r1.ebuild b/dev-java/openjdk/openjdk-17.0.3_p7-r1.ebuild
index c79922b35711..9f355b7b9030 100644
--- a/dev-java/openjdk/openjdk-17.0.3_p7-r1.ebuild
+++ b/dev-java/openjdk/openjdk-17.0.3_p7-r1.ebuild
@@ -26,6 +26,12 @@ bootstrap_uri() {
echo "${kw}? ( ${cond:+${cond}? (} ${baseuri}-${ver}-${kw}${musl:+-musl}.${suff} ${cond:+) })"
}
+# don't change versioning scheme
+# to find correct _p number, look at
+# https://github.com/openjdk/jdk${SLOT}u/tags
+# you will see, for example, jdk-17.0.4.1-ga and jdk-17.0.4.1+1, both point
+# to exact same commit sha. we should always use the full version.
+# -ga tag is just for humans to easily identify General Availability release tag.
MY_PV="${PV//_p/+}"
SLOT="$(ver_cut 1)"
diff --git a/dev-java/openjdk/openjdk-17.0.4.1_p1.ebuild b/dev-java/openjdk/openjdk-17.0.4.1_p1.ebuild
index 36683911df51..2ed126279a79 100644
--- a/dev-java/openjdk/openjdk-17.0.4.1_p1.ebuild
+++ b/dev-java/openjdk/openjdk-17.0.4.1_p1.ebuild
@@ -26,6 +26,12 @@ bootstrap_uri() {
echo "${kw}? ( ${cond:+${cond}? (} ${baseuri}-${ver}-${kw}${musl:+-musl}.${suff} ${cond:+) })"
}
+# don't change versioning scheme
+# to find correct _p number, look at
+# https://github.com/openjdk/jdk${SLOT}u/tags
+# you will see, for example, jdk-17.0.4.1-ga and jdk-17.0.4.1+1, both point
+# to exact same commit sha. we should always use the full version.
+# -ga tag is just for humans to easily identify General Availability release tag.
MY_PV="${PV//_p/+}"
SLOT="$(ver_cut 1)"
diff --git a/dev-java/openjdk/openjdk-17.0.5_p5.ebuild b/dev-java/openjdk/openjdk-17.0.5_p5.ebuild
index ce1e101e1c8d..191467d5a34c 100644
--- a/dev-java/openjdk/openjdk-17.0.5_p5.ebuild
+++ b/dev-java/openjdk/openjdk-17.0.5_p5.ebuild
@@ -26,6 +26,12 @@ bootstrap_uri() {
echo "${kw}? ( ${cond:+${cond}? (} ${baseuri}-${ver}-${kw}${musl:+-musl}.${suff} ${cond:+) })"
}
+# don't change versioning scheme
+# to find correct _p number, look at
+# https://github.com/openjdk/jdk${SLOT}u/tags
+# you will see, for example, jdk-17.0.4.1-ga and jdk-17.0.4.1+1, both point
+# to exact same commit sha. we should always use the full version.
+# -ga tag is just for humans to easily identify General Availability release tag.
MY_PV="${PV//_p/+}"
SLOT="$(ver_cut 1)"
diff --git a/dev-java/openjdk/openjdk-8.332_p09.ebuild b/dev-java/openjdk/openjdk-8.332_p09.ebuild
index 2ddd4bb724fa..e2f8f421b145 100644
--- a/dev-java/openjdk/openjdk-8.332_p09.ebuild
+++ b/dev-java/openjdk/openjdk-8.332_p09.ebuild
@@ -5,9 +5,14 @@ EAPI=7
inherit check-reqs eapi8-dosym flag-o-matic java-pkg-2 java-vm-2 multiprocessing toolchain-funcs
-# we need latest -ga tag from git, but want to keep build number as well
-# as _p component of the gentoo version string.
-
+# don't change versioning scheme
+# to find correct _p number, look at
+# https://github.com/openjdk/jdk${SLOT}u/tags
+# you will see, for example, jdk-17.0.4.1-ga and jdk-17.0.4.1+1, both point
+# to exact same commit sha. we should always use the full version.
+# -ga tag is just for humans to easily identify General Availability release tag.
+# we need -ga tag to fetch tarball and unpack it, but exact number everywhere else to
+# set build version properly
MY_PV="$(ver_rs 1 'u' 2 '-' ${PV%_p*}-ga)"
SLOT="${PV%%[.+]*}"
diff --git a/dev-java/openjdk/openjdk-8.345_p01.ebuild b/dev-java/openjdk/openjdk-8.345_p01.ebuild
index b46632bbb4bb..0981ff23ed4e 100644
--- a/dev-java/openjdk/openjdk-8.345_p01.ebuild
+++ b/dev-java/openjdk/openjdk-8.345_p01.ebuild
@@ -5,9 +5,14 @@ EAPI=7
inherit check-reqs eapi8-dosym flag-o-matic java-pkg-2 java-vm-2 multiprocessing toolchain-funcs
-# we need latest -ga tag from git, but want to keep build number as well
-# as _p component of the gentoo version string.
-
+# don't change versioning scheme
+# to find correct _p number, look at
+# https://github.com/openjdk/jdk${SLOT}u/tags
+# you will see, for example, jdk-17.0.4.1-ga and jdk-17.0.4.1+1, both point
+# to exact same commit sha. we should always use the full version.
+# -ga tag is just for humans to easily identify General Availability release tag.
+# we need -ga tag to fetch tarball and unpack it, but exact number everywhere else to
+# set build version properly
MY_PV="$(ver_rs 1 'u' 2 '-' ${PV%_p*}-ga)"
SLOT="${PV%%[.+]*}"