summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2016-01-23 04:08:57 +1100
committerMichael Palimaka <kensington@gentoo.org>2016-01-23 04:09:19 +1100
commit8591ef8f32a24c21208ec3e32521901deea56e4e (patch)
tree3e4f91773378e28d4ecc1c9fd8bd2da0a8372613 /dev-lang/falcon/files
parentprofiles/prefix/darwin/package.use.mask: mask USE=xattr for tar on Darwin (diff)
downloadgentoo-8591ef8f32a24c21208ec3e32521901deea56e4e.tar.gz
gentoo-8591ef8f32a24c21208ec3e32521901deea56e4e.tar.bz2
gentoo-8591ef8f32a24c21208ec3e32521901deea56e4e.zip
dev-lang/falcon: version bump
Gentoo-bug: 361995 Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-lang/falcon/files')
-rw-r--r--dev-lang/falcon/files/falcon-0.9.6.8-mongo-amd64.patch75
-rw-r--r--dev-lang/falcon/files/falcon-0.9.6.8-mongo-stdint.patch36
2 files changed, 111 insertions, 0 deletions
diff --git a/dev-lang/falcon/files/falcon-0.9.6.8-mongo-amd64.patch b/dev-lang/falcon/files/falcon-0.9.6.8-mongo-amd64.patch
new file mode 100644
index 000000000000..8385ca0d081c
--- /dev/null
+++ b/dev-lang/falcon/files/falcon-0.9.6.8-mongo-amd64.patch
@@ -0,0 +1,75 @@
+From 64526ea7d3b5ec04f398bd28cb4e505e6a0f3218 Mon Sep 17 00:00:00 2001
+From: Stanislas Marquis <stnsls@gmail.com>
+Date: Sun, 9 Jan 2011 08:40:00 +0100
+Subject: [PATCH] [mongo] [cmake] Fix problems with Linux x64.
+
+---
+ modules/native/mongodb/CMakeLists.txt | 11 +++++++++--
+ modules/native/mongodb/mongodb_mod.cpp | 2 +-
+ modules/native/mongodb/src/CMakeLists.txt | 8 ++++++--
+ 3 files changed, 16 insertions(+), 5 deletions(-)
+
+diff --git a/modules/native/mongodb/CMakeLists.txt b/modules/native/mongodb/CMakeLists.txt
+index ba7e5cf..bf2d869 100644
+--- a/modules/native/mongodb/CMakeLists.txt
++++ b/modules/native/mongodb/CMakeLists.txt
+@@ -8,6 +8,10 @@ falcon_define_module( FALCON_MODULE mongo )
+
+ message( STATUS "Adding mongodb module" )
+
++if ( NOT MSVC )
++ option( MONGO_HAVE_STDINT "MongoDB problem with int64_t?" OFF )
++endif()
++
+ ##
+ # Find Falcon
+ #
+@@ -28,8 +32,11 @@ add_subdirectory( src )
+ if ( MSVC )
+ add_definitions( -DMONGO_USE__INT64 )
+ else()
+- #add_definitions( -DMONGO_HAVE_STDINT )
+- add_definitions( -DMONGO_USE_LONG_LONG_INT )
++ if ( MONGO_HAVE_STDINT )
++ add_definitions( -DMONGO_HAVE_STDINT )
++ else()
++ add_definitions( -DMONGO_USE_LONG_LONG_INT )
++ endif()
+ endif()
+
+ ##
+diff --git a/modules/native/mongodb/mongodb_mod.cpp b/modules/native/mongodb/mongodb_mod.cpp
+index 6102664..4d47fac 100644
+--- a/modules/native/mongodb/mongodb_mod.cpp
++++ b/modules/native/mongodb/mongodb_mod.cpp
+@@ -1321,7 +1321,7 @@ BSONIter::makeItem( const bson_type tp,
+ //...
+ break;
+ case bson_long:
+- it = new Item( bson_iterator_long_raw( iter ) );
++ it = new Item( (int64) bson_iterator_long_raw( iter ) );
+ break;
+ case bson_eoo:
+ default:
+diff --git a/modules/native/mongodb/src/CMakeLists.txt b/modules/native/mongodb/src/CMakeLists.txt
+index 48cdaef..d883af3 100644
+--- a/modules/native/mongodb/src/CMakeLists.txt
++++ b/modules/native/mongodb/src/CMakeLists.txt
+@@ -7,8 +7,12 @@ include_directories( BEFORE . )
+ if ( MSVC )
+ add_definitions( -DMONGO_USE__INT64 )
+ else()
+- add_definitions( -DMONGO_USE_LONG_LONG_INT )
+- #add_definitions( --std=c99 )
++ add_definitions( -fPIC )
++ if ( MONGO_HAVE_STDINT )
++ add_definitions( -DMONGO_HAVE_STDINT )
++ else()
++ add_definitions( -DMONGO_USE_LONG_LONG_INT )
++ endif()
+ endif()
+
+ set( MONGO_SRCS
+--
+1.7.9.1
+
diff --git a/dev-lang/falcon/files/falcon-0.9.6.8-mongo-stdint.patch b/dev-lang/falcon/files/falcon-0.9.6.8-mongo-stdint.patch
new file mode 100644
index 000000000000..0f688b2ddbfc
--- /dev/null
+++ b/dev-lang/falcon/files/falcon-0.9.6.8-mongo-stdint.patch
@@ -0,0 +1,36 @@
+From a64c0c3959a0f5e853daba2b35ca19459acf875e Mon Sep 17 00:00:00 2001
+From: Stanislas Marquis <stnsls@gmail.com>
+Date: Sat, 29 Jan 2011 12:27:50 +0100
+Subject: [PATCH] [mongo] Fix detection of stdint.h
+
+---
+ modules/native/mongodb/CMakeLists.txt | 12 +++++++++++-
+ 1 files changed, 11 insertions(+), 1 deletions(-)
+
+diff --git a/modules/native/mongodb/CMakeLists.txt b/modules/native/mongodb/CMakeLists.txt
+index bf2d869..e4d1df6 100644
+--- a/modules/native/mongodb/CMakeLists.txt
++++ b/modules/native/mongodb/CMakeLists.txt
+@@ -8,8 +8,18 @@ falcon_define_module( FALCON_MODULE mongo )
+
+ message( STATUS "Adding mongodb module" )
+
++##
++# Check for stdint.h
++#
+ if ( NOT MSVC )
+- option( MONGO_HAVE_STDINT "MongoDB problem with int64_t?" OFF )
++ find_file( STDINT_H stdint.h HINTS /usr/include )
++ if ( STDINT_H STREQUAL STDINT_H-NOTFOUND )
++ option( MONGO_HAVE_STDINT "MongoDB should use stdint.h" OFF )
++ else()
++ option( MONGO_HAVE_STDINT "MongoDB should use stdint.h" ON )
++ endif()
++ mark_as_advanced( STDINT_H )
++ mark_as_advanced( MONGO_HAVE_STDINT )
+ endif()
+
+ ##
+--
+1.7.9.1
+