summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-11-28 11:17:55 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-11-28 11:23:47 +0100
commit8f5c0252dccce88e987dd1eaa958b22d32d8b5b2 (patch)
tree5c60d7967ef6042f4ead4165af7783b4ae73c243 /dev-lang/kotlin-bin
parentdev-lang/bas: bind ncurses slot; style tweaks (diff)
downloadgentoo-8f5c0252dccce88e987dd1eaa958b22d32d8b5b2.tar.gz
gentoo-8f5c0252dccce88e987dd1eaa958b22d32d8b5b2.tar.bz2
gentoo-8f5c0252dccce88e987dd1eaa958b22d32d8b5b2.zip
dev-lang/kotlin-bin: drop old 2.0.20
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-lang/kotlin-bin')
-rw-r--r--dev-lang/kotlin-bin/Manifest1
-rw-r--r--dev-lang/kotlin-bin/kotlin-bin-2.0.20.ebuild59
2 files changed, 0 insertions, 60 deletions
diff --git a/dev-lang/kotlin-bin/Manifest b/dev-lang/kotlin-bin/Manifest
index f83ce2e6448d..4ac590f2be9f 100644
--- a/dev-lang/kotlin-bin/Manifest
+++ b/dev-lang/kotlin-bin/Manifest
@@ -1,2 +1 @@
-DIST kotlin-compiler-2.0.20.zip 86110157 BLAKE2B 601e6d8b0ac3af3b8b0b2ddc87bb8ab2d69769e9f3d217c1be317874bfd77a8b767fd84c315637b48782393326bc3b1abc875d1293b3766dc03a0216d26cddf0 SHA512 07bb47339813d127783b2ddfd52635dd483744f1821c8b95075698f37c506e0b66c7abb3d9ab183ba957fe07b4ce1a34b9be2c4477ca0e9115feacab8380bba7
DIST kotlin-compiler-2.0.21.zip 85822011 BLAKE2B 007a3cb8902e5a12d883ede2ef670f821471c3273dc97d17935006e0dc35989fe540cbeaa0a8203fc95e05f2b36d95000a1e3ac11803c2723b1dfa361a102470 SHA512 0ab48b49fc3582274485eb5c65a6e5b5de9c45e9c2faafb0720bf07308af50d813eae6d73c57a56daed6b9fd5378d40ce701f14f13e3063bdb38c5d529eb7626
diff --git a/dev-lang/kotlin-bin/kotlin-bin-2.0.20.ebuild b/dev-lang/kotlin-bin/kotlin-bin-2.0.20.ebuild
deleted file mode 100644
index 7e3629cfadfc..000000000000
--- a/dev-lang/kotlin-bin/kotlin-bin-2.0.20.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit java-pkg-2 wrapper
-
-DESCRIPTION="Statically typed language that targets the JVM and JavaScript"
-HOMEPAGE="https://kotlinlang.org/
- https://github.com/JetBrains/kotlin/"
-SRC_URI="https://github.com/JetBrains/kotlin/releases/download/v${PV}/kotlin-compiler-${PV}.zip"
-S="${WORKDIR}/kotlinc"
-
-LICENSE="Apache-2.0 BSD MIT NPL-1.1"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- >=virtual/jre-1.8:*
-"
-DEPEND="
- >=virtual/jdk-1.8:*
-"
-BDEPEND="
- app-arch/unzip
-"
-
-src_prepare() {
- default
-
- rm bin/*.bat || die
-}
-
-src_compile() {
- :
-}
-
-src_install() {
- java-pkg_dojar lib/*
-
- # Follow the Java eclass JAR installation path.
- local app_home="/usr/share/${PN}"
-
- exeinto "${app_home}/bin"
- doexe bin/*
-
- local -a exes=(
- kapt
- kotlin
- kotlinc
- kotlinc-js
- kotlinc-jvm
- kotlin-dce-js
- )
- local exe
- for exe in "${exes[@]}" ; do
- make_wrapper "${exe}" "${app_home}/bin/${exe}"
- done
-}