summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger (asterix) <m.mairkeimberger@gmail.com>2016-08-06 16:58:54 +0200
committerWilliam Hubbs <williamh@gentoo.org>2016-10-04 11:37:21 -0500
commitf199a769f111158928c34b7c961c80c79d9b36a9 (patch)
tree5b99336c1d122ec999016edb90e5524505462fa2 /dev-lang/lua/files
parentapp-arch/pigz: version bump to 2.3.4 (diff)
downloadgentoo-f199a769f111158928c34b7c961c80c79d9b36a9.tar.gz
gentoo-f199a769f111158928c34b7c961c80c79d9b36a9.tar.bz2
gentoo-f199a769f111158928c34b7c961c80c79d9b36a9.zip
dev-lang/lua: remove unused patches
Diffstat (limited to 'dev-lang/lua/files')
-rw-r--r--dev-lang/lua/files/lua-5.1-make.patch64
-rw-r--r--dev-lang/lua/files/lua-5.1-make_static.patch12
-rw-r--r--dev-lang/lua/files/lua-5.2-make.patch60
3 files changed, 0 insertions, 136 deletions
diff --git a/dev-lang/lua/files/lua-5.1-make.patch b/dev-lang/lua/files/lua-5.1-make.patch
deleted file mode 100644
index 0c88bffedb22..000000000000
--- a/dev-lang/lua/files/lua-5.1-make.patch
+++ /dev/null
@@ -1,64 +0,0 @@
---- lua-5.1.1.orig/Makefile 2006-06-02 12:53:38.000000000 +0200
-+++ lua-5.1.1/Makefile 2006-11-16 02:16:53.000000000 +0100
-@@ -127,3 +127,22 @@
- .PHONY: all $(PLATS) clean test install local none dummy echo pecho lecho newer
-
- # (end of Makefile)
-+
-+# Use libtool for binary installs, etc.
-+
-+export V
-+export LIBTOOL = libtool --quiet --tag=CC
-+# See libtool manual about how to set this
-+
-+gentoo_clean:
-+ cd src; $(MAKE) $@
-+
-+gentoo_test: gentoo_linux
-+ test/lua.static test/hello.lua
-+
-+gentoo_install:
-+ mkdir -p $(INSTALL_BIN) $(INSTALL_INC) $(INSTALL_LIB)
-+ cd src; $(LIBTOOL) --mode=install $(INSTALL_EXEC) lua luac $(INSTALL_BIN)
-+ cd src; $(INSTALL_DATA) $(TO_INC) $(INSTALL_INC)
-+ cd src; $(LIBTOOL) --mode=install $(INSTALL_DATA) liblua.la $(INSTALL_LIB)
-+ cd src; $(LIBTOOL) --mode=install $(INSTALL_DATA) liblua.a $(INSTALL_LIB)
---- lua-5.1.1.orig/src/Makefile 2006-03-22 01:41:49.000000000 +0100
-+++ lua-5.1.1/src/Makefile 2006-11-16 02:10:27.000000000 +0100
-@@ -176,3 +176,36 @@
- ltm.h lzio.h lmem.h lopcodes.h lundump.h
-
- # (end of Makefile)
-+
-+export LIBTOOL = libtool --quiet --tag=CC
-+export LIB_VERSION = 6:1:1
-+
-+# The following rules use libtool for compiling and linking in order to
-+# provide shared library support.
-+
-+LIB_NAME = liblua.la
-+LIB_OBJS = $(CORE_O:.o=.lo) $(LIB_O:.o=.lo)
-+
-+%.lo %.o: %.c
-+ $(LIBTOOL) --mode=compile $(CC) -c $(CPPFLAGS) $(CFLAGS) -o $@ $<
-+
-+$(LIB_NAME): $(LIB_OBJS)
-+ $(LIBTOOL) --mode=link $(CC) -version-info $(LIB_VERSION) \
-+ -rpath $(RPATH) $(LDFLAGS) -o $(LIB_NAME) $(LIB_OBJS) $(LIB_LIBS)
-+
-+$(LIB_NAME:.la=.a): $(LIB_OBJS)
-+ $(LIBTOOL) --mode=link $(CC) -static $(LDFLAGS) -o $(LIB_NAME:.la=.a) $(LIB_OBJS)
-+
-+$(LUA_T): $(LUA_O) $(LIB_NAME)
-+ $(LIBTOOL) --mode=link $(CC) -Wl,-E $(LDFLAGS) -o $@ $(LUA_O) $(LUA_LIBS) -llua
-+
-+lua_test: $(LUA_O) $(LIB_NAME)
-+ $(LIBTOOL) --mode=link $(CC) -static -Wl,-E $(LDFLAGS) -o $@ $(LUA_O) $(LIB_NAME) $(LUA_LIBS)
-+
-+$(LUAC_T): $(LUAC_O) $(LIB_NAME)
-+ $(LIBTOOL) --mode=link $(CC) -static $(LDFLAGS) -o $@ $(LUAC_O) $(LIB_NAME)
-+
-+gentoo_clean:
-+ $(LIBTOOL) --mode=clean $(RM) $(ALL_O:.o=.lo) $(LIB_NAME) lua luac
-+
-+gentoo_all: $(LIB_NAME) $(LIB_NAME:.la=.a) $(LUA_T) lua_test $(LUAC_T)
diff --git a/dev-lang/lua/files/lua-5.1-make_static.patch b/dev-lang/lua/files/lua-5.1-make_static.patch
deleted file mode 100644
index f0125686c2b1..000000000000
--- a/dev-lang/lua/files/lua-5.1-make_static.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -ru lua-5.1.1.orig/src/Makefile lua-5.1.1/src/Makefile
---- lua-5.1.1.orig/src/Makefile 2006-11-21 07:19:31 +0000
-+++ lua-5.1.1/src/Makefile 2006-11-21 07:19:52 +0000
-@@ -196,7 +196,7 @@
- -rpath $(RPATH) -o $(LIB_NAME) $(LIB_OBJS) $(LIB_LIBS)
-
- $(LUA_T): $(LUA_O) $(LIB_NAME)
-- $(LIBTOOL) --mode=link $(CC) -Wl,-E $(LDFLAGS) -o $@ $(LUA_O) $(LUA_LIBS) -llua
-+ $(LIBTOOL) --mode=link $(CC) -static -Wl,-E $(LDFLAGS) -o $@ $(LUA_O) $(LIB_NAME) $(LUA_LIBS)
-
- $(LUAC_T): $(LUAC_O) $(LIB_NAME)
- $(LIBTOOL) --mode=link $(CC) -static -o $@ $(LUAC_O) $(LIB_NAME)
diff --git a/dev-lang/lua/files/lua-5.2-make.patch b/dev-lang/lua/files/lua-5.2-make.patch
deleted file mode 100644
index 431bbde3521e..000000000000
--- a/dev-lang/lua/files/lua-5.2-make.patch
+++ /dev/null
@@ -1,60 +0,0 @@
---- lua-5.1.1.orig/Makefile 2006-06-02 12:53:38.000000000 +0200
-+++ lua-5.1.1/Makefile 2006-11-16 02:16:53.000000000 +0100
-@@ -127,3 +127,18 @@
- .PHONY: all $(PLATS) clean install local none dummy echo pecho lecho newer
-
- # (end of Makefile)
-+
-+# Use libtool for binary installs, etc.
-+
-+export V
-+export LIBTOOL = ../libtool --quiet --tag=CC
-+# See libtool manual about how to set this
-+
-+gentoo_clean:
-+ cd src; $(MAKE) $@
-+
-+gentoo_install:
-+ mkdir -p $(INSTALL_BIN) $(INSTALL_INC) $(INSTALL_LIB)
-+ cd src; $(LIBTOOL) --mode=install $(INSTALL_EXEC) lua luac $(INSTALL_BIN)
-+ cd src; $(INSTALL_DATA) $(TO_INC) $(INSTALL_INC)
-+ cd src; $(LIBTOOL) --mode=install $(INSTALL_DATA) liblua.la $(INSTALL_LIB)
---- lua-5.1.1.orig/src/Makefile 2006-03-22 01:41:49.000000000 +0100
-+++ lua-5.1.1/src/Makefile 2006-11-16 02:10:27.000000000 +0100
-@@ -54,1 +54,1 @@
--$(LUA_T): $(LUA_O) $(LUA_A)
-+origin$(LUA_T): $(LUA_O) $(LUA_A)
-@@ -57,1 +57,1 @@
--$(LUAC_T): $(LUAC_O) $(LUA_A)
-+origin$(LUAC_T): $(LUAC_O) $(LUA_A)
-@@ -185,3 +185,30 @@
- lzio.o: lzio.c lua.h luaconf.h llimits.h lmem.h lstate.h lobject.h ltm.h \
- lzio.h
-
-+
-+export LIBTOOL = ../libtool --quiet --tag=CC
-+export LIB_VERSION = 6:1:1
-+
-+# The following rules use libtool for compiling and linking in order to
-+# provide shared library support.
-+
-+LIB_NAME = liblua.la
-+LIB_OBJS = $(CORE_O:.o=.lo) $(LIB_O:.o=.lo)
-+
-+%.lo %.o: %.c
-+ $(LIBTOOL) --mode=compile $(CC) -c $(CPPFLAGS) $(CFLAGS) -o $@ $<
-+
-+$(LIB_NAME): $(LIB_OBJS)
-+ $(LIBTOOL) --mode=link $(CC) -version-info $(LIB_VERSION) \
-+ -rpath $(RPATH) $(LDFLAGS) -o $(LIB_NAME) $(LIB_OBJS) $(LIB_LIBS)
-+
-+$(LUA_T): $(LUA_O:.o=.lo) $(LIB_NAME)
-+ $(LIBTOOL) --mode=link $(CC) -export-dynamic $(LDFLAGS) -o $@ $(LUA_O:.o=.lo) $(LIB_NAME) $(LUA_LIBS)
-+
-+$(LUAC_T): $(LUAC_O:.o=.lo) $(LIB_NAME)
-+ $(LIBTOOL) --mode=link $(CC) -static $(LDFLAGS) -o $@ $(LUAC_O:.o=.lo) $(LIB_NAME)
-+
-+gentoo_clean:
-+ $(LIBTOOL) --mode=clean $(RM) $(ALL_O:.o=.lo) $(LIB_NAME) lua luac
-+
-+gentoo_all: $(LIB_NAME) $(LUA_T) $(LUAC_T)