summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRafael Martins <rafaelmartins@gentoo.org>2020-02-01 22:52:07 +0100
committerRafael Martins <rafaelmartins@gentoo.org>2020-02-01 22:55:05 +0100
commit5f5a0bb3c9c316e21701d998d39eeec2fe3ac683 (patch)
tree73e2cbc543a9298162baf4015779d2f566a47a4e /dev-lang/luajit/files
parentmedia-plugins/kodi-visualization-spectrum: Cleanup old versions (diff)
downloadgentoo-5f5a0bb3c9c316e21701d998d39eeec2fe3ac683.tar.gz
gentoo-5f5a0bb3c9c316e21701d998d39eeec2fe3ac683.tar.bz2
gentoo-5f5a0bb3c9c316e21701d998d39eeec2fe3ac683.zip
dev-lang/luajit: fix build for musl systems. bug #707588
Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Rafael Martins <rafaelmartins@gentoo.org>
Diffstat (limited to 'dev-lang/luajit/files')
-rw-r--r--dev-lang/luajit/files/luajit-2-ldconfig.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-lang/luajit/files/luajit-2-ldconfig.patch b/dev-lang/luajit/files/luajit-2-ldconfig.patch
new file mode 100644
index 000000000000..add449a60381
--- /dev/null
+++ b/dev-lang/luajit/files/luajit-2-ldconfig.patch
@@ -0,0 +1,31 @@
+From 18c9cf7d3788a8f7408df45df92fc4ae3bcc0d80 Mon Sep 17 00:00:00 2001
+From: Mike Pall <mike>
+Date: Sat, 25 Jan 2020 17:37:12 +0100
+Subject: [PATCH] Fix POSIX install with missing or incompatible ldconfig.
+
+---
+ Makefile | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 07bc70faf..bff53f286 100644
+--- a/Makefile
++++ b/Makefile
+@@ -74,7 +74,7 @@ SYMLINK= ln -sf
+ INSTALL_X= install -m 0755
+ INSTALL_F= install -m 0644
+ UNINSTALL= $(RM)
+-LDCONFIG= ldconfig -n
++LDCONFIG= ldconfig -n 2>/dev/null
+ SED_PC= sed -e "s|^prefix=.*|prefix=$(PREFIX)|" \
+ -e "s|^multilib=.*|multilib=$(MULTILIB)|"
+
+@@ -118,7 +118,7 @@ install: $(INSTALL_DEP)
+ $(RM) $(INSTALL_TSYM) $(INSTALL_DYN) $(INSTALL_SHORT1) $(INSTALL_SHORT2)
+ cd src && test -f $(FILE_SO) && \
+ $(INSTALL_X) $(FILE_SO) $(INSTALL_DYN) && \
+- $(LDCONFIG) $(INSTALL_LIB) && \
++ ( $(LDCONFIG) $(INSTALL_LIB) || : ) && \
+ $(SYMLINK) $(INSTALL_SONAME) $(INSTALL_SHORT1) && \
+ $(SYMLINK) $(INSTALL_SONAME) $(INSTALL_SHORT2) || :
+ cd etc && $(INSTALL_F) $(FILE_MAN) $(INSTALL_MAN)