summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-11-23 15:56:15 +0100
committerThomas Deutschmann <whissi@gentoo.org>2019-11-23 15:56:15 +0100
commit386fed3c1f469a481a3333a09431d88f27e20c4f (patch)
treecf6f356212f503d65acfac42c967e10d01916b88 /dev-lang/php
parentmedia-gfx/imagemagick: bump to v6.9.10-74 (diff)
downloadgentoo-386fed3c1f469a481a3333a09431d88f27e20c4f.tar.gz
gentoo-386fed3c1f469a481a3333a09431d88f27e20c4f.tar.bz2
gentoo-386fed3c1f469a481a3333a09431d88f27e20c4f.zip
dev-lang/php: add missing RESTRICT="!test? ( test )"
Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-lang/php')
-rw-r--r--dev-lang/php/php-7.1.33.ebuild3
-rw-r--r--dev-lang/php/php-7.2.24.ebuild5
-rw-r--r--dev-lang/php/php-7.2.25.ebuild5
-rw-r--r--dev-lang/php/php-7.3.11.ebuild3
-rw-r--r--dev-lang/php/php-7.3.12.ebuild3
5 files changed, 17 insertions, 2 deletions
diff --git a/dev-lang/php/php-7.1.33.ebuild b/dev-lang/php/php-7.1.33.ebuild
index d6b54b2cba35..3ddc7c8941b7 100644
--- a/dev-lang/php/php-7.1.33.ebuild
+++ b/dev-lang/php/php-7.1.33.ebuild
@@ -146,6 +146,9 @@ REQUIRED_USE="
mysql? ( hash || ( mysqli pdo ) )
mysqli? ( hash )
"
+
+RESTRICT="!test? ( test )"
+
PATCHES=(
"${FILESDIR}/php-freetype-2.9.1.patch"
"${FILESDIR}/php-7.1.25-intl-use-icu-namespace.patch"
diff --git a/dev-lang/php/php-7.2.24.ebuild b/dev-lang/php/php-7.2.24.ebuild
index f47ed4aaf955..9b29c8d3e9d5 100644
--- a/dev-lang/php/php-7.2.24.ebuild
+++ b/dev-lang/php/php-7.2.24.ebuild
@@ -151,11 +151,14 @@ REQUIRED_USE="
mysqli? ( hash )
zip-encryption? ( zip )
"
+
+RESTRICT="!test? ( test )"
+
PATCHES=(
"${FILESDIR}/php-freetype-2.9.1.patch"
"${FILESDIR}/php-7.2.13-intl-use-icu-namespace.patch"
)
-RESTRICT="!test? ( test )"
+
PHP_MV="$(ver_cut 1)"
php_install_ini() {
diff --git a/dev-lang/php/php-7.2.25.ebuild b/dev-lang/php/php-7.2.25.ebuild
index 7a4b01c291e3..ec31c9cfef42 100644
--- a/dev-lang/php/php-7.2.25.ebuild
+++ b/dev-lang/php/php-7.2.25.ebuild
@@ -151,11 +151,14 @@ REQUIRED_USE="
mysqli? ( hash )
zip-encryption? ( zip )
"
+
+RESTRICT="!test? ( test )"
+
PATCHES=(
"${FILESDIR}/php-freetype-2.9.1.patch"
"${FILESDIR}/php-7.2.13-intl-use-icu-namespace.patch"
)
-RESTRICT="!test? ( test )"
+
PHP_MV="$(ver_cut 1)"
php_install_ini() {
diff --git a/dev-lang/php/php-7.3.11.ebuild b/dev-lang/php/php-7.3.11.ebuild
index c0862291df30..74fc91e45475 100644
--- a/dev-lang/php/php-7.3.11.ebuild
+++ b/dev-lang/php/php-7.3.11.ebuild
@@ -153,6 +153,9 @@ REQUIRED_USE="
mysql? ( || ( mysqli pdo ) )
zip-encryption? ( zip )
"
+
+RESTRICT="!test? ( test )"
+
PATCHES=(
"${FILESDIR}/php-freetype-2.9.1.patch"
)
diff --git a/dev-lang/php/php-7.3.12.ebuild b/dev-lang/php/php-7.3.12.ebuild
index e466f57d0e3c..8f92a1b3a862 100644
--- a/dev-lang/php/php-7.3.12.ebuild
+++ b/dev-lang/php/php-7.3.12.ebuild
@@ -153,6 +153,9 @@ REQUIRED_USE="
mysql? ( || ( mysqli pdo ) )
zip-encryption? ( zip )
"
+
+RESTRICT="!test? ( test )"
+
PATCHES=(
"${FILESDIR}/php-freetype-2.9.1.patch"
)