summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-11-07 08:16:03 +0000
committerSam James <sam@gentoo.org>2022-11-07 08:16:03 +0000
commit43763a7b650425142ba25aeb09839f967df44ac3 (patch)
tree2411e424139e5832668a246c7f07794691a6ab9b /dev-lang
parentapp-accessibility/brltty: Stabilize 6.5 arm64, #879965 (diff)
downloadgentoo-43763a7b650425142ba25aeb09839f967df44ac3.tar.gz
gentoo-43763a7b650425142ba25aeb09839f967df44ac3.tar.bz2
gentoo-43763a7b650425142ba25aeb09839f967df44ac3.zip
dev-lang/python: fix *FLAGS_FOR_BUILD in 3.12.0_alpha1_p1
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python/python-3.12.0_alpha1_p1.ebuild17
1 files changed, 12 insertions, 5 deletions
diff --git a/dev-lang/python/python-3.12.0_alpha1_p1.ebuild b/dev-lang/python/python-3.12.0_alpha1_p1.ebuild
index 0b85a0a8204b..df8279e32c7e 100644
--- a/dev-lang/python/python-3.12.0_alpha1_p1.ebuild
+++ b/dev-lang/python/python-3.12.0_alpha1_p1.ebuild
@@ -211,13 +211,14 @@ src_configure() {
# disable implicit optimization/debugging flags
local -x OPT=
- # pass system CFLAGS & LDFLAGS as _NODIST, otherwise they'll get
- # propagated to sysconfig for built extensions
- local -x CFLAGS_NODIST=${CFLAGS}
- local -x LDFLAGS_NODIST=${LDFLAGS}
- local -x CFLAGS= LDFLAGS=
if tc-is-cross-compiler ; then
+ # pass system CFLAGS & LDFLAGS as _NODIST, otherwise they'll get
+ # propagated to sysconfig for built extensions
+ local -x CFLAGS_NODIST=${CFLAGS_FOR_BUILD}
+ local -x LDFLAGS_NODIST=${LDFLAGS_FOR_BUILD}
+ local -x CFLAGS= LDFLAGS=
+
# We need to build our own Python on CBUILD first, and feed it in.
# bug #847910
local myeconfargs_cbuild=(
@@ -265,6 +266,12 @@ src_configure() {
popd &> /dev/null || die
fi
+ # pass system CFLAGS & LDFLAGS as _NODIST, otherwise they'll get
+ # propagated to sysconfig for built extensions
+ local -x CFLAGS_NODIST=${CFLAGS}
+ local -x LDFLAGS_NODIST=${LDFLAGS}
+ local -x CFLAGS= LDFLAGS=
+
# Fix implicit declarations on cross and prefix builds. Bug #674070.
if use ncurses; then
append-cppflags -I"${ESYSROOT}"/usr/include/ncursesw