summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-05 10:21:36 +0200
committerMichał Górny <mgorny@gentoo.org>2024-10-05 10:28:26 +0200
commit4a4aba1ecd0b9b8e39bc5715fb11b48f87b01d08 (patch)
tree22234268810d9cb35cca19ed6c3759b06f3ffc7b /dev-lang
parentdev-lang/python: Wrap all of pkg_setup into MERGE_TYPE check (diff)
downloadgentoo-4a4aba1ecd0b9b8e39bc5715fb11b48f87b01d08.tar.gz
gentoo-4a4aba1ecd0b9b8e39bc5715fb11b48f87b01d08.tar.bz2
gentoo-4a4aba1ecd0b9b8e39bc5715fb11b48f87b01d08.zip
dev-lang/python: Run check-reqs for PGO builds too
Extend check-reqs to USE=pgo without FEATURES=test, as we tend to run the same largefile tests in both cases. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python/python-3.13.0_rc3.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/dev-lang/python/python-3.13.0_rc3.ebuild b/dev-lang/python/python-3.13.0_rc3.ebuild
index c97f9faaa41a..c71af7471360 100644
--- a/dev-lang/python/python-3.13.0_rc3.ebuild
+++ b/dev-lang/python/python-3.13.0_rc3.ebuild
@@ -120,7 +120,9 @@ declare -rA PYTHON_KERNEL_CHECKS=(
)
pkg_pretend() {
- use test && check-reqs_pkg_pretend
+ if use pgo || use test; then
+ check-reqs_pkg_pretend
+ fi
if ! use gil || use jit; then
ewarn "USE=-gil and USE=jit flags are considered experimental upstream. Using"
@@ -134,8 +136,9 @@ pkg_pretend() {
pkg_setup() {
if [[ ${MERGE_TYPE} != binary ]]; then
use jit && llvm-r1_pkg_setup
- use test && check-reqs_pkg_setup
if use test || use pgo; then
+ check-reqs_pkg_setup
+
local CONFIG_CHECK
for f in "${!PYTHON_KERNEL_CHECKS[@]}"; do
CONFIG_CHECK+="~${f} "