summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2020-11-12 17:39:10 -0600
committerWilliam Hubbs <williamh@gentoo.org>2020-11-12 17:39:10 -0600
commit56dc87d421b1335c8485680e043883e4f5ddd56a (patch)
tree7e55adafb53ce5065cd007e4084a397dad1842b7 /dev-lang
parentdev-lang/go: mention new @go-rebuild set in pkg_postinst (diff)
downloadgentoo-56dc87d421b1335c8485680e043883e4f5ddd56a.tar.gz
gentoo-56dc87d421b1335c8485680e043883e4f5ddd56a.tar.bz2
gentoo-56dc87d421b1335c8485680e043883e4f5ddd56a.zip
dev-lang/go: add rebuild instructions to 1.14.12 and 1.15.5
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/go/go-1.14.12.ebuild15
-rw-r--r--dev-lang/go/go-1.15.5.ebuild15
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-lang/go/go-1.14.12.ebuild b/dev-lang/go/go-1.14.12.ebuild
index fa07749bdeb3..a65f588db763 100644
--- a/dev-lang/go/go-1.14.12.ebuild
+++ b/dev-lang/go/go-1.14.12.ebuild
@@ -186,3 +186,18 @@ src_install()
install_name_tool -id "${libmac64}" "${D}${libmac64}"
fi
}
+
+pkg_postinst() {
+ [[ -z ${REPLACING_VERSIONS} ]] && return
+ has_version "<sys-apps/portage-3.0.9" && return
+
+ einfo "After ${CATEGORY}/${PN} is updated it is recommended to rebuild"
+ einfo "all packages compiled with previous versions of ${CATEGORY}/${PN}"
+ einfo "due to the static linking nature of go."
+ einfo "If this is not done, the packages compiled with the older"
+ einfo "version of the compiler will not be updated until they are"
+ einfo "updated individually, which could mean they will have"
+ einfo "vulnerabilities."
+ einfo "Run 'emerge @go-rebuild' to rebuild all 'go' packages"
+ einfo "See https://bugs.gentoo.org/752153 for more info"
+}
diff --git a/dev-lang/go/go-1.15.5.ebuild b/dev-lang/go/go-1.15.5.ebuild
index fa07749bdeb3..a65f588db763 100644
--- a/dev-lang/go/go-1.15.5.ebuild
+++ b/dev-lang/go/go-1.15.5.ebuild
@@ -186,3 +186,18 @@ src_install()
install_name_tool -id "${libmac64}" "${D}${libmac64}"
fi
}
+
+pkg_postinst() {
+ [[ -z ${REPLACING_VERSIONS} ]] && return
+ has_version "<sys-apps/portage-3.0.9" && return
+
+ einfo "After ${CATEGORY}/${PN} is updated it is recommended to rebuild"
+ einfo "all packages compiled with previous versions of ${CATEGORY}/${PN}"
+ einfo "due to the static linking nature of go."
+ einfo "If this is not done, the packages compiled with the older"
+ einfo "version of the compiler will not be updated until they are"
+ einfo "updated individually, which could mean they will have"
+ einfo "vulnerabilities."
+ einfo "Run 'emerge @go-rebuild' to rebuild all 'go' packages"
+ einfo "See https://bugs.gentoo.org/752153 for more info"
+}