summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-07-12 10:04:52 +0100
committerSam James <sam@gentoo.org>2023-07-12 10:05:16 +0100
commit6b2dcbb11287d7992ed86ea756170c93a6419ab5 (patch)
tree3f05a94c35fbdd148c68f2cb42f3b4fc217bc35c /dev-libs/botan
parentmedia-video/pipewire: drop 0.3.73 (diff)
downloadgentoo-6b2dcbb11287d7992ed86ea756170c93a6419ab5.tar.gz
gentoo-6b2dcbb11287d7992ed86ea756170c93a6419ab5.tar.bz2
gentoo-6b2dcbb11287d7992ed86ea756170c93a6419ab5.zip
dev-libs/botan: respect MAKEOPTS for tests
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/botan')
-rw-r--r--dev-libs/botan/botan-2.19.2.ebuild6
-rw-r--r--dev-libs/botan/botan-2.19.3-r2.ebuild4
-rw-r--r--dev-libs/botan/botan-3.0.0-r2.ebuild4
-rw-r--r--dev-libs/botan/botan-3.1.0.ebuild4
4 files changed, 9 insertions, 9 deletions
diff --git a/dev-libs/botan/botan-2.19.2.ebuild b/dev-libs/botan/botan-2.19.2.ebuild
index e899feaea56b..9001823c1c74 100644
--- a/dev-libs/botan/botan-2.19.2.ebuild
+++ b/dev-libs/botan/botan-2.19.2.ebuild
@@ -3,9 +3,9 @@
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..11} )
VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/botan.asc
-inherit edo python-r1 toolchain-funcs verify-sig
+inherit edo multiprocessing python-r1 toolchain-funcs verify-sig
MY_P="Botan-${PV}"
DESCRIPTION="C++ crypto library"
@@ -167,7 +167,7 @@ src_configure() {
}
src_test() {
- LD_LIBRARY_PATH="${S}" ./botan-test || die "Validation tests failed"
+ LD_LIBRARY_PATH="${S}" edo ./botan-test --test-threads="$(makeopts_jobs)"
}
src_install() {
diff --git a/dev-libs/botan/botan-2.19.3-r2.ebuild b/dev-libs/botan/botan-2.19.3-r2.ebuild
index 3059e4d2c09e..901ed502d597 100644
--- a/dev-libs/botan/botan-2.19.3-r2.ebuild
+++ b/dev-libs/botan/botan-2.19.3-r2.ebuild
@@ -5,7 +5,7 @@ EAPI=8
PYTHON_COMPAT=( python3_{10..11} )
VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/botan.asc
-inherit edo python-r1 toolchain-funcs verify-sig
+inherit edo multiprocessing python-r1 toolchain-funcs verify-sig
MY_P="Botan-${PV}"
DESCRIPTION="C++ crypto library"
@@ -173,7 +173,7 @@ src_configure() {
}
src_test() {
- LD_LIBRARY_PATH="${S}" ./botan-test$(ver_cut 1) || die "Validation tests failed"
+ LD_LIBRARY_PATH="${S}" edo ./botan-test$(ver_cut 1) --test-threads="$(makeopts_jobs)"
}
src_install() {
diff --git a/dev-libs/botan/botan-3.0.0-r2.ebuild b/dev-libs/botan/botan-3.0.0-r2.ebuild
index fb1e9384a2cc..29f6c986af69 100644
--- a/dev-libs/botan/botan-3.0.0-r2.ebuild
+++ b/dev-libs/botan/botan-3.0.0-r2.ebuild
@@ -5,7 +5,7 @@ EAPI=8
PYTHON_COMPAT=( python3_{10..11} )
VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/botan.asc
-inherit edo python-r1 toolchain-funcs verify-sig
+inherit edo multiprocessing python-r1 toolchain-funcs verify-sig
MY_P="Botan-${PV}"
DESCRIPTION="C++ crypto library"
@@ -176,7 +176,7 @@ src_configure() {
}
src_test() {
- LD_LIBRARY_PATH="${S}" ./botan-test$(ver_cut 1) || die "Validation tests failed"
+ LD_LIBRARY_PATH="${S}" edo ./botan-test$(ver_cut 1) --test-threads="$(makeopts_jobs)"
}
src_install() {
diff --git a/dev-libs/botan/botan-3.1.0.ebuild b/dev-libs/botan/botan-3.1.0.ebuild
index 2fae139bb350..556004d6c660 100644
--- a/dev-libs/botan/botan-3.1.0.ebuild
+++ b/dev-libs/botan/botan-3.1.0.ebuild
@@ -5,7 +5,7 @@ EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/botan.asc
-inherit edo python-r1 toolchain-funcs verify-sig
+inherit edo multiprocessing python-r1 toolchain-funcs verify-sig
MY_P="Botan-${PV}"
DESCRIPTION="C++ crypto library"
@@ -173,7 +173,7 @@ src_configure() {
}
src_test() {
- LD_LIBRARY_PATH="${S}" ./botan-test$(ver_cut 1) || die "Validation tests failed"
+ LD_LIBRARY_PATH="${S}" edo ./botan-test$(ver_cut 1) --test-threads="$(makeopts_jobs)"
}
src_install() {