summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Carlier <devnexen@gmail.com>2017-03-24 19:55:57 +0000
committerMichał Górny <mgorny@gentoo.org>2017-07-15 08:37:41 +0200
commitc82166a3230cca521c494896387c507badd75590 (patch)
tree8fee1d2a51861dc2e9243c9078cdbfd2eb007150 /dev-libs/device-atlas-api-c/device-atlas-api-c-2.1.2_p1.ebuild
parentapp-admin/puppet: add 4.10.4 (diff)
downloadgentoo-c82166a3230cca521c494896387c507badd75590.tar.gz
gentoo-c82166a3230cca521c494896387c507badd75590.tar.bz2
gentoo-c82166a3230cca521c494896387c507badd75590.zip
dev-libs/device-atlas-api-c: Bump to 2.1.2_1 version
Closes: https://github.com/gentoo/gentoo/pull/4287
Diffstat (limited to 'dev-libs/device-atlas-api-c/device-atlas-api-c-2.1.2_p1.ebuild')
-rw-r--r--dev-libs/device-atlas-api-c/device-atlas-api-c-2.1.2_p1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-libs/device-atlas-api-c/device-atlas-api-c-2.1.2_p1.ebuild b/dev-libs/device-atlas-api-c/device-atlas-api-c-2.1.2_p1.ebuild
new file mode 100644
index 000000000000..bc28a136dd90
--- /dev/null
+++ b/dev-libs/device-atlas-api-c/device-atlas-api-c-2.1.2_p1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit cmake-multilib
+
+MY_P="deviceatlas-enterprise-c-${PV/_p/_}"
+
+DESCRIPTION="API to detect devices based on the User-Agent HTTP header"
+HOMEPAGE="https://deviceatlas.com"
+SRC_URI="${MY_P}.tgz"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc x86"
+IUSE="doc examples"
+
+RDEPEND="dev-libs/libpcre[${MULTILIB_USEDEP}]"
+DEPEND="
+ ${RDEPEND}"
+
+RESTRICT="fetch mirror bindist"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}/${PV}-src-cmakelists.patch"
+)
+
+pkg_nofetch() {
+ eerror "Please go to https://deviceatlas.com/deviceatlas-haproxy-module"
+ eerror "And download DeviceAtlas C API"
+ eerror "Then place the file in ${DISTDIR}/${MY_P}.zip"
+}
+
+multilib_src_install_all() {
+ if use doc ; then
+ local -a HTML_DOCS=( Documentation )
+ fi
+
+ if use examples ; then
+ insinto /usr/share/doc/${P}/examples
+ doins examples/daexutil.h
+ doins examples/example{0,1,2,3}.c
+ doins examples/util.c
+ doins examples/EXAMPLES.USAGE
+ fi
+
+ einstalldocs
+}