summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@atlas.cz>2023-02-22 11:39:56 +0100
committerSam James <sam@gentoo.org>2023-02-22 16:13:22 +0000
commit8c478a16109cc83fca3bf86f412e539d105d387d (patch)
tree1f87495992b9b9de6638a55486fafb152f27756c /dev-libs/hyperscan
parentgames-misc/fortune-mod: add github upstream metadata (diff)
downloadgentoo-8c478a16109cc83fca3bf86f412e539d105d387d.tar.gz
gentoo-8c478a16109cc83fca3bf86f412e539d105d387d.tar.bz2
gentoo-8c478a16109cc83fca3bf86f412e539d105d387d.zip
dev-libs/hyperscan: add 5.4.1
- EAPI bump to 8 - drop static-libs use flag - remove unneeded CMAKE_BUILD_TYPE variable Signed-off-by: Petr Vaněk <arkamar@atlas.cz> Closes: https://github.com/gentoo/gentoo/pull/29720 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/hyperscan')
-rw-r--r--dev-libs/hyperscan/Manifest1
-rw-r--r--dev-libs/hyperscan/hyperscan-5.4.1.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-libs/hyperscan/Manifest b/dev-libs/hyperscan/Manifest
index 583b450ea304..b573ca9efb54 100644
--- a/dev-libs/hyperscan/Manifest
+++ b/dev-libs/hyperscan/Manifest
@@ -1 +1,2 @@
DIST hyperscan-5.4.0.tar.gz 1844963 BLAKE2B 1a5af88655854b4c1ec58e6663b6c9c4b6fca0aa9d3e4daad3992daf911b8f359f48a95b65e4f05c71aa644e0271471d016fafaca05d547b838a9c52ea016e27 SHA512 cfec3f43b9e8b3fbb2e761927f3a173c1230f2688da710ec7708f2941ce6f550a1d3cb48b0b0e2ccf709807390117a7e40047cb99190bcc341f37eb3da13ae62
+DIST hyperscan-5.4.1.tar.gz 1848831 BLAKE2B 8be2a05de04a8f32c723e35be16923470ef7dbda830cf0a08c87bfcaff49564f9104f1b48b26a93a7fb157ac74e531841ea43db75bbfe3f836b98e748ccdfd45 SHA512 e9404946287e32604798dc8f9415efe8a47e464cf6e29e5c534ca6074f3674d2d38d4600787d3035ba2898a40e5048fbcd03e23f387ce43f81de4b6c63f70035
diff --git a/dev-libs/hyperscan/hyperscan-5.4.1.ebuild b/dev-libs/hyperscan/hyperscan-5.4.1.ebuild
new file mode 100644
index 000000000000..4377ae025213
--- /dev/null
+++ b/dev-libs/hyperscan/hyperscan-5.4.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit cmake flag-o-matic python-any-r1
+
+DESCRIPTION="High-performance regular expression matching library"
+SRC_URI="https://github.com/intel/hyperscan/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="
+ https://www.hyperscan.io/
+ https://github.com/intel/hyperscan
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="cpu_flags_x86_avx2 cpu_flags_x86_ssse3"
+
+RDEPEND="dev-libs/boost:="
+DEPEND="${RDEPEND}"
+BDEPEND="
+ ${PYTHON_DEPS}
+ dev-util/ragel
+"
+
+# We can't default this to on as it's against the expectation of
+# how CPU_FLAGS_* work for users.
+REQUIRED_USE="cpu_flags_x86_ssse3"
+
+src_prepare() {
+ # Respect user -O flags
+ sed -i '/set(OPT_CX*_FLAG/d' CMakeLists.txt || die
+
+ # upstream workaround
+ append-cxxflags -Wno-redundant-move
+ cmake_src_prepare
+}
+
+src_configure() {
+ use cpu_flags_x86_ssse3 && append-flags -mssse3
+ use cpu_flags_x86_avx2 && append-flags -mavx2
+
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=ON
+ -DBUILD_STATIC_AND_SHARED=OFF
+ -DBUILD_EXAMPLES=OFF
+ -DFAT_RUNTIME=false
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ "${BUILD_DIR}"/bin/unit-hyperscan || die
+}