summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2022-11-01 09:37:49 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2022-11-01 14:03:27 -0500
commit9c71eaabdc9d127a65cee396cd65f3bdad4c7a87 (patch)
treecef13d7bc6197b285b0c97d04f863bb3879e76d5 /dev-libs/icinga-php-library
parentapp-arch/upx: fix running tests (#878977) (diff)
downloadgentoo-9c71eaabdc9d127a65cee396cd65f3bdad4c7a87.tar.gz
gentoo-9c71eaabdc9d127a65cee396cd65f3bdad4c7a87.tar.bz2
gentoo-9c71eaabdc9d127a65cee396cd65f3bdad4c7a87.zip
dev-libs/icinga-php-library: add 0.10.0
Closes: https://bugs.gentoo.org/878993 Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-libs/icinga-php-library')
-rw-r--r--dev-libs/icinga-php-library/Manifest1
-rw-r--r--dev-libs/icinga-php-library/icinga-php-library-0.10.0.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-libs/icinga-php-library/Manifest b/dev-libs/icinga-php-library/Manifest
index 11894031e170..f1f458399b0a 100644
--- a/dev-libs/icinga-php-library/Manifest
+++ b/dev-libs/icinga-php-library/Manifest
@@ -1,2 +1,3 @@
+DIST icinga-php-library-0.10.0.tar.gz 2756161 BLAKE2B 327b9e2939dc4c511fb282faae0b7ca1801d22bd0fac38b9f694dc924e26d6bdd469d0118ef44e93a42d5480b2bb15ff5ec6aec19e00e5ae33c9c40d78643f9f SHA512 9619e5b68bb58f7f6264633ca1a24de84dcd78626d4675ecbf3fbe8601031ffcbc4c227e9029d5ad87e1be04cad562c93911fdcbda889046cdb9a416dd195530
DIST icinga-php-library-0.6.1.tar.gz 2159137 BLAKE2B 93287845a6c06653faca1850b18c880d023d4bf22c707616a21b92bd252661c811a33c7515fbf19a06936358244c7703bae83cc2e44dee460fe7a46bfa82d345 SHA512 64800727e60630224993bda89494921a3e10f14ccb43b8f57d023b372806ce9253cdf7f6e933df8b494ef0369784714ac857fb288f7f08880c29e8643f25e2ec
DIST icinga-php-library-0.8.1.tar.gz 2183054 BLAKE2B 56108f3251211c05ba29827ece49ea1b27bc22b0f0ae459a2f34d5f2ed106ebac1e14c15e1f69c4a3d862d163a0e1265ccb9e5ab0123e24a18e72549af1ee951 SHA512 3da7ad25c569651bc29757a89971d9dfce4cae177619ef70bcb93f1c155400b68ee8b76279b4914454edef41de0cb4d729c47446df622b04494987e0bf4e1098
diff --git a/dev-libs/icinga-php-library/icinga-php-library-0.10.0.ebuild b/dev-libs/icinga-php-library/icinga-php-library-0.10.0.ebuild
new file mode 100644
index 000000000000..c2b93055e450
--- /dev/null
+++ b/dev-libs/icinga-php-library/icinga-php-library-0.10.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Icinga PHP libraries for Icinga Web 2"
+HOMEPAGE="https://github.com/Icinga/icinga-php-library"
+MY_GITHUB_AUTHOR="Icinga"
+SRC_URI="https://github.com/${MY_GITHUB_AUTHOR}/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-lang/php:*"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_install() {
+ insinto "/usr/share/icinga-php/ipl"
+ cd "${S}"
+ doins -r *
+}