summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-08-03 22:06:26 +0200
committerConrad Kostecki <conikost@gentoo.org>2022-08-03 22:07:55 +0200
commitcb7045df8b274607670d1e1818a2853a4597363f (patch)
tree2340b3860941ef23574665c4fd1d30014b851d7f /dev-libs/intel-compute-runtime
parentnet-libs/libupnp: add 1.14.13 (diff)
downloadgentoo-cb7045df8b274607670d1e1818a2853a4597363f.tar.gz
gentoo-cb7045df8b274607670d1e1818a2853a4597363f.tar.bz2
gentoo-cb7045df8b274607670d1e1818a2853a4597363f.zip
dev-libs/intel-compute-runtime: add 22.30.23789
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-libs/intel-compute-runtime')
-rw-r--r--dev-libs/intel-compute-runtime/Manifest1
-rw-r--r--dev-libs/intel-compute-runtime/intel-compute-runtime-22.30.23789.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/dev-libs/intel-compute-runtime/Manifest b/dev-libs/intel-compute-runtime/Manifest
index 47e3ac7018d2..bf39bee8eb9b 100644
--- a/dev-libs/intel-compute-runtime/Manifest
+++ b/dev-libs/intel-compute-runtime/Manifest
@@ -3,3 +3,4 @@ DIST intel-compute-runtime-22.26.23599.tar.gz 5574368 BLAKE2B 6302ced3e75d7d31a5
DIST intel-compute-runtime-22.27.23681.tar.gz 5593740 BLAKE2B 5d627623e7b0ec89aacb5dfee7442803254c233382a2b242f0f856d51256a60d614e6a3d88ec5c0d494ad25211adb5d75a13b5ff86739795e46aa50e7a9686e4 SHA512 1269126ff447f7c0e1ec9e33ef5245476afe44812a2b6ded86f6219ae61c74bf862a152a740684638b12cdcffce454af3a3be5b4b16c3b7f9c0e7b660b73701a
DIST intel-compute-runtime-22.28.23726.tar.gz 5609087 BLAKE2B ec5b70090e58b08d63f006034d4326426f4caf42b681e32027da79876d019875540ed52cf048fe9919d54bcbac5911bac6ea8a228b8020b9e56d5a61bd1c3c2b SHA512 5e59c678a146eb995e6bcfcedb96c812e40d4561cd4725740742691fc79fd597f4c31659b08763376263ff6100a0f7960f4d5f05a35ff97bed2dc870df189c48
DIST intel-compute-runtime-22.29.23750.tar.gz 5613298 BLAKE2B 7c662c85732d2053d64a68651484030a16aeae4bac3943c2891771c865c623912d4466dea8258caf7a150d34cc06e2f7e451fde831cc6023ebee4036d55207f0 SHA512 8f9b7f87a93585a0a71d2e5339ec64d01f150722051ca844c47db1803491b6c4d8a371e3332ce6c0e85c6e129711cdba210000176904e922577c3e6c42b791a2
+DIST intel-compute-runtime-22.30.23789.tar.gz 5625283 BLAKE2B 0a59926453ae8a58afbd49a40d8b94ac9171d23a141f967c6d908b26ab66decbd082d42fe6e75bf9fd2b4327cbe5b4c71f6ef390a8a62435c06b749078d67cd4 SHA512 8f2caee7376a9a489efc7ee5b907786d1fc04ed3143dfc66e28069f4d19c13393c64cf6ea0159ce269ee2198dadddd7ef967a11efac90e616ce1f1c996b07153
diff --git a/dev-libs/intel-compute-runtime/intel-compute-runtime-22.30.23789.ebuild b/dev-libs/intel-compute-runtime/intel-compute-runtime-22.30.23789.ebuild
new file mode 100644
index 000000000000..af9f16456a1e
--- /dev/null
+++ b/dev-libs/intel-compute-runtime/intel-compute-runtime-22.30.23789.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CMAKE_BUILD_TYPE="Release"
+MY_PN="${PN/intel-/}"
+MY_P="${MY_PN}-${PV}"
+
+inherit cmake flag-o-matic
+
+DESCRIPTION="Intel Graphics Compute Runtime for oneAPI Level Zero and OpenCL Driver"
+HOMEPAGE="https://github.com/intel/compute-runtime"
+SRC_URI="https://github.com/intel/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+l0 +vaapi"
+
+RDEPEND=">=media-libs/gmmlib-22.1.7:="
+
+DEPEND="
+ ${DEPEND}
+ >=dev-libs/intel-metrics-library-0_pre20220526:=
+ dev-libs/libnl:3
+ dev-libs/libxml2:2
+ >=dev-util/intel-graphics-compiler-1.0.11485
+ >=dev-util/intel-graphics-system-controller-0.8.0:=
+ media-libs/mesa
+ >=virtual/opencl-3
+ l0? ( >=dev-libs/level-zero-1.8.5:= )
+ vaapi? (
+ x11-libs/libdrm[video_cards_intel]
+ x11-libs/libva
+ )
+"
+
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( "README.md" "FAQ.md" )
+
+PATCHES=( "${FILESDIR}/${PN}-22.24.23453-remove-fortify-sources.patch" )
+
+src_prepare() {
+ # Remove '-Werror' from default
+ sed -e '/Werror/d' -i CMakeLists.txt || die
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ # See https://github.com/intel/compute-runtime/issues/531
+ filter-flags -flto=* -flto
+
+ local mycmakeargs=(
+ -DCCACHE_ALLOWED="OFF"
+ -DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr"
+ -DCMAKE_INSTALL_LIBDIR="$(get_libdir)"
+ -DBUILD_WITH_L0="$(usex l0)"
+ -DDISABLE_LIBVA="$(usex !vaapi)"
+ -DNEO__METRICS_LIBRARY_INCLUDE_DIR="${ESYSROOT}/usr/include"
+ -DKHRONOS_GL_HEADERS_DIR="${ESYSROOT}/usr/include"
+ -DOCL_ICD_VENDORDIR="${EPREFIX}/etc/OpenCL/vendors"
+ -DSUPPORT_DG1="ON"
+ -Wno-dev
+
+ # See https://github.com/intel/intel-graphics-compiler/issues/204
+ # -DNEO_DISABLE_BUILTINS_COMPILATION="ON"
+
+ # If enabled, tests are automatically run during
+ # the compile phase and we cannot run them because
+ # they require permissions to access the hardware.
+ -DSKIP_UNIT_TESTS="1"
+ )
+
+ cmake_src_configure
+}