summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Zander <negril.nx+gentoo@gmail.com>2023-09-06 17:02:49 +0200
committerSam James <sam@gentoo.org>2023-09-24 23:09:56 +0100
commit39c69db21c0c4d66fb2685b369b33b5ed3397ff2 (patch)
tree6c08e79b39b50248544a353eacfca4d31ad46547 /dev-libs/libcgroup
parentgui-wm/dwl: new package, migrated from ::guru, add 0.4, 9999, 9999-r1 (diff)
downloadgentoo-39c69db21c0c4d66fb2685b369b33b5ed3397ff2.tar.gz
gentoo-39c69db21c0c4d66fb2685b369b33b5ed3397ff2.tar.bz2
gentoo-39c69db21c0c4d66fb2685b369b33b5ed3397ff2.zip
dev-libs/libcgroup: bump 3.1.0, fix CG_CLASSIFY=Yes
Fixes SRC_URI. Make CG_CLASSIFY=Yes work by adjusting executable path and add parsing of /etc/cgroup/cgconfig.d. Closes: https://bugs.gentoo.org/628802 Signed-off-by: Paul Zander <negril.nx+gentoo@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/32656 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/libcgroup')
-rw-r--r--dev-libs/libcgroup/Manifest1
-rw-r--r--dev-libs/libcgroup/files/cgconfig.confd-r28
-rw-r--r--dev-libs/libcgroup/files/cgconfig.initd-r253
-rw-r--r--dev-libs/libcgroup/libcgroup-3.0.0-r1.ebuild115
-rw-r--r--dev-libs/libcgroup/libcgroup-3.1.0.ebuild115
5 files changed, 292 insertions, 0 deletions
diff --git a/dev-libs/libcgroup/Manifest b/dev-libs/libcgroup/Manifest
index fc793519300c..169245e7cdd3 100644
--- a/dev-libs/libcgroup/Manifest
+++ b/dev-libs/libcgroup/Manifest
@@ -1,3 +1,4 @@
DIST libcgroup-0.41.tar.bz2 500120 BLAKE2B 3410b430aa58613b5b9abedba05bef99b1b8a1fd619d55fb446ab951e052a336efc918879217055bceee886a03d97c3ff46028a87e8231212653a886cfb80521 SHA512 1aedb02cd2ce3bc2e2a328a247a92976ad0978ca4d3aee4eb671fbcc6bb270348efc78dcf84f27fc500f8bfb9bb57c7d6e4d429ef2bc69e4e5118b7cd895a6bd
DIST libcgroup-2.0.tar.bz2 953191 BLAKE2B d4fe008a51a4f90047210a3c8e4ce48b1c4a126111ccc7fe919404b1782ea764404894a43a651e0d6b2674d02fb031cb56cf7a689c57600d856c03536524bb63 SHA512 b2c5d1128536bf49782415df2d1530cf48bdb287e5d2abdee68f9fa780d995d9bae79f97da5f0c437130d66054c96301b319cd1631a3b0efbc5bfe1e3414dc4b
DIST libcgroup-3.0.0.tar.gz 1125800 BLAKE2B 5d4999ac513de756ffe741d2e959c01d8500a2000f521dff31832e1ef545869fb9c8ae1c78d05aaa051e7e6e68266bd57a751ba3aa897966a83ff50128090ba5 SHA512 1e8a7c9a71d928ab0e354254b007b30fc159a30e441bd52a03ded142420c94e130594bb512680c62fc22f5193934fb78afc31453342b032d1db3197fd4c3e606
+DIST libcgroup-3.1.0.tar.gz 1223547 BLAKE2B 3cd3ca779b4453df71aba584ad8fe654fb55478ad89b36ba5deccf46e3ef331b11dc32a9a72dfa525784558701a72fd0777e05275233e599015ae93269661534 SHA512 84272e811422f2105e275ccadbd333fe6da495da5504cd97acd3101718e27b52e0f56b62f847933b32d613e15c170d1b998d85a89c1591e8ce37c33043f3e00b
diff --git a/dev-libs/libcgroup/files/cgconfig.confd-r2 b/dev-libs/libcgroup/files/cgconfig.confd-r2
new file mode 100644
index 000000000000..2770c85e2ee1
--- /dev/null
+++ b/dev-libs/libcgroup/files/cgconfig.confd-r2
@@ -0,0 +1,8 @@
+# /etc/conf.d/cgconfig: config file for /etc/init.d/cgconfig
+
+# Configuration file location
+CG_CONFIGFILE="/etc/cgroup/cgconfig.conf"
+CG_CONFIGDIR="/etc/cgroup/cgconfig.d"
+
+# Enable calssifying pid according to rules if necessary
+CG_CLASSIFY=No
diff --git a/dev-libs/libcgroup/files/cgconfig.initd-r2 b/dev-libs/libcgroup/files/cgconfig.initd-r2
new file mode 100644
index 000000000000..aaf3ea88031b
--- /dev/null
+++ b/dev-libs/libcgroup/files/cgconfig.initd-r2
@@ -0,0 +1,53 @@
+#!/sbin/openrc-run
+# Copyright 1999-2023 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+CGCONFIGPARSER="/usr/sbin/cgconfigparser"
+CGCLASSIFY="/usr/bin/cgclassify"
+: "${CG_CONFIGFILE:=/etc/cgroup/cgconfig.conf}"
+: "${CG_CONFIGDIR:=/etc/cgroup/cgconfig.d}"
+description="Control Group Configuration Service"
+
+start()
+{
+ ebegin "Setting up CGroups"
+ "${CGCONFIGPARSER}" "--load=${CG_CONFIGFILE}" "--load-directory=${CG_CONFIGDIR}" >/dev/null 2>&1
+ eend "$?"
+}
+
+start_post()
+{
+ # Classify PID according to the rules if requested
+ yesno "${CG_CLASSIFY}" || return 0
+ ebegin "Classifying PID to CGroups"
+ local pid
+ for pid in $(pgrep ''); do
+ ${CGCLASSIFY} ${pid} || einfo "Classifying ${pid} failed"
+ done
+ eend "$?"
+}
+
+stop()
+{
+ cgconfig_umount
+}
+
+cgconfig_umount()
+{
+ local ctrl eq mnt_pnt mnt_pts
+
+ while read ctrl eq mnt_pnt; do
+ case "${ctrl}" in
+ (\#*) continue ;;
+ (mount*) mnt_pts=true;;
+ (\}*) mnt_pts= ;;
+ (*)
+ [ -n "${mnt_pts}" ] || continue
+ mnt_pnt="${mnt_pnt%;}"
+ ebegin "Unmounting ${mnt_pnt}"
+ umount "${mnt_pnt}"
+ eend "$?"
+ ;;
+ esac
+ done < "${CG_CONFIGFILE}"
+}
diff --git a/dev-libs/libcgroup/libcgroup-3.0.0-r1.ebuild b/dev-libs/libcgroup/libcgroup-3.0.0-r1.ebuild
new file mode 100644
index 000000000000..9fdbb7a5bde3
--- /dev/null
+++ b/dev-libs/libcgroup/libcgroup-3.0.0-r1.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic linux-info pam systemd
+
+DESCRIPTION="Tools and libraries to configure and manage kernel control groups"
+HOMEPAGE="https://github.com/libcgroup/libcgroup"
+SRC_URI="https://github.com/libcgroup/libcgroup/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+daemon pam static-libs test +tools"
+REQUIRED_USE="daemon? ( tools )"
+
+# Test failure needs investigation
+RESTRICT="!test? ( test ) test"
+
+BDEPEND="
+ sys-devel/bison
+ sys-devel/flex
+"
+DEPEND="
+ elibc_musl? ( sys-libs/fts-standalone )
+ pam? ( sys-libs/pam )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-3.0.0-configure-bashism.patch"
+ "${FILESDIR}/${PN}-3.0.0-musl-strerror_r.patch"
+)
+
+pkg_setup() {
+ local CONFIG_CHECK="~CGROUPS"
+ if use daemon; then
+ CONFIG_CHECK="${CONFIG_CHECK} ~CONNECTOR ~PROC_EVENTS"
+ fi
+ linux-info_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ # Change rules file location
+ find src -name '*.c' -o -name '*.h' -0 \
+ | xargs -0 sed -i '/^#define/s:/etc/cg:/etc/cgroup/cg:'
+ sed -i 's:/etc/cg:/etc/cgroup/cg:' \
+ doc/man/cg* samples/config/*.conf README* || die "sed failed"
+
+ # Drop native libcgconfig init config
+ sed -i '/^man_MANS/s:cgred.conf.5::' \
+ doc/man/Makefile.am || die "sed failed"
+
+ # If we're not running tests, don't bother building them.
+ if ! use test; then
+ sed -i '/^SUBDIRS/s:tests::' Makefile.am || die
+ fi
+
+ eautoreconf
+}
+
+src_configure() {
+ if use elibc_musl; then
+ append-ldflags -lfts
+ fi
+
+ local myconf=(
+ "$(use_enable static-libs static)"
+ "$(use_enable daemon)"
+ "$(use_enable pam)"
+ "$(use_enable tools)"
+ "$(use_enable test tests)"
+ )
+
+ if use pam; then
+ myconf+=( "--enable-pam-module-dir=$(getpam_mod_dir)" )
+ fi
+
+ econf "${myconf[@]}"
+}
+
+src_test() {
+ # Run just the unit tests rather than the full lot as they
+ # need fewer permissions, no containers, etc.
+ emake -C tests/gunit check
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+
+ insinto /etc/cgroup
+ doins samples/config/cgconfig.conf
+ doins samples/config/cgrules.conf
+ doins samples/config/cgsnapshot_blacklist.conf
+
+ keepdir /etc/cgroup/cgconfig.d
+ keepdir /etc/cgroup/cgrules.d
+
+ if use tools; then
+ newconfd "${FILESDIR}/cgconfig.confd-r2" cgconfig
+ newinitd "${FILESDIR}/cgconfig.initd-r2" cgconfig
+ systemd_dounit "${FILESDIR}/cgconfig.service"
+ systemd_dounit "${FILESDIR}/cgrules.service"
+ fi
+
+ if use daemon; then
+ newconfd "${FILESDIR}/cgred.confd-r2" cgred
+ newinitd "${FILESDIR}/cgred.initd-r1" cgred
+ fi
+}
diff --git a/dev-libs/libcgroup/libcgroup-3.1.0.ebuild b/dev-libs/libcgroup/libcgroup-3.1.0.ebuild
new file mode 100644
index 000000000000..9fdbb7a5bde3
--- /dev/null
+++ b/dev-libs/libcgroup/libcgroup-3.1.0.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic linux-info pam systemd
+
+DESCRIPTION="Tools and libraries to configure and manage kernel control groups"
+HOMEPAGE="https://github.com/libcgroup/libcgroup"
+SRC_URI="https://github.com/libcgroup/libcgroup/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+daemon pam static-libs test +tools"
+REQUIRED_USE="daemon? ( tools )"
+
+# Test failure needs investigation
+RESTRICT="!test? ( test ) test"
+
+BDEPEND="
+ sys-devel/bison
+ sys-devel/flex
+"
+DEPEND="
+ elibc_musl? ( sys-libs/fts-standalone )
+ pam? ( sys-libs/pam )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-3.0.0-configure-bashism.patch"
+ "${FILESDIR}/${PN}-3.0.0-musl-strerror_r.patch"
+)
+
+pkg_setup() {
+ local CONFIG_CHECK="~CGROUPS"
+ if use daemon; then
+ CONFIG_CHECK="${CONFIG_CHECK} ~CONNECTOR ~PROC_EVENTS"
+ fi
+ linux-info_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ # Change rules file location
+ find src -name '*.c' -o -name '*.h' -0 \
+ | xargs -0 sed -i '/^#define/s:/etc/cg:/etc/cgroup/cg:'
+ sed -i 's:/etc/cg:/etc/cgroup/cg:' \
+ doc/man/cg* samples/config/*.conf README* || die "sed failed"
+
+ # Drop native libcgconfig init config
+ sed -i '/^man_MANS/s:cgred.conf.5::' \
+ doc/man/Makefile.am || die "sed failed"
+
+ # If we're not running tests, don't bother building them.
+ if ! use test; then
+ sed -i '/^SUBDIRS/s:tests::' Makefile.am || die
+ fi
+
+ eautoreconf
+}
+
+src_configure() {
+ if use elibc_musl; then
+ append-ldflags -lfts
+ fi
+
+ local myconf=(
+ "$(use_enable static-libs static)"
+ "$(use_enable daemon)"
+ "$(use_enable pam)"
+ "$(use_enable tools)"
+ "$(use_enable test tests)"
+ )
+
+ if use pam; then
+ myconf+=( "--enable-pam-module-dir=$(getpam_mod_dir)" )
+ fi
+
+ econf "${myconf[@]}"
+}
+
+src_test() {
+ # Run just the unit tests rather than the full lot as they
+ # need fewer permissions, no containers, etc.
+ emake -C tests/gunit check
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+
+ insinto /etc/cgroup
+ doins samples/config/cgconfig.conf
+ doins samples/config/cgrules.conf
+ doins samples/config/cgsnapshot_blacklist.conf
+
+ keepdir /etc/cgroup/cgconfig.d
+ keepdir /etc/cgroup/cgrules.d
+
+ if use tools; then
+ newconfd "${FILESDIR}/cgconfig.confd-r2" cgconfig
+ newinitd "${FILESDIR}/cgconfig.initd-r2" cgconfig
+ systemd_dounit "${FILESDIR}/cgconfig.service"
+ systemd_dounit "${FILESDIR}/cgrules.service"
+ fi
+
+ if use daemon; then
+ newconfd "${FILESDIR}/cgred.confd-r2" cgred
+ newinitd "${FILESDIR}/cgred.initd-r1" cgred
+ fi
+}