summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2015-10-07 18:33:34 +0200
committerChristoph Mende <angelos@gentoo.org>2015-10-07 19:49:56 +0200
commit0f76084ea41b71792fa5a49a190aed9b7172ba1e (patch)
tree6a998242a5924f1b82dfd5e1eeb7afe6c687b4af /dev-libs/libdbh/libdbh-5.0.19.ebuild
parentdev-libs/libtubo: Initial import (diff)
downloadgentoo-0f76084ea41b71792fa5a49a190aed9b7172ba1e.tar.gz
gentoo-0f76084ea41b71792fa5a49a190aed9b7172ba1e.tar.bz2
gentoo-0f76084ea41b71792fa5a49a190aed9b7172ba1e.zip
dev-libs/libdbh: Initial import
Package-Manager: portage-2.2.22
Diffstat (limited to 'dev-libs/libdbh/libdbh-5.0.19.ebuild')
-rw-r--r--dev-libs/libdbh/libdbh-5.0.19.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-libs/libdbh/libdbh-5.0.19.ebuild b/dev-libs/libdbh/libdbh-5.0.19.ebuild
new file mode 100644
index 000000000000..633df46aff97
--- /dev/null
+++ b/dev-libs/libdbh/libdbh-5.0.19.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils
+
+MY_P=${PN}2-${PV}
+
+DESCRIPTION="a small library to create and manage 64-bit disk based hash tables"
+HOMEPAGE="https://www.gnu.org/software/libdbh/"
+SRC_URI="mirror://sourceforge/dbh/dbh/${PV}/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ virtual/pkgconfig"
+
+S="${WORKDIR}"/${MY_P}
+
+pkg_setup() {
+ DOCS=( AUTHORS ChangeLog NEWS README TODO )
+}
+
+src_prepare() {
+ sed -i -e "s:-O2:${CFLAGS}:" m4/rfm-conditionals.m4 || die
+ eautoreconf
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}