summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDennis Lamm <expeditioneer@gentoo.org>2021-07-21 19:21:08 +0200
committerDennis Lamm <expeditioneer@gentoo.org>2021-07-21 19:48:22 +0200
commit88c5e4df38c6bae4c44f7aff21443ff1a7866211 (patch)
tree8897231aba08462f6f5cdafcaf87deab6d25440a /dev-libs/libnest2d/files/libnest2d-0.4-gnu-install-dirs.patch
parentprofiles/arch/riscv: mask USE=ruby on net-analyzer/rrdtool (diff)
downloadgentoo-88c5e4df38c6bae4c44f7aff21443ff1a7866211.tar.gz
gentoo-88c5e4df38c6bae4c44f7aff21443ff1a7866211.tar.bz2
gentoo-88c5e4df38c6bae4c44f7aff21443ff1a7866211.zip
dev-libs/libnest2d: replaced hard coded install dirs
now using CMAKEs 'GNUInstallDirs' Bug: https://bugs.gentoo.org/802906 Signed-off-by: Dennis Lamm <expeditioneer@gentoo.org> Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Dennis Lamm <expeditioneer@gentoo.org>
Diffstat (limited to 'dev-libs/libnest2d/files/libnest2d-0.4-gnu-install-dirs.patch')
-rw-r--r--dev-libs/libnest2d/files/libnest2d-0.4-gnu-install-dirs.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-libs/libnest2d/files/libnest2d-0.4-gnu-install-dirs.patch b/dev-libs/libnest2d/files/libnest2d-0.4-gnu-install-dirs.patch
new file mode 100644
index 000000000000..34484426f302
--- /dev/null
+++ b/dev-libs/libnest2d/files/libnest2d-0.4-gnu-install-dirs.patch
@@ -0,0 +1,25 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -114,6 +114,7 @@
+ endif()
+
+ include(CMakePackageConfigHelpers)
++include(GNUInstallDirs)
+
+ write_basic_package_version_file(
+ "${CMAKE_CURRENT_BINARY_DIR}/cmakeexports/${PROJECT_NAME}ConfigVersion.cmake"
+@@ -123,10 +124,10 @@
+
+ install(TARGETS libnest2d libnest2d_headeronly ${LIBNAME}
+ EXPORT ${PROJECT_NAME}Targets
+- RUNTIME DESTINATION bin
+- ARCHIVE DESTINATION lib
+- LIBRARY DESTINATION lib
+- INCLUDES DESTINATION include)
++ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
++ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
++ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
++ INCLUDES DESTINATION ${CMAKE_INSTALL_INCLUDEDIR})
+
+ export(EXPORT ${PROJECT_NAME}Targets
+ FILE "${CMAKE_CURRENT_BINARY_DIR}/cmakeexports/${PROJECT_NAME}Targets.cmake"