summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2015-08-19 07:10:06 +0200
committerJeroen Roovers <jer@gentoo.org>2015-08-19 07:10:06 +0200
commitc4456f9d089d84626a4ecb2a506dc9afaa77680f (patch)
treecf233315a3977268319687e4eae4fd63f90e30c4 /dev-libs/libnl/files
parentwww-client/vivaldi: Version bump. (diff)
downloadgentoo-c4456f9d089d84626a4ecb2a506dc9afaa77680f.tar.gz
gentoo-c4456f9d089d84626a4ecb2a506dc9afaa77680f.tar.bz2
gentoo-c4456f9d089d84626a4ecb2a506dc9afaa77680f.zip
Old.
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-libs/libnl/files')
-rw-r--r--dev-libs/libnl/files/libnl-3.2.23-python.patch26
-rw-r--r--dev-libs/libnl/files/libnl-3.2.23-utils.h41
2 files changed, 0 insertions, 67 deletions
diff --git a/dev-libs/libnl/files/libnl-3.2.23-python.patch b/dev-libs/libnl/files/libnl-3.2.23-python.patch
deleted file mode 100644
index 559376b546c6..000000000000
--- a/dev-libs/libnl/files/libnl-3.2.23-python.patch
+++ /dev/null
@@ -1,26 +0,0 @@
---- a/python/setup.py.in
-+++ b/python/setup.py.in
-@@ -9,6 +9,7 @@
- sources = ['netlink/capi.i'],
- include_dirs = include,
- swig_opts = opts,
-+ library_dirs=['@top_builddir@/lib/.libs'],
- libraries = ['nl-3'],
- )
-
-@@ -16,6 +17,7 @@
- sources = ['netlink/route/capi.i'],
- include_dirs = include,
- swig_opts = opts,
-+ library_dirs=['@top_builddir@/lib/.libs'],
- libraries = ['nl-3', 'nl-route-3'],
- )
-
-@@ -23,6 +25,7 @@
- sources = ['netlink/genl/capi.i'],
- include_dirs = include,
- swig_opts = opts,
-+ library_dirs=['@top_builddir@/lib/.libs'],
- libraries = ['nl-3', 'nl-genl-3'],
- )
-
diff --git a/dev-libs/libnl/files/libnl-3.2.23-utils.h b/dev-libs/libnl/files/libnl-3.2.23-utils.h
deleted file mode 100644
index 7836c3076ff4..000000000000
--- a/dev-libs/libnl/files/libnl-3.2.23-utils.h
+++ /dev/null
@@ -1,41 +0,0 @@
-struct list_head {
- struct list_head *next;
-};
-
-#define LIST_HEAD(name) \
- struct list_head name = { &(name) }
-
-static inline int list_empty(const struct list_head *head)
-{
- return head->next == head;
-}
-
-static inline void list_add(struct list_head *new, struct list_head *head)
-{
- new->next = head->next;
- head->next = new;
-}
-
-static inline void list_del(struct list_head *entry, struct list_head *prev)
-{
- prev->next = entry->next;
- entry->next = entry;
-}
-
-#define list_for_each_safe(pos, n, head) \
- for (n = (head), pos = (head)->next; pos != (head); \
- n = pos, pos = n->next)
-
-#undef offsetof
-#define offsetof(TYPE, MEMBER) ((size_t) &((TYPE *)0)->MEMBER)
-
-#define container_of(ptr, type, member) ({ \
- const typeof( ((type *)0)->member ) *__mptr = (ptr); \
- (type *)( (char *)__mptr - offsetof(type,member) );})
-
-#ifdef DEBUG
-#define pynl_dbg(fmt, ...) \
- fprintf(stderr, "%s: " fmt, __func__, __VA_ARGS__)
-#else
-#define pynl_dbg(fmt, ...)
-#endif