summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/libqtxdg
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/libqtxdg')
-rw-r--r--dev-libs/libqtxdg/Manifest3
-rw-r--r--dev-libs/libqtxdg/libqtxdg-0.5.3.ebuild38
-rw-r--r--dev-libs/libqtxdg/libqtxdg-1.1.0.ebuild43
-rw-r--r--dev-libs/libqtxdg/libqtxdg-1.2.0.ebuild44
-rw-r--r--dev-libs/libqtxdg/metadata.xml6
5 files changed, 134 insertions, 0 deletions
diff --git a/dev-libs/libqtxdg/Manifest b/dev-libs/libqtxdg/Manifest
new file mode 100644
index 000000000000..590b8870a36a
--- /dev/null
+++ b/dev-libs/libqtxdg/Manifest
@@ -0,0 +1,3 @@
+DIST libqtxdg-0.5.3.tar.xz 52948 SHA256 ce45c0de4f1f5c4587178cc8a1d12561b3d101461c71ce3715ed9d5d6a6ad6f4 SHA512 02211e7fd8fc5db014e642c8222a5bade95eef5da8f60c39567cac5f4da385c7b99b454d68a6c88e211981dd98bcb1d17d53c105dcf3e7b89b17b171af904ec2 WHIRLPOOL 1f4f2bc8e6731c0fbc31dcb0f8264f7aafe329f022a74f4bf43828c8016b8af02077d9dcfd1ee0a574d7441db4ba7676dfd0f431d727059b59ccefd5fbe9b216
+DIST libqtxdg-1.1.0.tar.xz 54268 SHA256 5c90989fcd13387cc8a7905a03e0b65f76aa28545cb9733625e1d88fd6ff4002 SHA512 67e47547d5719fa5a2c4f4b6d6f8c0bc285503ed611f1a3e8b1b5e2cf46f18e98d8b1394c1f68d16cbb0b5ec8721934f50401fb36bfae41bef574c4716b9937a WHIRLPOOL 24f4d35d85eabb0ebf53dcf60fee67fbbe72aca54060039d7f2e2418ab77b7f38a9822ed6c4f512bd4d9c5c66a9db5dee30b173e72d9b5bbc998c13496811839
+DIST libqtxdg-1.2.0.tar.xz 55704 SHA256 88c9b01b56fea205226b53642833963e4f27471de3b90e93e9b650ca28d098d9 SHA512 f3d6cacc21aec970fcba7de963d4703ec4ed057b0cacacb2458d30260be4ecfaf463e761033eca8c60254dcc83e593e0d722ad6097d837e46434297be0d68398 WHIRLPOOL 01ed25db765faa79973114683808a7c4fa65a05cba32f1221afea0328c77d17589f84af93f4829f95665ecdf55828676c0cab77fb5d0a97eb223338464bf9e26
diff --git a/dev-libs/libqtxdg/libqtxdg-0.5.3.ebuild b/dev-libs/libqtxdg/libqtxdg-0.5.3.ebuild
new file mode 100644
index 000000000000..ca79b77b6709
--- /dev/null
+++ b/dev-libs/libqtxdg/libqtxdg-0.5.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-utils
+
+DESCRIPTION="A Qt implementation of XDG standards"
+HOMEPAGE="http://lxqt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://git.lxde.org/git/lxde/${PN}.git"
+else
+ SRC_URI="http://lxqt.org/downloads/${PN}/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="test"
+
+CDEPEND="sys-apps/file
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4"
+DEPEND="${CDEPEND}
+ test? ( dev-qt/qttest:4 )"
+RDEPEND="${CDEPEND}
+ x11-misc/xdg-utils"
+
+S=${WORKDIR}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use test BUILD_TESTS)
+ )
+ cmake-utils_src_configure
+}
diff --git a/dev-libs/libqtxdg/libqtxdg-1.1.0.ebuild b/dev-libs/libqtxdg/libqtxdg-1.1.0.ebuild
new file mode 100644
index 000000000000..ec0b34b30d5a
--- /dev/null
+++ b/dev-libs/libqtxdg/libqtxdg-1.1.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-utils
+
+DESCRIPTION="A Qt implementation of XDG standards"
+HOMEPAGE="http://lxqt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://git.lxde.org/git/lxde/${PN}.git"
+else
+ SRC_URI="http://downloads.lxqt.org/${PN}/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="test"
+
+CDEPEND="
+ sys-apps/file
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+"
+DEPEND="${CDEPEND}
+ test? ( dev-qt/qttest:5 )
+"
+RDEPEND="${CDEPEND}
+ x11-misc/xdg-utils
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_QT5=ON
+ $(cmake-utils_use test BUILD_TESTS)
+ )
+ cmake-utils_src_configure
+}
diff --git a/dev-libs/libqtxdg/libqtxdg-1.2.0.ebuild b/dev-libs/libqtxdg/libqtxdg-1.2.0.ebuild
new file mode 100644
index 000000000000..a5ab28b27aa6
--- /dev/null
+++ b/dev-libs/libqtxdg/libqtxdg-1.2.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-utils
+
+DESCRIPTION="A Qt implementation of XDG standards"
+HOMEPAGE="http://lxqt.org/"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://git.lxde.org/git/lxde/${PN}.git"
+else
+ SRC_URI="http://downloads.lxqt.org/${PN}/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="test"
+
+CDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig
+ test? ( dev-qt/qttest:5 )
+"
+RDEPEND="${CDEPEND}
+ x11-misc/xdg-utils
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_QT4=OFF
+ $(cmake-utils_use_build test TESTS)
+ )
+ cmake-utils_src_configure
+}
diff --git a/dev-libs/libqtxdg/metadata.xml b/dev-libs/libqtxdg/metadata.xml
new file mode 100644
index 000000000000..2b2f83827853
--- /dev/null
+++ b/dev-libs/libqtxdg/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>lxqt</herd>
+ <herd>qt</herd>
+</pkgmetadata>