summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2020-06-30 09:48:24 -0400
committerCraig Andrews <candrews@gentoo.org>2020-06-30 09:51:25 -0400
commitcb3fc5f3341d4e17ee2fe15c3935e91b4137ce0f (patch)
tree32f39e505784502d12236b6c09277aa55c801995 /dev-libs/libudfread/libudfread-1.1.0.ebuild
parentsys-kernel/linux-firmware: Use "main" branch instead of default "master" (diff)
downloadgentoo-cb3fc5f3341d4e17ee2fe15c3935e91b4137ce0f.tar.gz
gentoo-cb3fc5f3341d4e17ee2fe15c3935e91b4137ce0f.tar.bz2
gentoo-cb3fc5f3341d4e17ee2fe15c3935e91b4137ce0f.zip
dev-libs/libudfread: 1.1.0 version bump
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'dev-libs/libudfread/libudfread-1.1.0.ebuild')
-rw-r--r--dev-libs/libudfread/libudfread-1.1.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-libs/libudfread/libudfread-1.1.0.ebuild b/dev-libs/libudfread/libudfread-1.1.0.ebuild
new file mode 100644
index 000000000000..6dd66e41c5cd
--- /dev/null
+++ b/dev-libs/libudfread/libudfread-1.1.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools multilib-minimal
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://code.videolan.org/videolan/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://code.videolan.org/videolan/libudfread/-/archive/${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Library for reading UDF from raw devices and image files"
+HOMEPAGE="https://code.videolan.org/videolan/libudfread/"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+IUSE="static-libs"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf
+}
+
+multilib_src_install_all() {
+ find "${D}" -name '*.la' -delete || die
+ if ! use static-libs ; then
+ find "${D}" -name '*.a' -delete || die
+ fi
+}