summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOz N Tiram <oz.tiram@gmail.com>2021-03-15 22:42:49 +0100
committerJoonas Niilola <juippis@gentoo.org>2021-03-16 08:42:54 +0200
commitafa144c79717ef606ec5d2452b30cc33a298a127 (patch)
treebf50a3ec0b9b9ed0892b37a88462dd06e07d24e9 /dev-libs/libuev
parentdev-libs/libuev: drop 2.2.0 (diff)
downloadgentoo-afa144c79717ef606ec5d2452b30cc33a298a127.tar.gz
gentoo-afa144c79717ef606ec5d2452b30cc33a298a127.tar.bz2
gentoo-afa144c79717ef606ec5d2452b30cc33a298a127.zip
dev-libs/libuev: bump version to 2.3.2
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Oz Tiram <oz.tiram@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/19944 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-libs/libuev')
-rw-r--r--dev-libs/libuev/Manifest1
-rw-r--r--dev-libs/libuev/libuev-2.3.2.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-libs/libuev/Manifest b/dev-libs/libuev/Manifest
index 04b416120968..f86427927bda 100644
--- a/dev-libs/libuev/Manifest
+++ b/dev-libs/libuev/Manifest
@@ -1,2 +1,3 @@
DIST libuev-2.3.0.tar.xz 247932 BLAKE2B dea136cbd34788b7156a5ce1b8390467fde77a21b6fb4c7b27068b87254eb42034579bcaed3228dcfacd00b320668db915557230ebbb8da9487ade2359a5fabe SHA512 dc6cd2d1df5336027d8df77fda17b9d9521d955ffa013a5e83958d6b4f981f14f5b0caac3e68e4fa4a8a00bbe8001a18de54ebc441b4231a2d17600c762f80d2
DIST libuev-2.3.1.tar.xz 247596 BLAKE2B b2d6a7034aa27a80c17438e4329cba59bc4f047b2879662f9900e886f13a948f2c507732d5c5a4abbb130e42af9ba8a935724d1542f3c929a60198889ac7cce9 SHA512 bd463604a89f5bd3e749375f450b376ed1d57b1195b69a5bcfd247fe92c4d42d245bbce9a7950f5aa5a13ce75abeeee028073b7d4356b7770d8821aa501113a9
+DIST libuev-2.3.2.tar.xz 247784 BLAKE2B 30f9ca2d71c2f05173d4c5863e0dce64e7a77987e3472b11ac5f3ecf677712ddc5fe9e9cc9587f73d6a5acfb716d02dfa744bb301d55b834d44e944bf09f3bd0 SHA512 dccf83ea61dd4841d2b7e1e75b8c46f41607b26aeefd49bc3d594d864408a282c2ff4cf6ff84cf596fe3382c02e53631593f12d5b79afd9f2e57fb9d021b60a8
diff --git a/dev-libs/libuev/libuev-2.3.2.ebuild b/dev-libs/libuev/libuev-2.3.2.ebuild
new file mode 100644
index 000000000000..4aa8d00bd3fa
--- /dev/null
+++ b/dev-libs/libuev/libuev-2.3.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A collection of useful BSD APIs"
+HOMEPAGE="https://github.com/troglobit/libuev"
+SRC_URI="https://github.com/troglobit/${PN}/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+src_configure() {
+ econf --enable-static=$(usex static-libs)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+ rm "${D}/usr/share/doc/${PF}/LICENSE" || die
+}