summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <alexey+gentoo@asokolov.org>2023-01-14 09:34:19 +0000
committerYixun Lan <dlan@gentoo.org>2023-01-15 00:03:22 +0800
commitf448871611e3cdeb583b06da70cbc42363457b26 (patch)
tree22538b17ccadb5beee5795161f310ff45181ed3d /dev-libs/mdns
parentmedia-sound/rescrobbled: remove openrc initd file (diff)
downloadgentoo-f448871611e3cdeb583b06da70cbc42363457b26.tar.gz
gentoo-f448871611e3cdeb583b06da70cbc42363457b26.tar.bz2
gentoo-f448871611e3cdeb583b06da70cbc42363457b26.zip
dev-libs/mdns: fix build on musl
Closes: https://bugs.gentoo.org/890790 Closes: https://github.com/gentoo/gentoo/pull/29100 Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'dev-libs/mdns')
-rw-r--r--dev-libs/mdns/files/mdns-1.4.2-timeval.patch12
-rw-r--r--dev-libs/mdns/mdns-1.4.2.ebuild6
2 files changed, 17 insertions, 1 deletions
diff --git a/dev-libs/mdns/files/mdns-1.4.2-timeval.patch b/dev-libs/mdns/files/mdns-1.4.2-timeval.patch
new file mode 100644
index 000000000000..01e46004d0c4
--- /dev/null
+++ b/dev-libs/mdns/files/mdns-1.4.2-timeval.patch
@@ -0,0 +1,12 @@
+https://github.com/mjansson/mdns/pull/69
+
+--- a/mdns.c
++++ b/mdns.c
+@@ -16,6 +16,7 @@
+ #include <netdb.h>
+ #include <ifaddrs.h>
+ #include <net/if.h>
++#include <sys/time.h>
+ #endif
+
+ // Alias some things to simulate recieving data to fuzz library
diff --git a/dev-libs/mdns/mdns-1.4.2.ebuild b/dev-libs/mdns/mdns-1.4.2.ebuild
index 96d4409beaa7..d1d62383e556 100644
--- a/dev-libs/mdns/mdns-1.4.2.ebuild
+++ b/dev-libs/mdns/mdns-1.4.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2022 Gentoo Authors
+# Copyright 2022-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -12,3 +12,7 @@ SRC_URI="https://github.com/mjansson/mdns/archive/refs/tags/${PV}.tar.gz -> ${P}
LICENSE="Unlicense"
SLOT="0"
KEYWORDS="~amd64 ~x86"
+
+PATCHES=(
+ "${FILESDIR}/${P}-timeval.patch"
+)