summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-10-02 18:52:43 +0200
committerHans de Graaff <graaff@gentoo.org>2023-10-02 18:53:27 +0200
commit18f7c3dc5579906aceb8ba0426c9d913519709e9 (patch)
tree86c969679f9d3b00c7f86b413070e560f3f7300c /dev-libs/protobuf-c/protobuf-c-1.4.0-r1.ebuild
parentdev-util/maturin: add 1.3.0 (diff)
downloadgentoo-18f7c3dc5579906aceb8ba0426c9d913519709e9.tar.gz
gentoo-18f7c3dc5579906aceb8ba0426c9d913519709e9.tar.bz2
gentoo-18f7c3dc5579906aceb8ba0426c9d913519709e9.zip
dev-libs/protobuf-c: drop 1.4.0-r1
Bug: https://bugs.gentoo.org/904423 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-libs/protobuf-c/protobuf-c-1.4.0-r1.ebuild')
-rw-r--r--dev-libs/protobuf-c/protobuf-c-1.4.0-r1.ebuild53
1 files changed, 0 insertions, 53 deletions
diff --git a/dev-libs/protobuf-c/protobuf-c-1.4.0-r1.ebuild b/dev-libs/protobuf-c/protobuf-c-1.4.0-r1.ebuild
deleted file mode 100644
index 8e8ab4e49d70..000000000000
--- a/dev-libs/protobuf-c/protobuf-c-1.4.0-r1.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools multilib-minimal
-
-MY_PV="${PV/_/-}"
-MY_P="${PN}-${MY_PV}"
-
-DESCRIPTION="Protocol Buffers implementation in C"
-HOMEPAGE="https://github.com/protobuf-c/protobuf-c"
-SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${MY_PV}/${MY_P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="BSD-2"
-# Subslot == SONAME version
-SLOT="0/1.0.0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-IUSE="static-libs test"
-RESTRICT="!test? ( test )"
-
-BDEPEND=">=dev-libs/protobuf-3:0
- virtual/pkgconfig"
-DEPEND=">=dev-libs/protobuf-3:0=[${MULTILIB_USEDEP}]"
-RDEPEND="${DEPEND}"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.4.0-include-path.patch
-)
-
-src_prepare() {
- default
-
- if ! use test; then
- eapply "${FILESDIR}"/${PN}-1.3.0-no-build-tests.patch
- fi
-
- eautoreconf
-}
-
-multilib_src_configure() {
- local myeconfargs=(
- $(use_enable static-libs static)
- )
-
- ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
-}
-
-multilib_src_install_all() {
- find "${ED}" -name '*.la' -type f -delete || die
- einstalldocs
-}