summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2019-07-31 11:22:09 -0400
committerCraig Andrews <candrews@gentoo.org>2019-08-07 13:38:46 -0400
commitb8ca3b0862eb435d6259550372bb655908123d07 (patch)
tree345f0dc9ede2af8289007258f2a5395f12ec7503 /dev-libs/rocm-hostcall/rocm-hostcall-2.7.0.ebuild
parentdev-libs/rocm-device-libs: Radeon Open Compute Device Libraries (diff)
downloadgentoo-b8ca3b0862eb435d6259550372bb655908123d07.tar.gz
gentoo-b8ca3b0862eb435d6259550372bb655908123d07.tar.bz2
gentoo-b8ca3b0862eb435d6259550372bb655908123d07.zip
dev-libs/rocm-hostcall: Radeon Open Compute hostcall API
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'dev-libs/rocm-hostcall/rocm-hostcall-2.7.0.ebuild')
-rw-r--r--dev-libs/rocm-hostcall/rocm-hostcall-2.7.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-libs/rocm-hostcall/rocm-hostcall-2.7.0.ebuild b/dev-libs/rocm-hostcall/rocm-hostcall-2.7.0.ebuild
new file mode 100644
index 000000000000..848a8f3a5408
--- /dev/null
+++ b/dev-libs/rocm-hostcall/rocm-hostcall-2.7.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/RadeonOpenCompute/ROCm-CompilerSupport/"
+ inherit git-r3
+ S="${WORKDIR}/${P}/lib/hostcall"
+else
+ SRC_URI="https://github.com/RadeonOpenCompute/ROCm-CompilerSupport/archive/roc-${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/ROCm-CompilerSupport-roc-${PV}/lib/hostcall"
+ KEYWORDS="~amd64"
+fi
+PATCHES=(
+ "${FILESDIR}/${P}-install-correctly.patch"
+)
+
+DESCRIPTION="Radeon Open Compute hostcall API"
+HOMEPAGE="https://github.com/RadeonOpenCompute/ROCm-CompilerSupport"
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+
+RDEPEND="dev-libs/rocr-runtime"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr/"
+ )
+ cmake-utils_src_configure
+}