summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-03-11 21:21:45 -0400
committerSam James <sam@gentoo.org>2024-03-12 02:24:46 +0000
commitdde18ab04c546545dfae709f39d7bf029662a541 (patch)
tree4ac29b9b5dc83b830e8cc3484c4a937d130405ba /dev-libs/rocr-runtime
parentdev-libs/rocr-runtime: remove another sed that doesn't apply (diff)
downloadgentoo-dde18ab04c546545dfae709f39d7bf029662a541.tar.gz
gentoo-dde18ab04c546545dfae709f39d7bf029662a541.tar.bz2
gentoo-dde18ab04c546545dfae709f39d7bf029662a541.zip
dev-libs/rocr-runtime: mark as LTO-unsafe
Closes: https://bugs.gentoo.org/856091 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/rocr-runtime')
-rw-r--r--dev-libs/rocr-runtime/rocr-runtime-5.7.1-r2.ebuild5
-rw-r--r--dev-libs/rocr-runtime/rocr-runtime-6.0.0-r1.ebuild5
2 files changed, 10 insertions, 0 deletions
diff --git a/dev-libs/rocr-runtime/rocr-runtime-5.7.1-r2.ebuild b/dev-libs/rocr-runtime/rocr-runtime-5.7.1-r2.ebuild
index edaaebfdc50f..b22b60ffa24f 100644
--- a/dev-libs/rocr-runtime/rocr-runtime-5.7.1-r2.ebuild
+++ b/dev-libs/rocr-runtime/rocr-runtime-5.7.1-r2.ebuild
@@ -48,6 +48,11 @@ src_prepare() {
}
src_configure() {
+ # -Werror=odr
+ # https://bugs.gentoo.org/856091
+ # https://github.com/ROCm/ROCR-Runtime/issues/182
+ filter-lto
+
use debug || append-cxxflags "-DNDEBUG"
local mycmakeargs=( -DINCLUDE_PATH_COMPATIBILITY=OFF )
cmake_src_configure
diff --git a/dev-libs/rocr-runtime/rocr-runtime-6.0.0-r1.ebuild b/dev-libs/rocr-runtime/rocr-runtime-6.0.0-r1.ebuild
index 02da6889b8cd..374dcec97554 100644
--- a/dev-libs/rocr-runtime/rocr-runtime-6.0.0-r1.ebuild
+++ b/dev-libs/rocr-runtime/rocr-runtime-6.0.0-r1.ebuild
@@ -47,6 +47,11 @@ src_prepare() {
}
src_configure() {
+ # -Werror=odr
+ # https://bugs.gentoo.org/856091
+ # https://github.com/ROCm/ROCR-Runtime/issues/182
+ filter-lto
+
use debug || append-cxxflags "-DNDEBUG"
local mycmakeargs=( -DINCLUDE_PATH_COMPATIBILITY=OFF )
cmake_src_configure