summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Roman <davidroman96@gmail.com>2024-04-26 13:16:44 +0200
committerJoonas Niilola <juippis@gentoo.org>2024-07-03 15:53:32 +0300
commit1d1484a8683f8f9e378fd767be0730ca679df6d0 (patch)
tree8e33c917dc07fca7dfaae55d041b4dfcb2a36453 /dev-libs/spdlog
parentdev-lisp/roswell: 23.10.14.114 (diff)
downloadgentoo-1d1484a8683f8f9e378fd767be0730ca679df6d0.tar.gz
gentoo-1d1484a8683f8f9e378fd767be0730ca679df6d0.tar.bz2
gentoo-1d1484a8683f8f9e378fd767be0730ca679df6d0.zip
dev-libs/spdlog: drop 1.11.0-r3, 1.11.0-r4
Signed-off-by: David Roman <davidroman96@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-libs/spdlog')
-rw-r--r--dev-libs/spdlog/Manifest1
-rw-r--r--dev-libs/spdlog/files/spdlog-fmt-10.patch121
-rw-r--r--dev-libs/spdlog/files/spdlog-musl-1.2.4.patch30
-rw-r--r--dev-libs/spdlog/spdlog-1.11.0-r3.ebuild55
-rw-r--r--dev-libs/spdlog/spdlog-1.11.0-r4.ebuild56
5 files changed, 0 insertions, 263 deletions
diff --git a/dev-libs/spdlog/Manifest b/dev-libs/spdlog/Manifest
index ea3f87cdbd7e..7f30f1758bf2 100644
--- a/dev-libs/spdlog/Manifest
+++ b/dev-libs/spdlog/Manifest
@@ -1,3 +1,2 @@
-DIST spdlog-1.11.0.tar.gz 373033 BLAKE2B a05a535ba55641ecb3bf484eeff902f266bf3967cfbd619234ab0ca2d0c15bddb27b73ce43c33623d02fb046f621933cd52cf39f377f354182d9cdab33340f28 SHA512 210f3135c7af3ec774ef9a5c77254ce172a44e2fa720bf590e1c9214782bf5c8140ff683403a85b585868bc308286fbdeb1c988e4ed1eb3c75975254ffe75412
DIST spdlog-1.12.0.tar.gz 251037 BLAKE2B 3170f1e680fc4652ed8ddc0f74627aec22149f028def599fc5ed4db3a942d840006963789577f2e3df0e2b8ca1d98a881f3b96be5e1174fdf0acea15b3676d6e SHA512 db9a4f13b6c39ffde759db99bcdfe5e2dbe4231e73b29eb906a3fa78d6b8ec66920b8bd4371df17ae21b7b562472a236bc4435678f3af92b6496be090074181d
DIST spdlog-1.13.0.tar.gz 264003 BLAKE2B 8ffeec847f082a0932f406ab44b4653661fdbe95a15f7b736367ee6d8f45ab36ca2182a9e9c6fba5c0688ab5436c16932b130541a8532cc2e5f4980e6340b929 SHA512 44fcb414ad9fbbe2a6d72c29143eeeae477b687ed30ae870d661b032a029ad4214ef43e7ef6350d02791d05504492978ade2d6733fab12ce4884d8f0bc4c6340
diff --git a/dev-libs/spdlog/files/spdlog-fmt-10.patch b/dev-libs/spdlog/files/spdlog-fmt-10.patch
deleted file mode 100644
index 5ee44c41ea6a..000000000000
--- a/dev-libs/spdlog/files/spdlog-fmt-10.patch
+++ /dev/null
@@ -1,121 +0,0 @@
-diff --git a/include/spdlog/sinks/daily_file_sink.h b/include/spdlog/sinks/daily_file_sink.h
-index f6f1bb1d..90af9676 100644
---- a/include/spdlog/sinks/daily_file_sink.h
-+++ b/include/spdlog/sinks/daily_file_sink.h
-@@ -13,6 +13,9 @@
- #include <spdlog/details/circular_q.h>
- #include <spdlog/details/synchronous_factory.h>
-
-+#include <iostream>
-+#include <sstream>
-+#include <iomanip>
- #include <chrono>
- #include <cstdio>
- #include <ctime>
-@@ -46,46 +49,15 @@ struct daily_filename_calculator
- */
- struct daily_filename_format_calculator
- {
-- static filename_t calc_filename(const filename_t &filename, const tm &now_tm)
-+ static filename_t calc_filename(const filename_t &file_path, const tm &now_tm)
- {
--#ifdef SPDLOG_USE_STD_FORMAT
-- // adapted from fmtlib: https://github.com/fmtlib/fmt/blob/8.0.1/include/fmt/chrono.h#L522-L546
--
-- filename_t tm_format;
-- tm_format.append(filename);
-- // By appending an extra space we can distinguish an empty result that
-- // indicates insufficient buffer size from a guaranteed non-empty result
-- // https://github.com/fmtlib/fmt/issues/2238
-- tm_format.push_back(' ');
--
-- const size_t MIN_SIZE = 10;
-- filename_t buf;
-- buf.resize(MIN_SIZE);
-- for (;;)
-- {
-- size_t count = strftime(buf.data(), buf.size(), tm_format.c_str(), &now_tm);
-- if (count != 0)
-- {
-- // Remove the extra space.
-- buf.resize(count - 1);
-- break;
-- }
-- buf.resize(buf.size() * 2);
-- }
--
-- return buf;
-+#if defined(_WIN32) && defined(SPDLOG_WCHAR_FILENAMES)
-+ std::wstringstream stream;
- #else
-- // generate fmt datetime format string, e.g. {:%Y-%m-%d}.
-- filename_t fmt_filename = fmt::format(SPDLOG_FMT_STRING(SPDLOG_FILENAME_T("{{:{}}}")), filename);
--
-- // MSVC doesn't allow fmt::runtime(..) with wchar, with fmtlib versions < 9.1.x
--# if defined(_MSC_VER) && defined(SPDLOG_WCHAR_FILENAMES) && FMT_VERSION < 90101
-- return fmt::format(fmt_filename, now_tm);
--# else
-- return fmt::format(SPDLOG_FMT_RUNTIME(fmt_filename), now_tm);
--# endif
--
-+ std::stringstream stream;
- #endif
-+ stream << std::put_time(&now_tm, file_path.c_str());
-+ return stream.str();
- }
-
- private:
-diff --git a/include/spdlog/logger.h b/include/spdlog/logger.h
-index 71544e84..1d802f32 100644
---- a/include/spdlog/logger.h
-+++ b/include/spdlog/logger.h
-@@ -369,9 +369,9 @@ protected:
- {
- memory_buf_t buf;
- #ifdef SPDLOG_USE_STD_FORMAT
-- fmt_lib::vformat_to(std::back_inserter(buf), fmt, fmt_lib::make_format_args(std::forward<Args>(args)...));
-+ fmt_lib::vformat_to(std::back_inserter(buf), fmt, fmt_lib::make_format_args(args...));
- #else
-- fmt::vformat_to(fmt::appender(buf), fmt, fmt::make_format_args(std::forward<Args>(args)...));
-+ fmt::vformat_to(fmt::appender(buf), fmt, fmt::make_format_args(args...));
- #endif
-
- details::log_msg log_msg(loc, name_, lvl, string_view_t(buf.data(), buf.size()));
-@@ -395,10 +395,9 @@ protected:
- // format to wmemory_buffer and convert to utf8
- wmemory_buf_t wbuf;
- # ifdef SPDLOG_USE_STD_FORMAT
-- fmt_lib::vformat_to(
-- std::back_inserter(wbuf), fmt, fmt_lib::make_format_args<fmt_lib::wformat_context>(std::forward<Args>(args)...));
-+ fmt_lib::vformat_to(std::back_inserter(wbuf), fmt, fmt_lib::make_format_args<fmt_lib::wformat_context>(args...));
- # else
-- fmt::vformat_to(std::back_inserter(wbuf), fmt, fmt::make_format_args<fmt::wformat_context>(std::forward<Args>(args)...));
-+ fmt::vformat_to(std::back_inserter(wbuf), fmt, fmt::make_format_args<fmt::wformat_context>(args...));
- # endif
-
- memory_buf_t buf;
-diff --git a/include/spdlog/common.h b/include/spdlog/common.h
-index e69201a8..5f671c5c 100644
---- a/include/spdlog/common.h
-+++ b/include/spdlog/common.h
-@@ -173,12 +173,19 @@ using format_string_t = fmt::format_string<Args...>;
- template<class T>
- using remove_cvref_t = typename std::remove_cv<typename std::remove_reference<T>::type>::type;
-
-+template <typename Char>
-+#if FMT_VERSION >= 90101
-+using fmt_runtime_string = fmt::runtime_format_string<Char>;
-+#else
-+using fmt_runtime_string = fmt::basic_runtime<Char>;
-+#endif
-+
- // clang doesn't like SFINAE disabled constructor in std::is_convertible<> so have to repeat the condition from basic_format_string here,
- // in addition, fmt::basic_runtime<Char> is only convertible to basic_format_string<Char> but not basic_string_view<Char>
- template<class T, class Char = char>
- struct is_convertible_to_basic_format_string
- : std::integral_constant<bool,
-- std::is_convertible<T, fmt::basic_string_view<Char>>::value || std::is_same<remove_cvref_t<T>, fmt::basic_runtime<Char>>::value>
-+ std::is_convertible<T, fmt::basic_string_view<Char>>::value || std::is_same<remove_cvref_t<T>, fmt_runtime_string<Char>>::value>
- {};
-
- # if defined(SPDLOG_WCHAR_FILENAMES) || defined(SPDLOG_WCHAR_TO_UTF8_SUPPORT)
diff --git a/dev-libs/spdlog/files/spdlog-musl-1.2.4.patch b/dev-libs/spdlog/files/spdlog-musl-1.2.4.patch
deleted file mode 100644
index cd1240d36f46..000000000000
--- a/dev-libs/spdlog/files/spdlog-musl-1.2.4.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-https://bugs.gentoo.org/906954
-https://github.com/gabime/spdlog/commit/287a00d364990edbb621fe5e392aeb550135fb96
-
-From 287a00d364990edbb621fe5e392aeb550135fb96 Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Tue, 3 Jan 2023 09:54:50 -0800
-Subject: [PATCH] Do not use LFS64 functions on linux/musl (#2589)
-
-On musl, off_t is 64bit always ( even on 32bit platforms ), therefore
-using LFS64 funcitons is not needed on such platforms. Moreover, musl
-has stopped providing aliases for these functions [1] which means it
-wont compile on newer musl systems. Therefore only use it on 32bit
-glibc/linux platforms and exclude musl like cygwin or OSX
-
-[1] https://git.musl-libc.org/cgit/musl/commit/?id=246f1c811448f37a44b41cd8df8d0ef9736d95f4
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
---- a/include/spdlog/details/os-inl.h
-+++ b/include/spdlog/details/os-inl.h
-@@ -236,8 +236,8 @@ SPDLOG_INLINE size_t filesize(FILE *f)
- # else
- int fd = ::fileno(f);
- # endif
--// 64 bits(but not in osx or cygwin, where fstat64 is deprecated)
--# if (defined(__linux__) || defined(__sun) || defined(_AIX)) && (defined(__LP64__) || defined(_LP64))
-+// 64 bits(but not in osx, linux/musl or cygwin, where fstat64 is deprecated)
-+# if ((defined(__linux__) && defined(__GLIBC__)) || defined(__sun) || defined(_AIX)) && (defined(__LP64__) || defined(_LP64))
- struct stat64 st;
- if (::fstat64(fd, &st) == 0)
- {
-
diff --git a/dev-libs/spdlog/spdlog-1.11.0-r3.ebuild b/dev-libs/spdlog/spdlog-1.11.0-r3.ebuild
deleted file mode 100644
index 508bcb7398b0..000000000000
--- a/dev-libs/spdlog/spdlog-1.11.0-r3.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-DESCRIPTION="Fast C++ logging library"
-HOMEPAGE="https://github.com/gabime/spdlog"
-
-if [[ ${PV} == *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/gabime/${PN}"
-else
- SRC_URI="https://github.com/gabime/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 arm arm64 hppa ~loong ppc ppc64 ~riscv sparc x86"
-fi
-
-LICENSE="MIT"
-SLOT="0/1"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-BDEPEND="
- virtual/pkgconfig
-"
-
-DEPEND="
- dev-libs/libfmt
-"
-
-RDEPEND="${DEPEND}"
-
-PATCHES=(
- "${FILESDIR}/${PN}-force_external_fmt.patch"
- "${FILESDIR}/${PN}-fmt-10.patch"
- "${FILESDIR}/${PN}-musl-1.2.4.patch"
-)
-
-src_prepare() {
- cmake_src_prepare
- rm -r include/spdlog/fmt/bundled || die "Failed to delete bundled libfmt"
-}
-
-src_configure() {
- local mycmakeargs=(
- -DSPDLOG_BUILD_BENCH=no
- -DSPDLOG_BUILD_EXAMPLE=no
- -DSPDLOG_FMT_EXTERNAL=yes
- -DSPDLOG_BUILD_SHARED=yes
- -DSPDLOG_BUILD_TESTS=$(usex test)
- )
-
- cmake_src_configure
-}
diff --git a/dev-libs/spdlog/spdlog-1.11.0-r4.ebuild b/dev-libs/spdlog/spdlog-1.11.0-r4.ebuild
deleted file mode 100644
index 02a505623954..000000000000
--- a/dev-libs/spdlog/spdlog-1.11.0-r4.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake-multilib
-
-DESCRIPTION="Fast C++ logging library"
-HOMEPAGE="https://github.com/gabime/spdlog"
-
-if [[ ${PV} == *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/gabime/${PN}"
-else
- SRC_URI="https://github.com/gabime/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-
-fi
-
-LICENSE="MIT"
-SLOT="0/1"
-IUSE="test static-libs"
-RESTRICT="!test? ( test )"
-
-BDEPEND="
- virtual/pkgconfig
-"
-
-DEPEND="
- >=dev-libs/libfmt-9.1.0-r2[${MULTILIB_USEDEP}]
-"
-
-RDEPEND="${DEPEND}"
-
-PATCHES=(
- "${FILESDIR}/${PN}-force_external_fmt.patch"
- "${FILESDIR}/${PN}-fmt-10.patch"
- "${FILESDIR}/${PN}-musl-1.2.4.patch"
-)
-
-multilib_src_prepare() {
- cmake_src_prepare
- rm -r include/spdlog/fmt/bundled || die "Failed to delete bundled libfmt"
-}
-
-multilib_src_configure() {
- local mycmakeargs=(
- -DSPDLOG_BUILD_BENCH=no
- -DSPDLOG_BUILD_EXAMPLE=no
- -DSPDLOG_FMT_EXTERNAL=yes
- -DSPDLOG_BUILD_SHARED=$(usex static-libs)
- -DSPDLOG_BUILD_TESTS=$(usex test)
- )
-
- cmake_src_configure
-}