summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-10-14 12:14:51 +0200
committerPacho Ramos <pacho@gentoo.org>2018-10-14 12:18:15 +0200
commit5aaeaca38d2f1f8cb0a510200cd90f8255bcf77f (patch)
tree9d38bc0a837a189a3f412c5ff3a0c6be049e7d75 /dev-libs/ucommon
parentapp-arch/lrzip: Drop old (diff)
downloadgentoo-5aaeaca38d2f1f8cb0a510200cd90f8255bcf77f.tar.gz
gentoo-5aaeaca38d2f1f8cb0a510200cd90f8255bcf77f.tar.bz2
gentoo-5aaeaca38d2f1f8cb0a510200cd90f8255bcf77f.zip
dev-libs/ucommon: Bump to 7.0.0
Closes: https://bugs.gentoo.org/596826 Closes: https://bugs.gentoo.org/634680 Closes: https://bugs.gentoo.org/650572 Closes: https://bugs.gentoo.org/663560 Signed-off-by: Pacho Ramos <pacho@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-libs/ucommon')
-rw-r--r--dev-libs/ucommon/Manifest1
-rw-r--r--dev-libs/ucommon/ucommon-7.0.0.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/dev-libs/ucommon/Manifest b/dev-libs/ucommon/Manifest
index de2a4cd6e0e7..a06751e67947 100644
--- a/dev-libs/ucommon/Manifest
+++ b/dev-libs/ucommon/Manifest
@@ -3,3 +3,4 @@ DIST ucommon-6.1.10.tar.gz 833384 BLAKE2B 790d47b529550ab02651ed41954d1f6c171154
DIST ucommon-6.3.1.tar.gz 830661 BLAKE2B be97174c44ad79ed3e526f263da085dbc112c8f5f0b4f8415a5d30ff7f919fea65e1468aeaaf301940ce060952842fc0e59184539c63ba965c01a0cb598dce30 SHA512 6f4832ac53aaf1456f2d913730b66588a89a3c1292fb79f3f56da466a2542af9c836579c0a3c4daf3f896a0c3e35f861b71514f960052adcb4e3abb872b781ec
DIST ucommon-6.5.2.tar.gz 847128 BLAKE2B a4bd6975ad0a83a109a85b5654fbf176957df0bad8edf1a519438c49af00a5523258e97a231021f9a3a3492746b6b6b88aa79600e58bf47b60ac6466b2f4fa12 SHA512 dc6dc048bad52d117edd1936ad31fd9fc6dba418fea3f7fd1578a96909c1eb53d2a42c4773a168db38ff24fc73b467ab30ec9b5ad5132ae473c36cea0e77b341
DIST ucommon-6.5.7.tar.gz 855822 BLAKE2B 56b5eb5f8372f983e0f348e5fc494c15bea57dc711e88a9a9f4ceeb8abf03680a82948ea080053a9d4c846172b64443a3947b3774b50c6d0a60c1f2ced63e69d SHA512 9927c9726252cdf050f217fa5993d34dcf9f76fab8399ee3a4c91cf087d9409947ed486a21e8448cb57ea95b52826682120f99d39287983c306434f9121b4d24
+DIST ucommon-7.0.0.tar.gz 837905 BLAKE2B ddc82d5d1a88d66f353d9e69eacd7cfaaa0204acb8b9c4152559a009d287f2ffdb7feedc6fc0303c93a39d607498dd15bf83798d088857582f79be435d010ca7 SHA512 d32f8603d920eb98b5d4bc75224a7a8bb8bf2001a8dd3152626a8438ea4c39503a7446dec3aa90cf464b7abb68a6e42bac488ef9705517bd333b64bce219915b
diff --git a/dev-libs/ucommon/ucommon-7.0.0.ebuild b/dev-libs/ucommon/ucommon-7.0.0.ebuild
new file mode 100644
index 000000000000..77953319a895
--- /dev/null
+++ b/dev-libs/ucommon/ucommon-7.0.0.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+DESCRIPTION="Portable C++ runtime for threads and sockets"
+HOMEPAGE="https://www.gnu.org/software/commoncpp"
+SRC_URI="mirror://gnu/commoncpp/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0/8" # soname version
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux"
+IUSE="doc static-libs +cxx debug libressl ssl gnutls"
+
+RDEPEND="
+ ssl? (
+ gnutls? (
+ net-libs/gnutls:0=
+ dev-libs/libgcrypt:0=
+ )
+ !gnutls? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
+ )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+DOCS=(README NEWS SUPPORT ChangeLog AUTHORS)
+
+PATCHES=(
+ "${FILESDIR}/${PN}-6.0.3-install_gcrypt.m4_file.patch"
+)
+
+src_prepare() {
+ default
+
+ # Aclocal 1.13 deprecated error BGO #467674
+ sed -e 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/g' -i configure.ac || die
+
+ # don't install latex and rtf documents
+ sed -e '/^GENERATE_LATEX/s@YES@NO@' -e '/^GENERATE_RTF/s@YES@NO@' \
+ -i Doxyfile.in || die
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=""
+ if use ssl; then
+ myconf+=" --with-sslstack=$(usex gnutls gnu ssl) "
+ else
+ myconf+=" --with-sslstack=nossl ";
+ fi
+
+ local myeconfargs=(
+ $(use_enable cxx stdcpp)
+ ${myconf}
+ --enable-atomics
+ --with-pkg-config
+ )
+ econf "${myeconfargs}"
+}
+
+src_compile() {
+ default
+ use doc && emake doxy
+}
+
+src_install() {
+ use doc && HTML_DOCS="doc/html/*"
+ default
+}