summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-08-29 02:49:26 +0100
committerSam James <sam@gentoo.org>2024-08-29 02:49:26 +0100
commit9c4f0326197828dfc3e502c5939232d89bdeb2b7 (patch)
tree1ff1391b549bc63b001fa6515fe11e757c996863 /dev-libs/userspace-rcu
parentsys-apps/rng-tools: add 6.17 (diff)
downloadgentoo-9c4f0326197828dfc3e502c5939232d89bdeb2b7.tar.gz
gentoo-9c4f0326197828dfc3e502c5939232d89bdeb2b7.tar.bz2
gentoo-9c4f0326197828dfc3e502c5939232d89bdeb2b7.zip
dev-libs/userspace-rcu: add 0.14.1
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/userspace-rcu')
-rw-r--r--dev-libs/userspace-rcu/Manifest1
-rw-r--r--dev-libs/userspace-rcu/userspace-rcu-0.14.1.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-libs/userspace-rcu/Manifest b/dev-libs/userspace-rcu/Manifest
index bb9ddf3d1c66..032a94cf1b09 100644
--- a/dev-libs/userspace-rcu/Manifest
+++ b/dev-libs/userspace-rcu/Manifest
@@ -1,2 +1,3 @@
DIST userspace-rcu-0.13.2.tar.bz2 611448 BLAKE2B 6d502e0035b03df262c917ba70f7442e2bd81369091b2c521fe5c32f31ed2ef7404070759f3a8910b767153e05d28e354d5e5ece2a3ba17e4a31dd7db3e1924f SHA512 e5097a7f653f51b3a47a09f79e7a153aab8fd22c0504a1127a9b33d093a9ae6a941b97c0fe175ee168e2976097aefdcdf8d5ce030afbe565c1b72f64d6f5b60a
DIST userspace-rcu-0.14.0.tar.bz2 661322 BLAKE2B ba9fa4c6dec693d2616234187db531f00fc0ade65f7e2a57182d9441728ddfa6f3e9d4544b824ca5edf7c027a43c9231d998a309c01f4bbab1eeefe856344f77 SHA512 7297e51012f4c44ee27c0e18ed9d87bf24be34db68a5398394c1e683a045bb561cf74aa913398404c0ed5cb8011af728ea12947717fa5f27627e5ca78e63a40f
+DIST userspace-rcu-0.14.1.tar.bz2 669999 BLAKE2B 6ae6a98020f731b5dc3bef5e7cf1a0b590087dbaff8836a4d2b694ad8d0d76b298261d99bea4281907cb516980b69c673d80baac17ae244e2f4fe690fc539293 SHA512 46137525854164df05326202909689b62f8f3aa6e04127eb9157a83aed8180f35a68332ec66e4e4fc9b0c046b64c64b492caed4b64f86f87a31579e4209ec345
diff --git a/dev-libs/userspace-rcu/userspace-rcu-0.14.1.ebuild b/dev-libs/userspace-rcu/userspace-rcu-0.14.1.ebuild
new file mode 100644
index 000000000000..aed78ed9c98c
--- /dev/null
+++ b/dev-libs/userspace-rcu/userspace-rcu-0.14.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Userspace RCU (read-copy-update) library"
+HOMEPAGE="https://liburcu.org/"
+SRC_URI="https://lttng.org/files/urcu/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0/8" # subslot = soname version
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="static-libs test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( sys-process/time )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.13.1-tests-no-benchmark.patch
+)
+
+src_prepare() {
+ default
+
+ # Needed for tests patch
+ # ... and refresh libtool (see https://github.com/gentoo/gentoo/pull/23973)
+ # ... and for build on loong (see https://github.com/gentoo/gentoo/pull/25189)
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-shared
+ $(use_enable static-libs static)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_test() {
+ default
+
+ emake -C tests/regression regtest
+
+ # We don't run the benchmark tests.
+ rm tests/benchmark/test-suite.log || die
+}
+
+src_install() {
+ default
+
+ find "${ED}" -type f -name "*.la" -delete || die
+}