summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2018-08-19 23:25:43 +0200
committerMichael Weber <xmw@gentoo.org>2018-08-19 23:25:43 +0200
commit8e0a99479df558044065d9040b535bd7068981c1 (patch)
tree31b017639cd1b59953bc38e62626d47708014c8c /dev-libs/yajl/files
parentapp-text/xmldiff: Version bump, new upstream. (diff)
downloadgentoo-8e0a99479df558044065d9040b535bd7068981c1.tar.gz
gentoo-8e0a99479df558044065d9040b535bd7068981c1.tar.bz2
gentoo-8e0a99479df558044065d9040b535bd7068981c1.zip
dev-libs/yajl: Use EAPI=6, fix build with uclibc (bug 512738).
Thanks a17r and René Rhéaume. Closes: https://github.com/gentoo/gentoo/pull/9620 Closes: https://bugs.gentoo.org/512738 Package-Manager: Portage-2.3.45, Repoman-2.3.10
Diffstat (limited to 'dev-libs/yajl/files')
-rw-r--r--dev-libs/yajl/files/yajl-2.1.0-uclibc.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/dev-libs/yajl/files/yajl-2.1.0-uclibc.patch b/dev-libs/yajl/files/yajl-2.1.0-uclibc.patch
new file mode 100644
index 000000000000..2e6f176de648
--- /dev/null
+++ b/dev-libs/yajl/files/yajl-2.1.0-uclibc.patch
@@ -0,0 +1,14 @@
+diff --git a/reformatter/CMakeLists.txt b/reformatter/CMakeLists.txt
+index da4032b..d48e218 100644
+--- a/reformatter/CMakeLists.txt
++++ b/reformatter/CMakeLists.txt
+@@ -26,7 +26,7 @@ LINK_DIRECTORIES(${CMAKE_CURRENT_BINARY_DIR}/../${YAJL_DIST_NAME}/lib)
+
+ ADD_EXECUTABLE(json_reformat ${SRCS})
+
+-TARGET_LINK_LIBRARIES(json_reformat yajl_s)
++TARGET_LINK_LIBRARIES(json_reformat yajl_s m)
+
+ # copy the binary into the output directory
+ GET_TARGET_PROPERTY(binPath json_reformat LOCATION)
+