summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Eden <sven.eden@prydeworx.com>2020-11-07 16:23:45 +0100
committerAaron Bauman <bman@gentoo.org>2020-11-13 16:31:15 -0500
commit586064fddf3896883ef78ccc55bd28d5d3fcd006 (patch)
tree195ae23bd66db5a60fac41611b33202ea6ddfa2a /dev-libs
parentdev-libs/ustr: Fix compilation using clang/LLVM (diff)
downloadgentoo-586064fddf3896883ef78ccc55bd28d5d3fcd006.tar.gz
gentoo-586064fddf3896883ef78ccc55bd28d5d3fcd006.tar.bz2
gentoo-586064fddf3896883ef78ccc55bd28d5d3fcd006.zip
dev-libs/ustr-1.0.4-r9 : Update to EAPI 7
Signed-off-by: Sven Eden <sven.eden@prydeworx.com> Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/ustr/ustr-1.0.4-r9.ebuild14
1 files changed, 9 insertions, 5 deletions
diff --git a/dev-libs/ustr/ustr-1.0.4-r9.ebuild b/dev-libs/ustr/ustr-1.0.4-r9.ebuild
index 632e404652a4..c3bbc52d9eb9 100644
--- a/dev-libs/ustr/ustr-1.0.4-r9.ebuild
+++ b/dev-libs/ustr/ustr-1.0.4-r9.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
inherit toolchain-funcs multilib-minimal
@@ -11,7 +11,7 @@ SRC_URI="ftp://ftp.and.org/pub/james/ustr/${PV}/${P}.tar.bz2"
LICENSE="|| ( BSD-2 MIT LGPL-2 )"
SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~mips x86"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
IUSE="static-libs ustr-import"
DOCS=(ChangeLog README README-DEVELOPERS AUTHORS NEWS TODO)
@@ -21,9 +21,13 @@ MULTILIB_WRAPPED_HEADERS=(
/usr/include/ustr-conf-debug.h
)
+PATCHES=(
+ "${FILESDIR}/${P}-inline-check.patch"
+ "${FILESDIR}/${PN}-1.0.4-build-libs.patch"
+)
+
src_prepare() {
- epatch "${FILESDIR}/${P}-inline-check.patch"
- epatch "${FILESDIR}/${PN}-1.0.4-build-libs.patch"
+ default
multilib_copy_sources
}