summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernd Waibel <waebbl-gentoo@posteo.net>2022-01-27 07:56:03 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2022-01-27 10:02:34 +0100
commit8fe19e99043699bfc65b164794182aa669cfcafd (patch)
tree3cbfb998cd110d543d29aa6d72cbf02ed50699ea /dev-libs
parentdev-python/pypy: Bump to 7.3.8_rc1 (diff)
downloadgentoo-8fe19e99043699bfc65b164794182aa669cfcafd.tar.gz
gentoo-8fe19e99043699bfc65b164794182aa669cfcafd.tar.bz2
gentoo-8fe19e99043699bfc65b164794182aa669cfcafd.zip
dev-libs/imath: cleanup old v3.1.1
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Bernd Waibel <waebbl-gentoo@posteo.net> Closes: https://github.com/gentoo/gentoo/pull/23978 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/imath/Manifest1
-rw-r--r--dev-libs/imath/imath-3.1.1.ebuild92
2 files changed, 0 insertions, 93 deletions
diff --git a/dev-libs/imath/Manifest b/dev-libs/imath/Manifest
index 02adfd733ca7..5c310d17c92d 100644
--- a/dev-libs/imath/Manifest
+++ b/dev-libs/imath/Manifest
@@ -1,2 +1 @@
-DIST imath-3.1.1.tar.gz 568231 BLAKE2B a1210b5f6ff4723a133d317c2b40338e387973a1409868a218192a53778b86a0912c77911bdf76286a6ed6931175aec38bf24ddc0c76eed3375b7a2945dba124 SHA512 b2f4cc21e44094ef139a1f04bb997c7e41770ff886457fff00d65ca477ba579c86fd5fbd465998c4519855fcb34328ac834d84d0d011f758f56a20ef79e9ca3d
DIST imath-3.1.3.tar.gz 570840 BLAKE2B b037c9bdee87f58c7a2be9dbda52c89c26eba25fe07342710578f9eef4b90a49b9d5dc5451702c960ae94427d7f748b79b81b7fc9ad350d2252e9e4bf6a1d6cc SHA512 a11f5e736bc49098d735c7903f186c15b03efbec082a8cf2e6635546368035cec0d36c7ae64bfd01bd8eeffb2dd247b8dab19e440a3e1fe33008edacc1268f75
diff --git a/dev-libs/imath/imath-3.1.1.ebuild b/dev-libs/imath/imath-3.1.1.ebuild
deleted file mode 100644
index 82fabc71d73a..000000000000
--- a/dev-libs/imath/imath-3.1.1.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit cmake python-single-r1
-
-MY_PN="${PN^}"
-
-DESCRIPTION="Imath basic math package"
-HOMEPAGE="https://imath.readthedocs.io"
-SRC_URI="https://github.com/AcademySoftwareFoundation/${MY_PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
-# re-keywording needed for (according to ilmbase keywords):
-# ~mips ~x64-macos ~x86-solaris
-KEYWORDS="amd64 ~arm arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-LICENSE="BSD"
-SLOT="3/29"
-IUSE="doc large-stack python static-libs test"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-RESTRICT="!test? ( test )"
-
-# blocker due to file collision #803347
-RDEPEND="
- !dev-libs/imath:0
- sys-libs/zlib
- python? (
- ${PYTHON_DEPS}
- $(python_gen_cond_dep '
- dev-libs/boost:=[python,${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- ')
- )
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- virtual/pkgconfig
- doc? ( $(python_gen_cond_dep 'dev-python/breathe[${PYTHON_USEDEP}]') )
- python? ( ${PYTHON_DEPS} )
-"
-
-PATCHES=( "${FILESDIR}"/${P}-0001-changes-needed-for-proper-slotting.patch )
-DOCS=( CHANGES.md CONTRIBUTORS.md README.md SECURITY.md docs/PortingGuide2-3.md )
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_configure() {
- local majorver=$(ver_cut 1)
-
- local mycmakeargs=(
- -DBUILD_SHARED_LIBS=$(usex !static-libs)
- -DIMATH_ENABLE_LARGE_STACK=$(usex large-stack)
- -DIMATH_HALF_USE_LOOKUP_TABLE=ON
- -DIMATH_INSTALL_PKG_CONFIG=ON
- -DIMATH_OUTPUT_SUBDIR="${MY_PN}-${majorver}"
- -DIMATH_USE_CLANG_TIDY=OFF
- -DIMATH_USE_NOEXCEPT=ON
- )
- if use python; then
- mycmakeargs+=(
- # temp. disable for finding libboost_python310, #803032
- #-DBoost_NO_BOOST_CMAKE=OFF
- -DPYTHON=ON
- -DPython3_EXECUTABLE="${PYTHON}"
- -DPython3_INCLUDE_DIR=$(python_get_includedir)
- -DPython3_LIBRARY=$(python_get_library_path)
- )
- fi
-
- cmake_src_configure
-}
-
-src_compile() {
- cmake_src_compile
-
- if use doc; then
- pushd "${S}"/docs 2>/dev/null || die
- doxygen || die
- emake html
- popd 2>/dev/null || die
- fi
-}
-
-src_install() {
- use doc && HTML_DOCS=( "${S}/docs/_build/html/." )
- cmake_src_install
-}