summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-11-14 21:18:10 +0100
committerDavid Seifert <soap@gentoo.org>2020-11-14 21:18:10 +0100
commit9e03b4ce88a3680dcb5ac1228161d8aa3f576b3d (patch)
treee9e7d1e908cde0333c7ffed45e610fc6e305141c /dev-libs
parentdev-lang/open-cobol: disable static libs (diff)
downloadgentoo-9e03b4ce88a3680dcb5ac1228161d8aa3f576b3d.tar.gz
gentoo-9e03b4ce88a3680dcb5ac1228161d8aa3f576b3d.tar.bz2
gentoo-9e03b4ce88a3680dcb5ac1228161d8aa3f576b3d.zip
dev-libs/bareos-fastlzlib: disable static libs
Closes: https://bugs.gentoo.org/726930 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/bareos-fastlzlib/bareos-fastlzlib-0_pre20150524.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/dev-libs/bareos-fastlzlib/bareos-fastlzlib-0_pre20150524.ebuild b/dev-libs/bareos-fastlzlib/bareos-fastlzlib-0_pre20150524.ebuild
index b748fee355af..e657d1537775 100644
--- a/dev-libs/bareos-fastlzlib/bareos-fastlzlib-0_pre20150524.ebuild
+++ b/dev-libs/bareos-fastlzlib/bareos-fastlzlib-0_pre20150524.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -21,8 +21,12 @@ RDEPEND="${DEPEND}
S="${WORKDIR}/fastlzlib-master"
+src_configure() {
+ econf --disable-static
+}
+
src_install() {
emake DESTDIR="${D}" install
- find "${D}" -name '*.la' -delete
+ find "${ED}" -name '*.la' -delete || die
find "${D}" -type d -name libfastlz -exec rm -rf {} +
}